E90Post
 


Extreme Power House
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > Help!! Car Problems~Limp mode & Valve Problem??



Reply
 
Thread Tools Search this Thread
      07-10-2013, 03:11 PM   #23
ska///235i
***** noob
ska///235i's Avatar
United_States
194
Rep
9,237
Posts

 
Drives: M235i
Join Date: Sep 2005
Location: Boston

iTrader: (32)

Garage List
2006 325xi  [0.00]
They can tell you this and that, doesnt matter....either you tow it to another shop or tow in home for diy.
Appreciate 0
      07-10-2013, 09:26 PM   #24
1AddictsAnonymous
Second Lieutenant
1AddictsAnonymous's Avatar
Canada
5
Rep
240
Posts

 
Drives: 08 135i M Sport 6MT
Join Date: Feb 2013
Location: Edmonton

iTrader: (2)

Garage List
2008 BMW 135i  [0.00]
Yeah get it out of that shop. Also BMS is a piggyback system so no, resetting DME or ECU will not prevent it from working
__________________
2008 Sedona Red 135i ///M Sport
Alarm Retrofit | Misc. Coding | Carbon Interior Trim | Custom Red Interior Stitching
Year One of the 1

Appreciate 0
      07-10-2013, 09:50 PM   #25
Delusive
Lieutenant Colonel
Delusive's Avatar
United_States
27
Rep
1,502
Posts

 
Drives: Static E92
Join Date: May 2012
Location: Bay Area, CA

iTrader: (6)

I can read codes for you if your near Daly City so you can actually figure out whats the problem with your car then take it into an indy shop since you'll know what needs to be done or if its an easy fix DIY at home.
__________________
Appreciate 0
      07-11-2013, 03:32 PM   #26
Murdered
Private
1
Rep
67
Posts

 
Drives: BMW 328xi
Join Date: Nov 2010
Location: Bay Area

iTrader: (0)

Garage List
2007 BMW 328xi  [0.00]
Update: So the mechanic disconnected the BMW box from the car and ran new tests and the error codes that are now coming back is a bad gas pedal. They say there 100% positive on it so they are going to replace the gas pedal tomorrow. Hopefully in time for my first car rally.

Fingers crossed
Appreciate 0
      07-12-2013, 02:48 PM   #27
TSM330i
2006 330i, TSM, Black, manual, sport
TSM330i's Avatar
United_States
74
Rep
3,134
Posts

 
Drives: E90 330i, E86 Z4 3.0si
Join Date: Nov 2005
Location: Chester Springs, PA

iTrader: (2)

Quote:
Originally Posted by Murdered View Post
Update: So the mechanic disconnected the BMW box from the car and ran new tests and the error codes that are now coming back is a bad gas pedal. They say there 100% positive on it so they are going to replace the gas pedal tomorrow. Hopefully in time for my first car rally.

Fingers crossed
Like I said, they're guessing. It keeps changing.
If it's not the gas pedal, make sure they put the original one back in and you're not charged for it. Pay the "analysis" fee and get that car out of there.
__________________
2006 330i, TSM, Black, Sport, JIC Cross Coil-Overs, UUC Sways, 18" Advan RS, Mich PSS 255/265, BMW Electric Steering Wheel, Rogue shifter, M-Tech front, CF emblems, Dinan TB, Intake, exhaust, strut bar, Stoptech BBK, LSD, M3 susp., LUX 5, CF Hood and CSL, Sparco Seats, AA tune, CF Roof
Appreciate 0
      07-12-2013, 03:14 PM   #28
Maestro
Captain
44
Rep
905
Posts

 
Drives: 2007 335i Sedan
Join Date: Nov 2006
Location: Philadelphia

iTrader: (0)

I will tell you, when I had my issue it took 3 visits from a BMW service engineer and 5 weeks to figure out what was going on. The BMW dealer could not figure it out on their own. It first threw the Valvetronic codes and they replace the solenoid, then it threw more codes, and they replaced more things. In the end they told me they ended up replacing the entire top end since the cam and rocker arms guilds worn unevenly (which they claim was known issue on some cars). They never fully told me what the issue was, nor did the service report indicated what they did, It just said warrant repair of VANOS. I do know they also did software upgrades and they put in a none release version of the software, which eventually got replace with a future release.

My point is this, some time the problems are more complicated than most mechanics can deal with especially if they never saw it before and only relying on the codes.

Realize my issue all started because my son kept bucking the engine trying to start from a stand still. Make no sense that all of sudden the car is throwing codes and kept going into limp mode.

Last edited by Maestro; 07-15-2013 at 11:39 AM.
Appreciate 0
      07-12-2013, 04:12 PM   #29
Murdered
Private
1
Rep
67
Posts

 
Drives: BMW 328xi
Join Date: Nov 2010
Location: Bay Area

iTrader: (0)

Garage List
2007 BMW 328xi  [0.00]
Good to know, thanks for the input. I'm getting a call back from the mechanic in about an hour and if the problem isn't fixed im gunna take her somewhere else.

Thanks agian.
Appreciate 0
      07-12-2013, 07:43 PM   #30
Murdered
Private
1
Rep
67
Posts

 
Drives: BMW 328xi
Join Date: Nov 2010
Location: Bay Area

iTrader: (0)

Garage List
2007 BMW 328xi  [0.00]
Ok, so they installed the gas pedal and now the car wont even start. So f*cking pissed. Goodbye GG2h and possibly my car.... Having them reinstall my old gas pedal and having the car towed to a BMW dealership.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:34 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST