E90Post
 


 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > UK > UK Technical Forum > DSC Failure?



Reply
 
Thread Tools Search this Thread
      10-13-2013, 02:58 AM   #23
bmwm-power
Private
 
Drives: BMW E90 320d M Sport Auto
Join Date: Jun 2011
Location: BIRMINGHAM

Posts: 60
iTrader: (0)

litany

dont know what the number of the dsc unit is mate. havent looked at it..where will it be printed?
bmwm-power is offline   United Kingdom
0
Reply With Quote
      10-13-2013, 03:27 AM   #24
wev666
Registered
 
Drives: 335i 6MT
Join Date: Oct 2013
Location: Notts, UK

Posts: 2
iTrader: (0)

Hi all,

I have exactly the same thing happen last week, purchased a cable and software from BM cables and loaded inpa to an old laptop, DSC pump failure, Ive looked at ECU testing and am happy to do the work myself, but unsure of the bleeding procedure (even after reading numerous threads on the subject) I need to get my head round how its done before I attempt the work myself, cant afford to be off the road more than a week and cant afford the BMW stealer prices!

Any help appreciated.... (sorry for jumping on your thread OP).
wev666 is offline  
0
Reply With Quote
      10-13-2013, 06:04 AM   #25
litany
Private
 
Drives: e92 330dA M57NA
Join Date: Sep 2012
Location: Southampton

Posts: 52
iTrader: (2)

Quote:
Originally Posted by bmwm-power View Post
litany

dont know what the number of the dsc unit is mate. havent looked at it..where will it be printed?
Hi, dsc unit is on driver's side behind engine bay. You have to remove a black cover. Number is printed on side of unit and is very hard to read, so use a small mirror.
litany is offline   United Kingdom
0
Reply With Quote
      10-13-2013, 06:14 AM   #26
litany
Private
 
Drives: e92 330dA M57NA
Join Date: Sep 2012
Location: Southampton

Posts: 52
iTrader: (2)

Quote:
Originally Posted by wev666 View Post
Hi all,

I have exactly the same thing happen last week, purchased a cable and software from BM cables and loaded inpa to an old laptop, DSC pump failure, Ive looked at ECU testing and am happy to do the work myself, but unsure of the bleeding procedure (even after reading numerous threads on the subject) I need to get my head round how its done before I attempt the work myself, cant afford to be off the road more than a week and cant afford the BMW stealer prices!

Any help appreciated.... (sorry for jumping on your thread OP).
I fixed my dsc myself according to errors below:
5DF0 - pump motor
5DF1 - pump motor connector faulty
litany is offline   United Kingdom
0
Reply With Quote
      10-20-2013, 05:35 AM   #27
bmwm-power
Private
 
Drives: BMW E90 320d M Sport Auto
Join Date: Jun 2011
Location: BIRMINGHAM

Posts: 60
iTrader: (0)

hi, quick update, went and bought the dsc repair kit for my car, my mechanic quoted reg to the dealers and asked for repair kit.
i went and picked it up as he said i could pay for it on his trade account
cost me 174.01 with the discount (was quoted 193)
the part number given to me was b34.51.6.797.896 (my car is a 2007 57 plate 320d m sport E90. 163bhp engine model)
booked in tomorow to fit fo hopefully should be all sorted. could have attempted it myself but didnt was to mess with beeling brakes or the coding part especially seeing as its safety critical and theres no room for error!
bmwm-power is offline   United Kingdom
0
Reply With Quote
      10-20-2013, 12:02 PM   #28
oldbilly
Second Lieutenant
 
Drives: 330d e91 M Sport
Join Date: Apr 2012
Location: cambridgeshire

Posts: 215
iTrader: (2)

Quote:
Originally Posted by oldbilly View Post
another update, still having the error lights coming up, also the yellow battery light, went back and had the codes read resulting in the same number of codes including battery and junction box electrics so installed a new battery and on its 1st run today brought up the same errors!
when I returned home I checked the main cable into the junction/fuse box and looks ok, but a relay fitted next the power cable felt quite warm, I'm now wondering if the relay may be the problem?
I have now fitted a brand new n/s/f abs speed sensor and since then no lights hopefully its now rectified and will monitor this over the next few days.
oldbilly is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:24 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST