E90Post
 


Lux Angel Eyes
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > Help Electric Issues



Reply
 
Thread Tools Search this Thread
      11-08-2013, 10:04 AM   #1
Red Ice BMW
Private
 
Drives: BMW E92 325D
Join Date: Jun 2012
Location: UK

Posts: 98
iTrader: (0)

Help Electric Issues

Hi guys,

I've recently started having some electrical faults and just want to know if anyones had similar and can advise.

About 2-3 months ago when leaving the key in the ignition after a minute or less the battery warning light would come on, then a few weeks ago when unlocking the car the welcome lights (angel eyes) stopped lighting up. Now in the last few days it seems like the rear window demister has stopped working and the climate heaters take an age to heat up compared to a week or two ago. Also the dash lights etc. were set at the brightest level by me and now each time I get in the car they have reset to half way. Its almost like the car is in power save mode.

I've done the battery voltage test and with ignition running I get between 14.2 and 14.9, with ignition off the battery is around 12.5 and 13.5. To me this is normal for the battery.

Any suggestions guys? Going to an auto electrician next week but just thought I'd check of anyones had similar.

Thanks
Red Ice BMW is offline   Scotland
0
Reply With Quote
      11-08-2013, 01:21 PM   #2
Red Ice BMW
Private
 
Drives: BMW E92 325D
Join Date: Jun 2012
Location: UK

Posts: 98
iTrader: (0)

TTT
Red Ice BMW is offline   Scotland
0
Reply With Quote
      11-08-2013, 02:23 PM   #3
Tom K.
Major General
 
Tom K.'s Avatar
 
Drives: '07 328iT, '13 Boxster
Join Date: Mar 2008
Location: Maryland

Posts: 5,377
iTrader: (0)

On my '07, similar issues were the result of a bad IBS. Also, was your car subject to last year's cable recall?

Tom
Tom K. is offline   United_States
0
Reply With Quote
      11-08-2013, 03:10 PM   #4
Red Ice BMW
Private
 
Drives: BMW E92 325D
Join Date: Jun 2012
Location: UK

Posts: 98
iTrader: (0)

Quote:
Originally Posted by Tom K.
On my '07, similar issues were the result of a bad IBS. Also, was your car subject to last year's cable recall?

Tom
Hi mate, not had any recalls as far as I'm aware. Whats IBS? Is that an expensive cable? Thanks for replying
Red Ice BMW is offline   Scotland
0
Reply With Quote
      11-08-2013, 03:37 PM   #5
GoRomeo
Colonel
 
GoRomeo's Avatar
 
Drives: 330i
Join Date: Feb 2006
Location: San Diego CA

Posts: 2,306
iTrader: (0)

Garage List
2006 330i  [2.83]
Just because you are reading voltage on battery does not mean your bettery retains the charge. The reading you are getting is the voltage from alternator which is only showing the charging system is working ok. There should be an eye hole on top of battery which shows condition, what color is it?

Do a load test on your battery and replace. Most likey is your battery if you have not replaced it yet. Good luck!
GoRomeo is online now  
0
Reply With Quote
      11-08-2013, 03:42 PM   #6
Tom K.
Major General
 
Tom K.'s Avatar
 
Drives: '07 328iT, '13 Boxster
Join Date: Mar 2008
Location: Maryland

Posts: 5,377
iTrader: (0)

Quote:
Originally Posted by Red Ice BMW View Post
Hi mate, not had any recalls as far as I'm aware. Whats IBS? Is that an expensive cable? Thanks for replying
The IBS (Intelligent Battery Sensor) is contained within the negative cable and communicates with the alternator to provide the proper charge. It is the reason that a new battery must be "registered" to facilitate that communication.

The recall affected many E9x models in the US and involved the positive cable connection, IIRC. You might check with your dealer to find out if your car was included.

And GoRomeo makes a lot of sense - especially if your battery is more than 5 years old.

Good luck in sorting out your issues.

Tom
Tom K. is offline   United_States
0
Reply With Quote
      11-08-2013, 05:30 PM   #7
PichaDis11
Captain
 
PichaDis11's Avatar
 
Drives: 08 328i
Join Date: Mar 2013
Location: NY

Posts: 904
iTrader: (3)

Quote:
Originally Posted by GoRomeo View Post
Just because you are reading voltage on battery does not mean your bettery retains the charge. The reading you are getting is the voltage from alternator which is only showing the charging system is working ok. There should be an eye hole on top of battery which shows condition, what color is it?

Do a load test on your battery and replace. Most likey is your battery if you have not replaced it yet. Good luck!
this +1
PichaDis11 is offline   United_States
0
Reply With Quote
      11-08-2013, 05:33 PM   #8
Red Ice BMW
Private
 
Drives: BMW E92 325D
Join Date: Jun 2012
Location: UK

Posts: 98
iTrader: (0)

Thanks guys, most likely is the battery then :-(! How do I do the load test, sorry to sound really silly.

Appreciate it, thanks again!
Red Ice BMW is offline   Scotland
0
Reply With Quote
      11-08-2013, 05:38 PM   #9
GoRomeo
Colonel
 
GoRomeo's Avatar
 
Drives: 330i
Join Date: Feb 2006
Location: San Diego CA

Posts: 2,306
iTrader: (0)

Garage List
2006 330i  [2.83]
Quote:
Originally Posted by Red Ice BMW View Post
Thanks guys, most likely is the battery then :-(! How do I do the load test, sorry to sound really silly.

Appreciate it, thanks again!
Not sure if in the UK Auto parts stores do a free battery test. If so, take your car there and they can do this for you with a battery load tester.

If you replace your battery make sure its the right one and do the registration and coding if needed. There is a lot of info here about it.

Happy reading!
GoRomeo is online now  
0
Reply With Quote
      11-25-2013, 04:10 PM   #10
Red Ice BMW
Private
 
Drives: BMW E92 325D
Join Date: Jun 2012
Location: UK

Posts: 98
iTrader: (0)

Hi all, thanks for the help, replaced the battery and all is well! Now have DPF error :-(
Red Ice BMW is offline   Scotland
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:36 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST