E90Post
 


Alpine HID
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Long crank times and high idle



Reply
 
Thread Tools Search this Thread
      07-29-2013, 05:41 PM   #1
carlsontheflyer
Private
 
carlsontheflyer's Avatar
 
Drives: 2010 335i M-Sport 6MT
Join Date: May 2013
Location: Atlanta, GA, USA

Posts: 80
iTrader: (0)

Long crank times and high idle

About two months ago I began noticing a couple of unusual symptoms.

First I noticed longer crank times in the mornings. They weren't overly long, but longer than usual. Sometimes it seemed like the engine was trying to start, but would stutter and start on the next turn. Once the engine was running everything was fine, no shaking, or misfiring, and no codes at all, at least according to my Cobb AP. Also, if I restarted the engine right after running it, it would start on half a turn, but if the car sat overnight, or for several hours, it would take it longer to start.

Second thing I noticed is higher than usual idle RPM. Once warmed up, my car has always idled around 650 RPM with AC off, but lately I have noticed that once fully warmed up, it idles at 850 RPM. What is strange, is that for the first 20 minutes or so of my drive it idles fine at 650, and the idle jumps up to 850 only AFTER it's fully warmed up and the oil temp reaches 240F or so.

Also, in the past when the AC was turned on, the idle RPM would rise to about 750, which is normal with an added load on the engine, but now, when it's idling at 850 and I turn on the AC, the idle RPM doesn't go up any higher, and I feel a slight vibration, as if the RPMs are too low.

The only mods I have are FMIC, DCI and Cobb flash. I unmarried Cobb from my car and restored it to stock PPK, but there is no difference. And still no codes or errors of any kind.

I took the car to my dealership, since it's still under factory warranty. They've now had the car for 5 days and haven't been able to find anything wrong, or at least that's what the SA told me. For the long crank issue, they for some reason they replaced the starter on the car.
I don't know how good of a diagnostic they performed, but they told me that because I have an aftermarket air filter (aFe DCI), they cannot go any further since the high idle is probably caused by the DCI, and if I want them to do more, I'd have to pay for it...

Did I mention that it's a 2010 car with 38k miles with factory warranty??? And since when does an aftermarket air filter that's been used by thousands of people cause these kinds of issues??? I called BS on that, but they won't budge. And I don't know what to do. I called BMW NA and the idiot on the phone told me that since BMW dealerships are private enterprises, they have the right to refuse to do work under warranty!!!

ARGH!!!!
__________________
Carlson The Flyer | BMW CCA # 423862
2010 e92 335i, Le Mans Blue, Sport, Premium, M-Sport, 3 pedals of course!
Heated Seats | Black Dakota Leather | Cobb FMIC | aFe Stage 2 DCI | Cobb AP |

Last edited by carlsontheflyer; 07-29-2013 at 05:47 PM.
carlsontheflyer is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:51 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST