E90Post
 


 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > UK > oil warning light - but oil level ok??



Reply
 
Thread Tools Search this Thread
      08-06-2013, 10:39 AM   #1
nealer74
Private
 
nealer74's Avatar
 
Drives: E93 M3
Join Date: Sep 2012
Location: Northern Ireland, United Kingdom

Posts: 75
iTrader: (0)

oil warning light - but oil level ok??

When I parked up at Dublin ariport - turned the car off the yellow oil can warning light flashed up, but when i went through the service menu - the check oil function 'ok'

anyone seen this before ... ?

Cheers.
nealer74 is offline  
0
Reply With Quote
      08-06-2013, 10:55 AM   #2
UKF32Dude
-
 
Drives: F32
Join Date: Dec 2008
Location: Earth

Posts: 1,461
iTrader: (0)

Dodgy sensor maybe? Does it give an oil level indication in the DIS/iDrive?
UKF32Dude is offline  
0
Reply With Quote
      08-06-2013, 11:06 AM   #3
nealer74
Private
 
nealer74's Avatar
 
Drives: E93 M3
Join Date: Sep 2012
Location: Northern Ireland, United Kingdom

Posts: 75
iTrader: (0)

was starting to think sensor as well ... didn't show the level in the DIS just reported 'ok' ... no iDrive
nealer74 is offline  
0
Reply With Quote
      08-06-2013, 05:43 PM   #4
UKF32Dude
-
 
Drives: F32
Join Date: Dec 2008
Location: Earth

Posts: 1,461
iTrader: (0)

Quote:
Originally Posted by nealer74 View Post
was starting to think sensor as well ... didn't show the level in the DIS just reported 'ok' ... no iDrive
Doesn't it give a level in DIS? Not familiar with it on 3 series as have iDrive, but mates 1 series has a level/gauge-type thing in DIS. Or I think it does!
UKF32Dude is offline  
0
Reply With Quote
      08-07-2013, 04:55 AM   #5
gaza01
Lieutenant Colonel
 
gaza01's Avatar
 
Drives: E92 335i
Join Date: Dec 2010
Location: London

Posts: 1,815
iTrader: (3)

Not meaning to spook you but if its a doggy sensor then which reading is correct??..the one saying oil level is ok or the one saying u need oil. Best get it checked out asap
gaza01 is offline   United Kingdom
0
Reply With Quote
      08-07-2013, 06:20 AM   #6
xPETEZx
Lieutenant
 
Drives: BMW 325i SE 6MT (E90 LCI)
Join Date: Oct 2012
Location: London

Posts: 533
iTrader: (0)

Was the engine running?

If you select that option while it is not running it wont give you a level.
xPETEZx is online now   United Kingdom
0
Reply With Quote
      08-08-2013, 08:28 AM   #7
nealer74
Private
 
nealer74's Avatar
 
Drives: E93 M3
Join Date: Sep 2012
Location: Northern Ireland, United Kingdom

Posts: 75
iTrader: (0)

thanks for the replies ... got it checked out yesterday ... sensor gone and it needed oil - got the oil, just need to go back for sensor next week.

Whilst it was there I did take a wee spin in a M135 ... ooooooooh what a lovely car.
nealer74 is offline  
0
Reply With Quote
      08-08-2013, 08:30 AM   #8
nealer74
Private
 
nealer74's Avatar
 
Drives: E93 M3
Join Date: Sep 2012
Location: Northern Ireland, United Kingdom

Posts: 75
iTrader: (0)

btw - xPETEZx ... your 100% - thats how they knew it was the sensor (before plugging it in) as it came up 'ok' or just hung when the engine was running.

thanks again.
nealer74 is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:45 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST