E90Post
 


GTB Performance
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > BMW Coding > Dealer updated all modules except EKP & KOMBI, why?



Reply
 
Thread Tools Search this Thread
      08-12-2013, 04:00 PM   #1
Per Hansson
Private
 
Drives: BMW 325 E90 '06
Join Date: Oct 2011
Location: Sweden

Posts: 68
iTrader: (0)

Dealer updated all modules except EKP & KOMBI, why?

Hi, this car belongs to a friend of me, it's an E90 built June 2005
Lately he had some issues with rough idling during cold starts.
I deleted his adaptations using INPA on the "adaptation 2" page using the F6 "All adaptations" button.
I'm not sure if I should also touch the adaptations under the "adaptation 1" page? (He did have his spark plugs replaced by someone who probably did not clear any adaptations...)

While I was in INPA I noticed under the user information field that all modules where updated when he requested a software update through BMW, except his EKP & KOMBI modules.
Now the former really makes me scratch my head because I think that should always be updated together with DDE?
Also strange is the fact that those two modules are separated by a week in their original coding dates in 2005...
Any idea why it is like this? Should it be safe to update these modules with WinKFP?

Here is a printout of his modules using INPA: http://hem.spray.se/hanzzzon/E90/UIF-IDENT.png

Last edited by Per Hansson; 08-13-2013 at 07:27 AM.
Per Hansson is offline   Sweden
0
Reply With Quote
      08-12-2013, 11:25 PM   #2
nate5ks
Captain
 
Drives: 2006 BMW 330xi
Join Date: Nov 2011
Location: Jacksonville Beach, FL

Posts: 604
iTrader: (0)

I've updated Kombi with winkfp. It will need to be coded with expert mode or the gas gauges will not work. EKP I didn't see an update for. It's the fuel pump so probably not much to improve on.
nate5ks is offline   United_States
0
Reply With Quote
      08-13-2013, 12:30 AM   #3
Dracon
BimmerPost Supporting Vendor

 
Drives: 2006 330i E90
Join Date: Apr 2009
Location: Nashville, TN

Posts: 831
iTrader: (12)

Quote:
Originally Posted by Per Hansson View Post
Hi, this car belongs to a friend of me, it's an E90 built June 2005
Lately he had some issues with rough idling during cold starts.
I deleted his adaptations using INPA on the "adaptation 2" page using the F6 "All adaptations" button.
I'm not sure if I should also touch the adaptations under the "adaptation 1" page? (He did have his spark plugs replaced by someone who probably did not clear any adaptations...)

While I was in INPA I noticed under the user information field that all modules where updated when he requested a software update through BMW, except his EKP & KOMBI modules.
Now the former really makes me scratch my head because I think that should always be updated together with DDE?
Also strange is the fact that those two modules are separated by a week in their original coding dates in 2005...
Any idea why it is like this? Should it be safe to update these modules with WinKFP?

Here is a printout of his modules using INPA: http://hem.spray.se/hanzzzon/UIF-IDENT.png
There may not have been an update to flash unto the KOMBI or EKP. I don't think there's ever been a software update for my KOMBI or EKP since my car was built in 04/2005. But everything else has been updated (I'm running 2.49.4 currently).
Dracon is offline   United_States
0
Reply With Quote
      08-13-2013, 03:15 AM   #4
Per Hansson
Private
 
Drives: BMW 325 E90 '06
Join Date: Oct 2011
Location: Sweden

Posts: 68
iTrader: (0)

My car has much later versions of both EKP & KOMBI, do you mean it's because his car is a year older?
On mine I have:
EKP SW-No FSV 5.0.35
KOMBI SW-No FSV 179.65.192

And especially the KOMBI is visually different in the menus on mine after the update was done almost a year ago...
I was thinking that due to his rough idling problems, where he has also had some issues at higher RPM's (just a very brief power loss) that updated fuel pump management might help these issues...
Per Hansson is offline   Sweden
0
Reply With Quote
      08-13-2013, 04:14 AM   #5
Dracon
BimmerPost Supporting Vendor

 
Drives: 2006 330i E90
Join Date: Apr 2009
Location: Nashville, TN

Posts: 831
iTrader: (12)

Quote:
Originally Posted by Per Hansson View Post
My car has much later versions of both EKP & KOMBI, do you mean it's because his car is a year older?
On mine I have:
EKP SW-No FSV 5.0.35
KOMBI SW-No FSV 179.65.192

And especially the KOMBI is visually different in the menus on mine after the update was done almost a year ago...
I was thinking that due to his rough idling problems, where he has also had some issues at higher RPM's (just a very brief power loss) that updated fuel pump management might help these issues...
He may have a different part number for the KOMBI which runs a different software version even if they look the same.

The dealership doesn't get the choose which modules to update. When they hook ISTA/P up to the car, it scans the vehicle and forces them to update every module which ISTA/P detects an update for. They aren't allowed to pick and choose which modules to update.
Dracon is offline   United_States
0
Reply With Quote
      08-13-2013, 04:19 AM   #6
Per Hansson
Private
 
Drives: BMW 325 E90 '06
Join Date: Oct 2011
Location: Sweden

Posts: 68
iTrader: (0)

Interesting, guess we will see later today then
About the adaptations question, does clearing "all adaptations" on the "adaptation 2" page in INPA clear all adaptations or only those in that page?
Per Hansson is offline   Sweden
0
Reply With Quote
      08-13-2013, 02:34 PM   #7
Per Hansson
Private
 
Drives: BMW 325 E90 '06
Join Date: Oct 2011
Location: Sweden

Posts: 68
iTrader: (0)

Tried updating his EKP module using WinKFP now, it updated but the version number did not change, so I guess you where correct and no update is available...
Question: can I somehow check if there exists an updated version without flashing?
I'd like to just verify if his KOMBI module really is the latest version or not...
And any idea about my previous adaptations questions?
Per Hansson is offline   Sweden
0
Reply With Quote
      08-13-2013, 06:06 PM   #8
nate5ks
Captain
 
Drives: 2006 BMW 330xi
Join Date: Nov 2011
Location: Jacksonville Beach, FL

Posts: 604
iTrader: (0)

Using winkfp, select update zusb then select your particular Kombi module. Enter the vin then select program. It will prompt you if you want to update from one software version to the next. If the two numbers indicating software versions are the same then there is no update.
nate5ks is offline   United_States
0
Reply With Quote
      08-14-2013, 02:15 AM   #9
Per Hansson
Private
 
Drives: BMW 325 E90 '06
Join Date: Oct 2011
Location: Sweden

Posts: 68
iTrader: (0)

I went into: "Comfort Mode" > "Enter ZUSB" and typed the ZB number read using INPA under UIF.
That selected the EKM260 ECU family & the ZB number.
Next I pressed "Enter VIN" & typed in the full VIN
Then "Done" & "Program".
But it never said the module was the same version, what should I have done differently?
Here is a screenshot right before pressing "Program"
Per Hansson is offline   Sweden
0
Reply With Quote
      09-09-2013, 01:17 PM   #10
Per Hansson
Private
 
Drives: BMW 325 E90 '06
Join Date: Oct 2011
Location: Sweden

Posts: 68
iTrader: (0)

Quote:
Originally Posted by Per Hansson View Post
...Lately he had some issues with rough idling during cold starts.
I deleted his adaptations using INPA on the "adaptation 2" page using the F6 "All adaptations" button.
I'm not sure if I should also touch the adaptations under the "adaptation 1" page? (He did have his spark plugs replaced by someone who probably did not clear any adaptations...)
A few days later I did delete several adaptations on the "adaptation 1" page aswell because the issues he had remained.
After this his car has been running great for several weeks now

He just called me about a funny thing though, now a few weeks later without changing anything the car has started showing the "check ok" message on every cold start.
Is this normal behavior? He checked the manual but could not find a definitive answer. Also my own E90 does not show "Check OK" unless I invoke it in the menus. Both our cars are without iDrive btw...
Per Hansson is offline   Sweden
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:22 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST