E90Post
 


Extreme Power House
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > Canada > Help GTA people! I have a boost leak



Reply
 
Thread Tools Search this Thread
      08-24-2013, 11:16 AM   #1
Reapur
Second Lieutenant
2
Rep
237
Posts

 
Drives: 2009 135i
Join Date: May 2013
Location: Toronto

iTrader: (0)

Help GTA people! I have a boost leak

Is there anyone in the GTA available today to help me find a boost leak on the cold side of the engine ASAP?

It's small wherever it is, I'm losing about 4psi of boost overall and it's quite audible, also last night the 30FF code popped up. The car had intake valves cleaned Thursday and the leak appeared later that night as the car was fine when I left the shop.
Appreciate 0
      09-11-2013, 04:54 AM   #2
Briancanadiano
Brian335tt
Briancanadiano's Avatar
Canada
11
Rep
868
Posts

 
Drives: BMW 335i premium package 19"ri
Join Date: Aug 2012
Location: Toronto

iTrader: (2)

How do you know if there's a leak? My car only when cold makes a very loud swoosh noise almost as if it had a blow off valve but then once warmed up doesn't do it no more.. Could that be a boost leak?
Appreciate 0
      09-11-2013, 08:00 AM   #3
Reapur
Second Lieutenant
2
Rep
237
Posts

 
Drives: 2009 135i
Join Date: May 2013
Location: Toronto

iTrader: (0)

Quote:
Originally Posted by Briancanadiano
How do you know if there's a leak? My car only when cold makes a very loud swoosh noise almost as if it had a blow off valve but then once warmed up doesn't do it no more.. Could that be a boost leak?
Because it wasn't meeting boost target not to mention u can hear it when you're on it.

It's ok I found it. Hose clamp slid off my FMIC inlet coupler. It's been fixed for ages. This local community is kinda abysmal. I asked for help 3 weeks ago and just got a reply.
Appreciate 0
      09-11-2013, 03:56 PM   #4
marcvtec
Lieutenant Colonel
22
Rep
1,795
Posts

 
Drives: 335i
Join Date: Oct 2006
Location: toronto

iTrader: (0)

That's great,

Next time we will rotate your tires for free a give you a pizza slice.
__________________
COBB Powered, Spec2+, Wavetrac, DCI, Forge DV's, AR catless DP's, AA FMIC, M3 links & Sways, 19' BBS LM's wrapped in PSS, Zimmerman cross drilled rotors, hawk carbon pads, M3 Spoiler, AC roof Spoiler, Aero Lip, Vorsteiner Diffuser, m3 sides, Tinted, And One Happy BMW Driver.
Appreciate 0
      09-11-2013, 04:35 PM   #5
Briancanadiano
Brian335tt
Briancanadiano's Avatar
Canada
11
Rep
868
Posts

 
Drives: BMW 335i premium package 19"ri
Join Date: Aug 2012
Location: Toronto

iTrader: (2)

Ya sometimes people tend to get on the quiet side.
Appreciate 0
      09-11-2013, 04:36 PM   #6
Briancanadiano
Brian335tt
Briancanadiano's Avatar
Canada
11
Rep
868
Posts

 
Drives: BMW 335i premium package 19"ri
Join Date: Aug 2012
Location: Toronto

iTrader: (2)

Quote:
Originally Posted by Reapur View Post
Because it wasn't meeting boost target not to mention u can hear it when you're on it.

It's ok I found it. Hose clamp slid off my FMIC inlet coupler. It's been fixed for ages. This local community is kinda abysmal. I asked for help 3 weeks ago and just got a reply.
Is it bad thing hearing that swoosh sound in the beginning when it's cold ? Sometimes feels like I'm gonna wreck something cuz it's so loud. Thanks for the reply and sorry for the thread jack
Appreciate 0
      09-11-2013, 06:01 PM   #7
Reapur
Second Lieutenant
2
Rep
237
Posts

 
Drives: 2009 135i
Join Date: May 2013
Location: Toronto

iTrader: (0)

Quote:
Originally Posted by marcvtec
That's great,

Next time we will rotate your tires for free
Your attitude pretty much sums up my frustration with this local forum.

There are plenty of online car communities that would offer help at the drop of a hat. The local Toronto bunch seems pretty closed off and non active.

Collective knowledge and corporation forms comradely, friendships and can save everyone a lot of money from not dealing with a dealership.
Appreciate 0
      09-11-2013, 06:04 PM   #8
Reapur
Second Lieutenant
2
Rep
237
Posts

 
Drives: 2009 135i
Join Date: May 2013
Location: Toronto

iTrader: (0)

Quote:
Originally Posted by Briancanadiano
Quote:
Originally Posted by Reapur View Post
Because it wasn't meeting boost target not to mention u can hear it when you're on it.

It's ok I found it. Hose clamp slid off my FMIC inlet coupler. It's been fixed for ages. This local community is kinda abysmal. I asked for help 3 weeks ago and just got a reply.
Is it bad thing hearing that swoosh sound in the beginning when it's cold ? Sometimes feels like I'm gonna wreck something cuz it's so loud. Thanks for the reply and sorry for the thread jack
It's pretty hard to determine what's happening to your car from the description given.

If you have a boost leak you will eventually throw a 30FF code indicating there's a boost leak. If you don't have a code and you're not down on power then it's unlikely you have one.
Appreciate 0
      09-11-2013, 06:42 PM   #9
Briancanadiano
Brian335tt
Briancanadiano's Avatar
Canada
11
Rep
868
Posts

 
Drives: BMW 335i premium package 19"ri
Join Date: Aug 2012
Location: Toronto

iTrader: (2)

Quote:
Originally Posted by Reapur View Post
It's pretty hard to determine what's happening to your car from the description given.

If you have a boost leak you will eventually throw a 30FF code indicating there's a boost leak. If you don't have a code and you're not down on power then it's unlikely you have one.
Just on cold start if I push down on the accelerator as soon as I shift it'll make a very loud swoosh like air bursting noise... Only when it's cold though...
Appreciate 0
      09-11-2013, 06:43 PM   #10
Reapur
Second Lieutenant
2
Rep
237
Posts

 
Drives: 2009 135i
Join Date: May 2013
Location: Toronto

iTrader: (0)

Quote:
Originally Posted by Briancanadiano
Quote:
Originally Posted by Reapur View Post
It's pretty hard to determine what's happening to your car from the description given.

If you have a boost leak you will eventually throw a 30FF code indicating there's a boost leak. If you don't have a code and you're not down on power then it's unlikely you have one.
Just on cold start if I push down on the accelerator as soon as I shift it'll make a very loud swoosh like air bursting noise... Only when it's cold though...
Try recording a video and uploading it to YouTube to show the problem
Appreciate 0
      09-11-2013, 07:21 PM   #11
Briancanadiano
Brian335tt
Briancanadiano's Avatar
Canada
11
Rep
868
Posts

 
Drives: BMW 335i premium package 19"ri
Join Date: Aug 2012
Location: Toronto

iTrader: (2)

Quote:
Originally Posted by Reapur View Post
Try recording a video and uploading it to YouTube to show the problem
Will do!
Appreciate 0
      09-12-2013, 01:42 PM   #12
marcvtec
Lieutenant Colonel
22
Rep
1,795
Posts

 
Drives: 335i
Join Date: Oct 2006
Location: toronto

iTrader: (0)

Quote:
Originally Posted by Reapur View Post
Your attitude pretty much sums up my frustration with this local forum.

There are plenty of online car communities that would offer help at the drop of a hat. The local Toronto bunch seems pretty closed off and non active.

Collective knowledge and corporation forms comradely, friendships and can save everyone a lot of money from not dealing with a dealership.
Not really,

It's the lack of data you provided and yet expected answers and mentioned the community sucks.
Something is wrong with my car help ASAP, really? Could be a million things.
Frustration is only caused by the person creating it.
Our locals have help each other numerous times.
__________________
COBB Powered, Spec2+, Wavetrac, DCI, Forge DV's, AR catless DP's, AA FMIC, M3 links & Sways, 19' BBS LM's wrapped in PSS, Zimmerman cross drilled rotors, hawk carbon pads, M3 Spoiler, AC roof Spoiler, Aero Lip, Vorsteiner Diffuser, m3 sides, Tinted, And One Happy BMW Driver.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:45 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST