E90Post
 


TireRack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Suspension | Brakes | Chassis > Steering Problem : Car pulls Right/Left (Please Help)



Reply
 
Thread Tools Search this Thread
      10-20-2013, 09:11 PM   #1
idk alex
@idk_alex
5

 
idk alex's Avatar
 
Drives: Yes
Join Date: Sep 2009
Location: Tampa Bay Area


Posts: 406
iTrader: (2)

Garage List
2010 E92  [0.00]
Steering Problem : Car pulls Right/Left (Please Help)

I need your guys' help.

The car was involved in a crash. The impact was on the driver side rear end with some front end damage as well. Almost all of the damage was structural. The car has been fixed and re evaluated by an indie and a BMW dealer 8+ times and still this issue isn't fixed.

Bottom Line.

If you make a right hand turn, my car will pull right after the turn. If I make a left hand turn the car will drive straight or pull slightly left. So this car is never driving perfectly.

I'm thinking it cant be something constant because I can influence it. Its not a constant pull right or left. I can make it pull to the right or drive straight. But in daily driving where I have to make right and left turns it gets pretty annoying to constantly be battling the steering wheel. Its a bigger issue than you'd think since after I make a right turn, I cant jolt the steering wheel to the left safely.

The car aligns out perfectly every time its on the rack and tbh its not an alignment issue.

The car had Fortune Auto Coilovers on it before the crash and the car drove perfect. After the accident, while the car was in the shop, a brand new set of Fortune Auto Coilovers was ordered and installed.

Im thinking it has to be something up front related to the steering. Since that is what is influencing it. The steering rack has been replaced along with a lot of other parts. I'm thinking its a bushing somewhere or a bearing but I have no clue anymore.

If you have any suggestions please throw them out there, this is driving me crazy and if I cant get it sorted out I probably will ditch the car.
Thank you

As of now Im planning on putting on my stock suspension next week and seeing if that fixes the issue. If it does I will send my coilovers back and get them warrantied. But Im looking for any suggestions/advice/help/ANYTHING!!!

Thank you
Appreciate 0
      10-21-2013, 12:05 AM   #2
nikitino25
Lieutenant
United_States
7

 
nikitino25's Avatar
 
Drives: '07 E92 335i
Join Date: Dec 2011
Location: Missouri


Posts: 537
iTrader: (2)

Yep, I'm having the same problem. I think we might have put a washer on upside down so may have to take the front struts back off to check. Maybe they did the same when installing your new coils. If that's not it, may have to take mine to the dealer.......I'll keep you posted
Appreciate 0
      10-21-2013, 07:04 AM   #3
idk alex
@idk_alex
5

 
idk alex's Avatar
 
Drives: Yes
Join Date: Sep 2009
Location: Tampa Bay Area


Posts: 406
iTrader: (2)

Garage List
2010 E92  [0.00]
What washer are you guys talking about? And my car went to the dealer 5+ times for this and they never figured it out.
Appreciate 0
      10-21-2013, 11:34 AM   #4
nikitino25
Lieutenant
United_States
7

 
nikitino25's Avatar
 
Drives: '07 E92 335i
Join Date: Dec 2011
Location: Missouri


Posts: 537
iTrader: (2)

Look at this thread, has a picture of the washer
http://www.e90post.com/forums/showthread.php?t=840223

also shows it on this video right at 13:36



he calls it a spacer plate

It's also part #7 on this diagram:

http://www.realoem.com/bmw/showparts...67&hg=31&fg=10

Last edited by nikitino25; 10-21-2013 at 11:47 AM.
Appreciate 0
      10-21-2013, 06:20 PM   #5
idk alex
@idk_alex
5

 
idk alex's Avatar
 
Drives: Yes
Join Date: Sep 2009
Location: Tampa Bay Area


Posts: 406
iTrader: (2)

Garage List
2010 E92  [0.00]
Quote:
Originally Posted by nikitino25 View Post
Look at this thread, has a picture of the washer
http://www.e90post.com/forums/showthread.php?t=840223

also shows it on this video right at 13:36



he calls it a spacer plate

It's also part #7 on this diagram:

http://www.realoem.com/bmw/showparts...67&hg=31&fg=10
Oh wow, Ill have to see if Fortune Auto assembled my coilovers wrong.

Whats your next course of action?
Appreciate 0
      10-21-2013, 06:31 PM   #6
nikitino25
Lieutenant
United_States
7

 
nikitino25's Avatar
 
Drives: '07 E92 335i
Join Date: Dec 2011
Location: Missouri


Posts: 537
iTrader: (2)

It looks like I will be taking off my struts to see if we put that washer in upside down by accident....
Appreciate 0
      10-21-2013, 11:07 PM   #7
jjellyneck
First Lieutenant
3

 
Drives: 2008 335i MT
Join Date: Jun 2012
Location: TX


Posts: 335
iTrader: (0)

Hmmm....well I do know that is what my car did when the toe-in was pretty extreme. Had an alignment and it was then fine.
From my motorcycle experience it felt more like excessive "rake" or maybe camber. But the toe in was too much per the specs.
Appreciate 0
      10-22-2013, 07:42 AM   #8
idk alex
@idk_alex
5

 
idk alex's Avatar
 
Drives: Yes
Join Date: Sep 2009
Location: Tampa Bay Area


Posts: 406
iTrader: (2)

Garage List
2010 E92  [0.00]
My toe is in oem spec^^^^

And I think im going to take off my top hats tonight and replace them with the oem ones and see if the problem goes away.

I have a feeling its something with them.
Appreciate 0
      10-22-2013, 07:53 AM   #9
essex_lad
Captain
15

 
essex_lad's Avatar
 
Drives: E92 330i tuned Msport Highline
Join Date: Jun 2013
Location: Essex


Posts: 931
iTrader: (0)

Get a hunter tracking system on it then you can see what's out it sounds like your toe is out on the rear.

It may end up being one of them problems which is always a mystery and can never be sorted. It may be better to chuck the car into an auction and get another one.
Appreciate 0
      10-22-2013, 10:19 AM   #10
jjellyneck
First Lieutenant
3

 
Drives: 2008 335i MT
Join Date: Jun 2012
Location: TX


Posts: 335
iTrader: (0)

Quote:
Originally Posted by jjellyneck View Post
Hmmm....well I do know that is what my car did when the toe-in was pretty extreme. Had an alignment and it was then fine.
From my motorcycle experience it felt more like excessive "rake" or maybe camber. But the toe in was too much per the specs.
Oops....I meant caster and not camber (the motorcycle comparison).
So everything is in spec but still has that weird pull--I know what that feels like.
Appreciate 0
      10-22-2013, 01:40 PM   #11
nikitino25
Lieutenant
United_States
7

 
nikitino25's Avatar
 
Drives: '07 E92 335i
Join Date: Dec 2011
Location: Missouri


Posts: 537
iTrader: (2)

Quote:
Originally Posted by jjellyneck View Post
Oops....I meant caster and not camber (the motorcycle comparison).
So everything is in spec but still has that weird pull--I know what that feels like.
I don't think the caster is adjustable but I could be wrong. I think the toe being off can cause this issue but OP says his was checked as was mine at an alignment shop though not a BMW shop....
Appreciate 0
      10-22-2013, 01:51 PM   #12
tahoerdr
Private
United_States
0

 
tahoerdr's Avatar
 
Drives: E92 335xi
Join Date: Apr 2008
Location: Bay Area, CA


Posts: 93
iTrader: (3)

A lot of BMWs get tracking issues after an accident due to tow trucks winching the cars onto the flatbed via the front control arms instead of the removable two hook at the bumper. The arms become slightly deformed. I'm thinking this is probably not your issue but may be a contributing factor.

Caster can change the behavior of steering as well. My TCKR camber plates allow for caster adjustment and recommend maxing the adjustment (tilt struts toward the rear of vehicle).
Appreciate 0
      10-22-2013, 01:53 PM   #13
jjellyneck
First Lieutenant
3

 
Drives: 2008 335i MT
Join Date: Jun 2012
Location: TX


Posts: 335
iTrader: (0)

Quote:
Originally Posted by nikitino25 View Post
I don't think the caster is adjustable but I could be wrong. I think the toe being off can cause this issue but OP says his was checked as was mine at an alignment shop though not a BMW shop....
Yes, true....unless is got "adjusted" from the accident. But then again, alignment is good. I definitely know that mine did the exact same thing when the toe-in was excessive (due to installing new M3 control arms and tension rods, etc).
Maybe some slop in the front end is causing the problem...he starts into the turn, and then the suspension moves in the same direction and causes the excessive and continued pull.
Appreciate 0
      10-23-2013, 01:56 AM   #14
idk alex
@idk_alex
5

 
idk alex's Avatar
 
Drives: Yes
Join Date: Sep 2009
Location: Tampa Bay Area


Posts: 406
iTrader: (2)

Garage List
2010 E92  [0.00]
Hey everyone thanks for the responses. Tonight I put my full suspension back to stock and it seems to have cured the problem. We checked everything down there also to find any slop or anything that needs replacing and it all seemed to check out.

Getting it alligned tomorrow to confirm.

So Im guessing something had to do with the coilover which we still cant figure out. Im sending them back to get warrantied
Appreciate 0
      10-23-2013, 02:37 AM   #15
essex_lad
Captain
15

 
essex_lad's Avatar
 
Drives: E92 330i tuned Msport Highline
Join Date: Jun 2013
Location: Essex


Posts: 931
iTrader: (0)

Bent strut maybe. Glad you have sorted it.
Appreciate 0
      10-23-2013, 08:01 AM   #16
idk alex
@idk_alex
5

 
idk alex's Avatar
 
Drives: Yes
Join Date: Sep 2009
Location: Tampa Bay Area


Posts: 406
iTrader: (2)

Garage List
2010 E92  [0.00]
They were all brand new coilovers which is why we are confused.
I guess i just got the lucky set.
Appreciate 0
      10-23-2013, 05:39 PM   #17
idk alex
@idk_alex
5

 
idk alex's Avatar
 
Drives: Yes
Join Date: Sep 2009
Location: Tampa Bay Area


Posts: 406
iTrader: (2)

Garage List
2010 E92  [0.00]
So I got it aligned today. There is no more (memory steering).

The car does go wherever the crown of the road is. I dont remember my car being this sensitive but then again Ive been obsessed the past 3 months with this issue.

So looks like im sending my coils to get refurbed
Appreciate 0
      11-05-2013, 06:45 PM   #18
nikitino25
Lieutenant
United_States
7

 
nikitino25's Avatar
 
Drives: '07 E92 335i
Join Date: Dec 2011
Location: Missouri


Posts: 537
iTrader: (2)

Quote:
Originally Posted by nikitino25 View Post
It looks like I will be taking off my struts to see if we put that washer in upside down by accident....
Finally pulled my struts this weekend and did have that stupid washer upside down. Reassembled struts correctly and re-installed and now no more trouble..
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:50 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST