E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > ConnectedDrive / I-Drive / Navigation Related Discussion > Radio not holding presets



Reply
 
Thread Tools Search this Thread
      10-21-2013, 09:47 PM   #1
mbanks21
Captain
 
Drives: 2006 330i
Join Date: Aug 2013
Location: St. Pete Florida

Posts: 635
iTrader: (5)

Radio not holding presets

06 330i with premium package and navigation if that helps. I find a station, click the knob, select "set", pick the preset slot I want and click the knob again. When I turn the car off or change to cd and come back to the radio the preset is a different station. Even weirder if I turn to the next preset then back again it will be the correct station, occasionally. Thoughts?
mbanks21 is offline  
0
Reply With Quote
      10-25-2013, 01:40 PM   #2
mbanks21
Captain
 
Drives: 2006 330i
Join Date: Aug 2013
Location: St. Pete Florida

Posts: 635
iTrader: (5)

Bueller?
mbanks21 is offline  
0
Reply With Quote
      10-25-2013, 03:33 PM   #3
adriang
Captain
 
Drives: 2011 BMW 335d
Join Date: Feb 2012
Location: Nobleton

Posts: 603
iTrader: (0)

thats odd, i know each key fob saves its own settings like seat, mirror, a/c/heat settings, radio presets etc.
the only thing i can think of is when you turn your car off, you end up turning the car on with a different key fob.
but from reading your post you say that you go from radio to cd to radio and it changes while the car is still on. strange.
hopefully someone has more insight to help you
__________________
2011 BMW 335d
adriang is online now   Canada
0
Reply With Quote
      10-25-2013, 04:54 PM   #4
Dracon
BimmerPost Supporting Vendor

 
Drives: 2006 330i E90
Join Date: Apr 2009
Location: Nashville, TN

Posts: 964
iTrader: (18)

Quote:
Originally Posted by mbanks21 View Post
06 330i with premium package and navigation if that helps. I find a station, click the knob, select "set", pick the preset slot I want and click the knob again. When I turn the car off or change to cd and come back to the radio the preset is a different station. Even weirder if I turn to the next preset then back again it will be the correct station, occasionally. Thoughts?
I think that was a software issue that was resolved in later versions of the CCC iDrive firmware.
Dracon is offline   United_States
0
Reply With Quote
      10-25-2013, 07:18 PM   #5
igotag
Enlisted Member
 
Drives: 2009 335i X-Drive Coupe
Join Date: Jan 2013
Location: Seattle, WA

Posts: 44
iTrader: (0)

It is probably an issue with the battery... When my battery was going on I experienced a lot of similar symptoms. When you start getting a battery going out there are all kinds of crazy electrical problems!
igotag is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:45 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST