E90Post
 


Horizon LED
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > 335i misfire, shaking, reduced power under load



Reply
 
Thread Tools Search this Thread
      11-04-2013, 03:13 PM   #1
GATORSHOES2
Private
0
Rep
52
Posts

 
Drives: E92 08 335i
Join Date: Aug 2013
Location: Texas

iTrader: (0)

335i misfire, shaking, reduced power under load

Haven't had my 335i for too long now, but recently if I put the car under load "a little more than half throttle" to pass someone or generally just "take off" the check engine light comes on and the car starts sputtering when pushing the pedal.

It's raining so I haven't been able to swap coils or plugs, but what do you guys thing?
The Check engine light would go away with a restart but now it's always up.

Code says Misfire Cylinder 2 <<<
__________________
Appreciate 0
      11-05-2013, 11:27 AM   #2
sankohuy
Second Lieutenant
sankohuy's Avatar
4
Rep
255
Posts

 
Drives: E92 335i
Join Date: Oct 2012
Location: norcal

iTrader: (0)

So what are you really asking? You know it's a misfire...so...just change coil or plugs when you get a chance....
__________________
Appreciate 0
      11-05-2013, 12:00 PM   #3
Artmasterx
Captain
Artmasterx's Avatar
17
Rep
859
Posts

 
Drives: 2007 BMW 335i
Join Date: Jun 2008
Location: MA

iTrader: (0)

Garage List
2006 Volvo V70R  [5.00]
2007 BMW 335i  [5.00]
Quote:
Originally Posted by sankohuy View Post
So what are you really asking? You know it's a misfire...so...just change coil or plugs when you get a chance....
+1. Just had a misfire in cylinder 3 and it seemed like the plug and coil were both bad.

Swap the coil to another cylinder, if the misfire follows then replace the coil. If not, then the plug.

In my case, the misfire followed the coil, but even after replacing the coil the plug was still acting up. Replacing both fixed the problem.
__________________
Current: 2007 335i sedan
Alpine White | Sports | Premium | Cold | Comfort Access

FORMERLY: 128i coupe
Alpine White | Sports Package | Black Leather
Appreciate 0
      11-07-2013, 02:11 AM   #4
GATORSHOES2
Private
0
Rep
52
Posts

 
Drives: E92 08 335i
Join Date: Aug 2013
Location: Texas

iTrader: (0)

It's only when I open the throttle all the way. Or WOT as you say?

Swapped coils, still spitting cylinder 2 at me, no change.
Also... OMFG the small hole you have to fit a socket for the plugs.. 4 different places.. Not one socket fit, going to have to order one.
__________________
Appreciate 0
      11-07-2013, 11:47 AM   #5
sankohuy
Second Lieutenant
sankohuy's Avatar
4
Rep
255
Posts

 
Drives: E92 335i
Join Date: Oct 2012
Location: norcal

iTrader: (0)

That IS the symptom if a misfire, shakes when you accelerate. You will need to order a special N54 socket to change the plugs, cost about $20-$25. What's the mileage on your car?
Edit: I have a feeling it's your coil tho, but change the plug first and see wussup, cheaper if it fixes
__________________
Appreciate 0
      11-07-2013, 06:55 PM   #6
GATORSHOES2
Private
0
Rep
52
Posts

 
Drives: E92 08 335i
Join Date: Aug 2013
Location: Texas

iTrader: (0)

Quote:
Originally Posted by sankohuy View Post
That IS the symptom if a misfire, shakes when you accelerate. You will need to order a special N54 socket to change the plugs, cost about $20-$25. What's the mileage on your car?
Edit: I have a feeling it's your coil tho, but change the plug first and see wussup, cheaper if it fixes
I guess I goofed when I changed coils and cleared the code yesterday.
Today I swapped plugs and the problem followed the plug, but when I put the plug back the problem stayed, so I swapped the bad cylinder coil to a different cylinder and the problem followed. Ordered a replacement for 44$ online. OEM >

I made the thread cause I was fearing an injector or carbon build up issue.
__________________
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:56 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST