E90Post
 


GT Haus
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > UK > UK Technical Forum > Airbag Control Unit



Reply
 
Thread Tools Search this Thread
      11-21-2013, 11:40 AM   #1
JackR
First Lieutenant
JackR's Avatar
5
Rep
302
Posts

 
Drives: BMW 330d SE
Join Date: Nov 2012
Location: Somerset, United Kingdom

iTrader: (0)

Airbag Control Unit

Hello you lot!

Right I've had the restraint system failure light come up, along with the damn annoying warn every time on the iDrive and it's come down to, after replacing the air bag, checking connections etc....... The Airbag control Unit.

I know it's under the centre console somewhere but how on Earth does one go about getting at it? I nearly lost my rag earlier with it so have come here to type this. A sign of defeat.... Yes.

Also, when it comes to replacing it, I've read that the new one will need to be coded to my car? Is this true? If so how do I go about that or is that something only BMW can do? They want 415 for one, I told them quietly and politely to shove it.

Pretty sure that's about it. If not then I'll edit this post. Also if you have any other suggestions before ripping the car apart that'd be ideal!

JR.. OUT.
Appreciate 0
      11-27-2013, 07:57 AM   #2
mistryn
Lieutenant Colonel
mistryn's Avatar
35
Rep
1,998
Posts

 
Drives: BMW 335D
Join Date: Oct 2011
Location: Mids

iTrader: (7)

if I am thinking of the same one, unless you get one from a car that is same year as yours and month then you can get away with swapping and no ciding required - again if its the same one i am thinking of one I have a spare unit at home that you can have for a small price?
Appreciate 0
      11-28-2013, 09:49 AM   #3
JackR
First Lieutenant
JackR's Avatar
5
Rep
302
Posts

 
Drives: BMW 330d SE
Join Date: Nov 2012
Location: Somerset, United Kingdom

iTrader: (0)

Hello mistryn, so what you're saying is that assuming I get a 2006 (October I think) airbag unit no coding is needed. I've searched and searched for answer with regards to coding them and I can't find anything so starting to think that maybe it's not necessary!

I'll Pm you buddy!
Appreciate 0
      11-28-2013, 04:43 PM   #4
makkan00
Major General
makkan00's Avatar
United Kingdom
132
Rep
7,690
Posts

 
Drives: F10
Join Date: Dec 2011
Location: Essex

iTrader: (48)

Expose the airbag unit and look at the terminals. It could be that rusty terminal or some water ingress is increasing the resistance. It may be just a easy fix.

Expose it and have a look at it before shelling any money out.
__________________
Appreciate 0
      01-14-2014, 04:50 PM   #5
JackR
First Lieutenant
JackR's Avatar
5
Rep
302
Posts

 
Drives: BMW 330d SE
Join Date: Nov 2012
Location: Somerset, United Kingdom

iTrader: (0)

Right turns out that it was the airbag control unit. I bought a new one at the cost of.... wait for it..... 415inc VAT. But that's all done. Dusted!


Case closed!!
Appreciate 0
      01-14-2014, 05:40 PM   #6
Tipper
Private First Class
Tipper's Avatar
3
Rep
124
Posts

 
Drives: 2007 E91 320d SE auto
Join Date: Jan 2009
Location: Devon, UK

iTrader: (0)

Go on tell us the whole story...did it need coding?
Appreciate 0
      01-15-2014, 03:31 PM   #7
JackR
First Lieutenant
JackR's Avatar
5
Rep
302
Posts

 
Drives: BMW 330d SE
Join Date: Nov 2012
Location: Somerset, United Kingdom

iTrader: (0)

Sorry I was a little vague.
Quote:
Originally Posted by Tipper View Post
Go on tell us the whole story...did it need coding?
The full story. Basically what happened was..... A resister was put on the airbag plug to see if the coding was before or after that, it was before. So then it was placed on another socket under the centre console just before the control unit to save stripping wiring etc etc. So that confirmed it was the control unit.

A new one was ordered for a tidy sum of 415inc VAT from BMW (Westerly Yeovil), who I can't stand but that's by the by! That took a couple of days to arrive. The old one was removed which was easy as piss!

As for coding, I'm not sure! I took it to Tytherleigh Vehicle Electrics (TVE) which did anything else for me.


So i did a fair few miles today and all is well! Apart from one of the damn H8 LED bulbs going - but a new one is being sent from the people I bought them off so can't grumble at that!
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:17 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST