E90Post
 


GTB Performance
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > BMW Coding > DIY: How to setup BMW Standard Tools 2.12 w/Windows 7 x86 (32-bit)



Reply
 
Thread Tools Search this Thread
      12-28-2013, 05:21 PM   #23
Moonchen
Registered
 
Drives: e39 540
Join Date: Dec 2013
Location: NZ

Posts: 2
iTrader: (0)

Hi all.

Great DIY.

I am having trouble downloading the INPA 5.02 in the links above. It is rather slow and the last attempt ended up in a corrupted file.

Is there an alternative method to getting the required 5.02 files?
Moonchen is offline  
0
Reply With Quote
      12-28-2013, 09:38 PM   #24
bschmidt25
Registered
 
Drives: '07 530xi
Join Date: Feb 2013
Location: Wisconsin

Posts: 3
iTrader: (0)

Quote:
Originally Posted by Javy View Post
Damn! You think this will work with XP?
I just installed it on a XP Pro SP3 virtual machine. Works fine. No changes needed to the instructions.
bschmidt25 is offline  
0
Reply With Quote
      12-28-2013, 09:44 PM   #25
bschmidt25
Registered
 
Drives: '07 530xi
Join Date: Feb 2013
Location: Wisconsin

Posts: 3
iTrader: (0)

Quote:
Originally Posted by Moonchen View Post
Hi all.

Great DIY.

I am having trouble downloading the INPA 5.02 in the links above. It is rather slow and the last attempt ended up in a corrupted file.

Is there an alternative method to getting the required 5.02 files?
Not that I know of. It is slow, but I was able to download it. The file is fine, so if you are getting a corrupt file error your download must have failed at some point. Maybe try using a download manager like Get Right...
bschmidt25 is offline  
0
Reply With Quote
      12-28-2013, 09:49 PM   #26
Ilyas
Private
 
Ilyas's Avatar
 
Drives: BMW 328xi Coupe
Join Date: Jan 2013
Location: East Lansing, MI

Posts: 85
iTrader: (0)

Garage List
2007 BMW 328xi  [5.00]
Guys, don't download 5.0.2; you don't really need to install it, you can go straight with BMW Standard Tools.
If you need CFGDAT and SGDAT folders - find torrents for INPA_EA-90X - it has 5.0.4 version with scripts.
Ilyas is offline  
0
Reply With Quote
      12-30-2013, 06:55 AM   #27
Moonchen
Registered
 
Drives: e39 540
Join Date: Dec 2013
Location: NZ

Posts: 2
iTrader: (0)

Thanks for that.

I can't seem to find a current link to 5.0.4. Has anyone got a mega.co.nz cloud drive?
Moonchen is offline  
0
Reply With Quote
      01-16-2014, 05:10 PM   #28
woggledog
Private First Class
 
Drives: 2007 E91 320D SE
Join Date: Jan 2014
Location: Surrey

Posts: 118
iTrader: (0)

Despising Windows as I do, I don't actually own it (I have a mac) and was looking at how to get it cheap to run in a VM

Imagine my surprise when I found that you can download it for free…. Legally!

It's time limited, so you'll have to reboot, and it is really for evaluation purposes but…

http://technet.microsoft.com/en-us/evalcenter/dn407368

If someone wants to repay my good deed, you can help me code my 6FL when I fit it :-)
woggledog is offline   United Kingdom
0
Reply With Quote
      01-19-2014, 07:22 PM   #29
Javy
e92javy
 
Javy's Avatar
 
Drives: Alpine White E92 M
Join Date: Apr 2010
Location: Miami

Posts: 981
iTrader: (5)

Finally got around to doing this and didn't get that far.

As soon as I got to step 3 in the installation of INPA which was to run Step_1\NFS\Entpackt\disk1\SETUP.EXE, the computer would do nothing. If I did step 4 which was Step_2\INSTALL\Instprog.exe then it would work. Not sure what to do now.

So frustrating !
__________________
Instagram- (javy_e92) 09 335i coupe / M package / Alpine White / Dinan Stage 2 / Alpina B3 Flash / Alufelgen SF71 / ST coils / Lux H8 / AFE Stage 2 intake / 6700k mtech HID / Performance trunk spoiler / Gloss black roof / CF interior wrap / PE Muffler Mod / ETS Charge pipe / Tial BOV / Cyba Quad Diffuser / Cyba Quad Black Chrome tips / Gloss black grills / AW reflectors / LED turn signals / Remote Key +
Javy is offline   United_States
0
Reply With Quote
      01-19-2014, 09:26 PM   #30
808AWD325xi
Ballin' out of control.
 
808AWD325xi's Avatar
 
Drives: 2009 BMW 335i
Join Date: Jul 2007
Location: Fremont, CA

Posts: 634
iTrader: (0)

Quote:
Originally Posted by Javy View Post
I finally downloaded everything I need to get this going and saved it all on a USB drive. I am running windows XP though. How do I get windows 7?
Quote:
Originally Posted by 808AWD325xi View Post
Windows 7 Home Premium SP1 32-bit OEM is $99.99 from frys.com, download only OEM pricing starts at about $70.00 on other sites.
Quote:
Originally Posted by Javy View Post
Damn! You think this will work with XP?
Quote:
Originally Posted by 808AWD325xi View Post
This DIY was tested with Windows 7 32-bit, I really can't say.
Quote:
Originally Posted by bschmidt25 View Post
I just installed it on a XP Pro SP3 virtual machine. Works fine. No changes needed to the instructions.
Quote:
Originally Posted by Javy View Post
Finally got around to doing this and didn't get that far.

As soon as I got to step 3 in the installation of INPA which was to run Step_1\NFS\Entpackt\disk1\SETUP.EXE, the computer would do nothing. If I did step 4 which was Step_2\INSTALL\Instprog.exe then it would work. Not sure what to do now.

So frustrating !
Are you running Windows 7 SP1 or Windows XP SP3?
808AWD325xi is offline   United_States
0
Reply With Quote
      01-19-2014, 11:11 PM   #31
nate5ks
Captain
 
Drives: 2006 BMW 330xi
Join Date: Nov 2011
Location: Jacksonville Beach, FL

Posts: 604
iTrader: (0)

Go to kickass torrents and search for windows. You'll find all versions. You may even find activation tools...
nate5ks is offline   United_States
0
Reply With Quote
      01-19-2014, 11:13 PM   #32
nate5ks
Captain
 
Drives: 2006 BMW 330xi
Join Date: Nov 2011
Location: Jacksonville Beach, FL

Posts: 604
iTrader: (0)

And it will all work on xp or 7 flawlessly. I have it on windows 8 now.
nate5ks is offline   United_States
0
Reply With Quote
      01-20-2014, 12:05 AM   #33
Javy
e92javy
 
Javy's Avatar
 
Drives: Alpine White E92 M
Join Date: Apr 2010
Location: Miami

Posts: 981
iTrader: (5)

I am running windows 7 service pack 1
__________________
Instagram- (javy_e92) 09 335i coupe / M package / Alpine White / Dinan Stage 2 / Alpina B3 Flash / Alufelgen SF71 / ST coils / Lux H8 / AFE Stage 2 intake / 6700k mtech HID / Performance trunk spoiler / Gloss black roof / CF interior wrap / PE Muffler Mod / ETS Charge pipe / Tial BOV / Cyba Quad Diffuser / Cyba Quad Black Chrome tips / Gloss black grills / AW reflectors / LED turn signals / Remote Key +
Javy is offline   United_States
0
Reply With Quote
      01-20-2014, 01:48 PM   #34
808AWD325xi
Ballin' out of control.
 
808AWD325xi's Avatar
 
Drives: 2009 BMW 335i
Join Date: Jul 2007
Location: Fremont, CA

Posts: 634
iTrader: (0)

Lightbulb

Quote:
Originally Posted by Javy View Post
Finally got around to doing this and didn't get that far.

As soon as I got to step 3 in the installation of INPA which was to run Step_1\NFS\Entpackt\disk1\SETUP.EXE, the computer would do nothing. If I did step 4 which was Step_2\INSTALL\Instprog.exe then it would work. Not sure what to do now.

So frustrating !
Quote:
Originally Posted by 808AWD325xi View Post
Are you running Windows 7 SP1 or Windows XP SP3?
Quote:
Originally Posted by Javy View Post
I am running windows 7 service pack 1
This is likely caused by the old (circa Windows 95) InstallShield 5.50.126.0 (SETUP.EXE) that had issues with long filenames.

After extracting '350517-inpa k+can.rar' , copy the inpa folder to the root of your C: drive. (i.e. C:\)

Copy the EC-APPS folder from C:\inpa\01_Step1 to the root of your C: drive as outlined in step 2 of the installation guide.

Finally, run SETUP.EXE from C:\inpa\01_Step1\NFS\Entpackt\disk1. This should solve your problem.
808AWD325xi is offline   United_States
0
Reply With Quote
      01-20-2014, 04:04 PM   #35
Javy
e92javy
 
Javy's Avatar
 
Drives: Alpine White E92 M
Join Date: Apr 2010
Location: Miami

Posts: 981
iTrader: (5)

Quote:
Originally Posted by 808AWD325xi View Post
This is likely caused by the old (circa Windows 95) InstallShield 5.50.126.0 (SETUP.EXE) that had issues with long filenames.

After extracting '350517-inpa k+can.rar' , copy the inpa folder to the root of your C: drive. (i.e. C:\)

Copy the EC-APPS folder from C:\inpa\01_Step1 to the root of your C: drive as outlined in step 2 of the installation guide.

Finally, run SETUP.EXE from C:\inpa\01_Step1\NFS\Entpackt\disk1. This should solve your problem.
I have the INPA file in WinRAR. The system is not letting me copy the files and paste then to C:
__________________
Instagram- (javy_e92) 09 335i coupe / M package / Alpine White / Dinan Stage 2 / Alpina B3 Flash / Alufelgen SF71 / ST coils / Lux H8 / AFE Stage 2 intake / 6700k mtech HID / Performance trunk spoiler / Gloss black roof / CF interior wrap / PE Muffler Mod / ETS Charge pipe / Tial BOV / Cyba Quad Diffuser / Cyba Quad Black Chrome tips / Gloss black grills / AW reflectors / LED turn signals / Remote Key +
Javy is offline   United_States
0
Reply With Quote
      01-20-2014, 06:58 PM   #36
808AWD325xi
Ballin' out of control.
 
808AWD325xi's Avatar
 
Drives: 2009 BMW 335i
Join Date: Jul 2007
Location: Fremont, CA

Posts: 634
iTrader: (0)

Quote:
Originally Posted by Javy View Post
I have the INPA file in WinRAR. The system is not letting me copy the files and paste then to C:
I used the Free RAR Extract Frog, I'm not familiar with WinRAR. This WinRAR FAQ explains how to extract files:
http://www.win-rar.com/faq.html?&L=0
808AWD325xi is offline   United_States
0
Reply With Quote
      01-20-2014, 07:02 PM   #37
Javy
e92javy
 
Javy's Avatar
 
Drives: Alpine White E92 M
Join Date: Apr 2010
Location: Miami

Posts: 981
iTrader: (5)

Quote:
Originally Posted by 808AWD325xi View Post
I used the Free RAR Extract Frog, I'm not familiar with WinRAR. This WinRAR FAQ explains how to extract files:
http://www.win-rar.com/faq.html?&L=0
Ok. I was able to follow directions perfectly and everything worked. I stopped right before installing BMW standard tools. My INPA screen looks just like yours except the ignition circle is not black. I assume its because its not connected to the car ?
__________________
Instagram- (javy_e92) 09 335i coupe / M package / Alpine White / Dinan Stage 2 / Alpina B3 Flash / Alufelgen SF71 / ST coils / Lux H8 / AFE Stage 2 intake / 6700k mtech HID / Performance trunk spoiler / Gloss black roof / CF interior wrap / PE Muffler Mod / ETS Charge pipe / Tial BOV / Cyba Quad Diffuser / Cyba Quad Black Chrome tips / Gloss black grills / AW reflectors / LED turn signals / Remote Key +
Javy is offline   United_States
0
Reply With Quote
      01-20-2014, 07:20 PM   #38
808AWD325xi
Ballin' out of control.
 
808AWD325xi's Avatar
 
Drives: 2009 BMW 335i
Join Date: Jul 2007
Location: Fremont, CA

Posts: 634
iTrader: (0)

Thumbs up

Quote:
Originally Posted by Javy View Post
Ok. I was able to follow directions perfectly and everything worked. I stopped right before installing BMW standard tools. My INPA screen looks just like yours except the ignition circle is not black. I assume its because its not connected to the car ?
Great, glad to hear that it worked for you.

If your not connected to the car, the Battery and Ignition circles will not be solid black.

Don't forget to copy the INPA 5.0.2 CFGDAT and SGDAT folders to removable media for safe keeping and make sure that you reinstall Windows prior to installing BMW Standard Tools 2.12 which contains INPA 5.0.6...
808AWD325xi is offline   United_States
0
Reply With Quote
      01-20-2014, 07:37 PM   #39
Javy
e92javy
 
Javy's Avatar
 
Drives: Alpine White E92 M
Join Date: Apr 2010
Location: Miami

Posts: 981
iTrader: (5)

Quote:
Originally Posted by 808AWD325xi View Post
Great, glad to hear that it worked for you.

If your not connected to the car, the Battery and Ignition circles will not be solid black.

Don't forget to copy the INPA 5.0.2 CFGDAT and SGDAT folders to removable media for safe keeping and make sure that you reinstall Windows prior to installing BMW Standard Tools 2.12 which contains INPA 5.0.6...
Is re-installing windows really needed. Reason I am asking is because I got a copy of windows 7 online and I don't remember where it was from. Can I continue without re-installing ?
__________________
Instagram- (javy_e92) 09 335i coupe / M package / Alpine White / Dinan Stage 2 / Alpina B3 Flash / Alufelgen SF71 / ST coils / Lux H8 / AFE Stage 2 intake / 6700k mtech HID / Performance trunk spoiler / Gloss black roof / CF interior wrap / PE Muffler Mod / ETS Charge pipe / Tial BOV / Cyba Quad Diffuser / Cyba Quad Black Chrome tips / Gloss black grills / AW reflectors / LED turn signals / Remote Key +
Javy is offline   United_States
0
Reply With Quote
      01-20-2014, 07:51 PM   #40
808AWD325xi
Ballin' out of control.
 
808AWD325xi's Avatar
 
Drives: 2009 BMW 335i
Join Date: Jul 2007
Location: Fremont, CA

Posts: 634
iTrader: (0)

Quote:
Originally Posted by Javy View Post
Is re-installing windows really needed. Reason I am asking is because I got a copy of windows 7 online and I don't remember where it was from. Can I continue without re-installing ?
Probably, but I highly recommend reinstalling Windows as the old EDIABAS & WinKFP installation program made changes to the system registry, etc. This DIY was tested with a fresh install of Windows 7 prior to installing BMW Standard Tools 2.12, your mileage may vary.

If you decide not to reinstall Windows 7, I suggest completely uninstalling INPA 5.0.2 and friends prior to installing BMW Standard Tools 2.12.
808AWD325xi is offline   United_States
0
Reply With Quote
      01-20-2014, 09:08 PM   #41
Javy
e92javy
 
Javy's Avatar
 
Drives: Alpine White E92 M
Join Date: Apr 2010
Location: Miami

Posts: 981
iTrader: (5)

Quote:
Originally Posted by 808AWD325xi View Post
Probably, but I highly recommend reinstalling Windows as the old EDIABAS & WinKFP installation program made changes to the system registry, etc. This DIY was tested with a fresh install of Windows 7 prior to installing BMW Standard Tools 2.12, your mileage may vary.

If you decide not to reinstall Windows 7, I suggest completely uninstalling INPA 5.0.2 and friends prior to installing BMW Standard Tools 2.12.
Ok. I guess for now I will just stick with what I got so I can at least read codes etc through INPA.

However, when I plug in my cable. My computer reads it and installs it on it own unlike your DIY. I get USB Serial Port (COM3)ready but the USB Serial Converter does not show up.
__________________
Instagram- (javy_e92) 09 335i coupe / M package / Alpine White / Dinan Stage 2 / Alpina B3 Flash / Alufelgen SF71 / ST coils / Lux H8 / AFE Stage 2 intake / 6700k mtech HID / Performance trunk spoiler / Gloss black roof / CF interior wrap / PE Muffler Mod / ETS Charge pipe / Tial BOV / Cyba Quad Diffuser / Cyba Quad Black Chrome tips / Gloss black grills / AW reflectors / LED turn signals / Remote Key +
Javy is offline   United_States
0
Reply With Quote
      01-20-2014, 09:20 PM   #42
808AWD325xi
Ballin' out of control.
 
808AWD325xi's Avatar
 
Drives: 2009 BMW 335i
Join Date: Jul 2007
Location: Fremont, CA

Posts: 634
iTrader: (0)

Quote:
Originally Posted by Javy View Post
Ok. I guess for now I will just stick with what I got so I can at least read codes etc through INPA.

However, when I plug in my cable. My computer reads it and installs it on it own unlike your DIY. I get USB Serial Port (COM3)ready but the USB Serial Converter does not show up.
You need to change it to COM1. Are you using a cable from one stop?
808AWD325xi is offline   United_States
0
Reply With Quote
      01-20-2014, 09:46 PM   #43
Javy
e92javy
 
Javy's Avatar
 
Drives: Alpine White E92 M
Join Date: Apr 2010
Location: Miami

Posts: 981
iTrader: (5)

Quote:
Originally Posted by 808AWD325xi View Post
You need to change it to COM1. Are you using a cable from one stop?
I changed it to com1 but when i connected it to the car, it did nothing. I am using the cable from one stop.
Javy is offline   United_States
0
Reply With Quote
      01-20-2014, 10:06 PM   #44
808AWD325xi
Ballin' out of control.
 
808AWD325xi's Avatar
 
Drives: 2009 BMW 335i
Join Date: Jul 2007
Location: Fremont, CA

Posts: 634
iTrader: (0)

Quote:
Originally Posted by Javy View Post
I changed it to com1 but when i connected it to the car, it did nothing. I am using the cable from one stop.
Make sure that the latency timer is to set to 1msec. You should be good to go, otherwise it's probably an issue related to the fact that you didn't reinstall Windows 7 prior to installing BMW Standard Tools 2.12.

This DIY has been tested thoroughly and works as described.
808AWD325xi is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:45 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST