E90Post
 


ECS BMW
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > Australia > Service Light Comes on After Second Ignition



Reply
 
Thread Tools Search this Thread
      12-18-2013, 06:10 AM   #1
dorkbydesign
Enlisted Member
 
Drives: 2007 320i
Join Date: Jul 2013
Location: Sydney, Australia

Posts: 46
iTrader: (0)

Service Light Comes on After Second Ignition

Hello!

I have a really strange problem. If I turn my engine on then turn it off, then immediately turn it back on, the service light comes on.

The problem is depicted here:




Why is this happening? The only code I have is for the brake pads (which still have 3-4mm left on them.

Thanks!
dorkbydesign is offline  
0
Reply With Quote
      12-18-2013, 06:22 PM   #2
Stuart@BMRAutowerkes
BimmerPost Supporting Vendor

 
Stuart@BMRAutowerkes's Avatar
 
Drives: a black car
Join Date: Sep 2010
Location: Sydney

Posts: 4,836
iTrader: (3)

I reckon your brake pad wear sensor has made contact with the rotor causing it to 'trip', even though the pads may still have 3-4mm left.
Stuart@BMRAutowerkes is offline  
0
Reply With Quote
      12-18-2013, 07:45 PM   #3
dorkbydesign
Enlisted Member
 
Drives: 2007 320i
Join Date: Jul 2013
Location: Sydney, Australia

Posts: 46
iTrader: (0)

Does this warrant the service light to come on?
dorkbydesign is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:05 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST