Bimmerpost for iPhone and Android have just been updated with a host of bug fixes. If you've ever had trouble logging into it in the past, give it a try now!

  E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > Subwoofer problem need help!!!



Reply
 
Thread Tools Search this Thread
      01-15-2014, 03:27 PM   #1
bmw_cro86
New Member
0
Rep
8
Posts

Drives: BMW 318d E90 2006
Join Date: Jan 2012
Location: Bosnia and Herzegowina

iTrader: (0)

Subwoofer problem need help!!!

Recently on my BMW E90 318d navigation Bussines (stereo system-base system) I notice that my subwoofer under the seat are making funny noise and that they are gone bad

Name:  2010-10-09 16.11.08.jpg
Views: 5695
Size:  113.5 KB


I found used subwoofer but they are from BMW E90 2010 with HI-FI system like this on picture

Name:  subremovalwithnewsub.JPG
Views: 3426
Size:  68.6 KB

my question is can i put this one from 2010 in may BMW e90 2006???
Can I caused any problems to I-drive if I do that???

Please help..

Thank you in advance
Appreciate 0
      01-15-2014, 06:12 PM   #2
Technic
Lieutenant General
Technic's Avatar
United_States
474
Rep
12,208
Posts

Drives: 2015 320i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

iTrader: (18)

Take a look at the connector in your original OEM woofer:

- how many pins does it have? 4, correct?

Take a look at the connector of the HiFi woofer:

- how many pins does it have? 2, correct?

Using the HiFi woofers will disconnect the front speakers in your Stereo system.

If you jump wires 1 to 2 and 3 to 4 (numbers molded in the connector)at your OEM connector (the one that you plug into the woofer) then it will work.

If both woofers have 2 pins then no jumper required.
Appreciate 0
      01-16-2014, 02:31 PM   #3
bmw_cro86
New Member
0
Rep
8
Posts

Drives: BMW 318d E90 2006
Join Date: Jan 2012
Location: Bosnia and Herzegowina

iTrader: (0)

Quote:
Originally Posted by Technic View Post
Take a look at the connector in your original OEM woofer:

- how many pins does it have? 4, correct?

Take a look at the connector of the HiFi woofer:

- how many pins does it have? 2, correct?

Using the HiFi woofers will disconnect the front speakers in your Stereo system.

If you jump wires 1 to 2 and 3 to 4 (numbers molded in the connector)at your OEM connector (the one that you plug into the woofer) then it will work.

If both woofers have 2 pins then no jumper required.

First thx for replay...
My old subwoofer (base system-stereo system) have 2 pins and they look the same as the pins on subwoofer from HIFI system from bmw e90 2010...
my question is can i make any damage on my i-drive system if i put this subwoofer from BMW e90 2010(HIFI SYSTEM) to my BMW e90 2006(STEREO SYSTEM)???
Appreciate 0
      01-16-2014, 03:16 PM   #4
bmw325i
Major General
133
Rep
5,126
Posts

Drives: 2006 BMW 325i
Join Date: Oct 2010
Location: United States

iTrader: (8)

Quote:
Originally Posted by bmw_cro86 View Post
First thx for replay...
My old subwoofer (base system-stereo system) have 2 pins and they look the same as the pins on subwoofer from HIFI system from bmw e90 2010...
my question is can i make any damage on my i-drive system if i put this subwoofer from BMW e90 2010(HIFI SYSTEM) to my BMW e90 2006(STEREO SYSTEM)???
Well hifi woofers are 2 ohm. I don't know what impedance the base woofers are, but I am assuming they are 4 ohm. You can find out by checking it with a multimeter.

I think you would be better off with some logic 7 woofers which are 4 ohm.
Appreciate 0
      01-16-2014, 03:49 PM   #5
Technic
Lieutenant General
Technic's Avatar
United_States
474
Rep
12,208
Posts

Drives: 2015 320i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

iTrader: (18)

Quote:
Originally Posted by bmw325i View Post
Well hifi woofers are 2 ohm. I don't know what impedance the base woofers are, but I am assuming they are 4 ohm. You can find out by checking it with a multimeter.

I think you would be better off with some logic 7 woofers which are 4 ohm.
Correct...
Appreciate 0
      01-16-2014, 05:11 PM   #6
bmw_cro86
New Member
0
Rep
8
Posts

Drives: BMW 318d E90 2006
Join Date: Jan 2012
Location: Bosnia and Herzegowina

iTrader: (0)

Quote:
Originally Posted by Technic View Post
Correct...
ok thanks guys...

but if I put this one in I probabaly would not have any problems???
Appreciate 0
      01-16-2014, 05:43 PM   #7
bmw325i
Major General
133
Rep
5,126
Posts

Drives: 2006 BMW 325i
Join Date: Oct 2010
Location: United States

iTrader: (8)

Quote:
Originally Posted by bmw_cro86 View Post
ok thanks guys...

but if I put this one in I probabaly would not have any problems???
You could possibly damage the stock headunit, or cause the headunit to produce a clipped signal.
Appreciate 0
      01-16-2014, 05:49 PM   #8
bmw_cro86
New Member
0
Rep
8
Posts

Drives: BMW 318d E90 2006
Join Date: Jan 2012
Location: Bosnia and Herzegowina

iTrader: (0)

Quote:
Originally Posted by bmw325i View Post
You could possibly damage the stock headunit, or cause the headunit to produce a clipped signal.
OK i understand lower impendance can cause damage on stock unit that's all I want to know thx.

I will look for the same subwoofer whit 4 oms impendance...
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 07:53 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST