E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > Sirius Stopped + SOS Malfunction + no access to Bluetooth menu



Reply
 
Thread Tools Search this Thread
      01-23-2014, 11:11 PM   #1
Greatdane84
Leeeroy Jankins
 
Greatdane84's Avatar
 
Drives: 335i e90 LCI
Join Date: Jan 2013
Location: SW Florida

Posts: 401
iTrader: (1)

Garage List
2009 335i  [5.00]
Details:

5 Months ago, little water got on amplifier and I haven't replaced. The amp was the only area with water and radio continued to work while subs stopped.

5 Days ago, I get in car in the Morning and I noticed all presets are gone. Sirius stations and Fm stations gone. I can still access cd/multimedia, AM/FM, navigation and menus. I called Sirius later on and membership was still active and they sent refresh signal which did nothing. I also can't see any options or menus for satellite radio.

Later that day, turn car on maybe for 3rd time after preset incident and I see "SOS System Malfunction". Then I can't access Bluetooth phone list. System hangs up and just sits.

Soft reboot does nothing.

Everything I've looked on forums mentions everything from TCU to the CCC , to The fiber optic cable.

Things to know:
-antenna and nothing on car was touched within this all happening
-NO Comfort Access
-Only have one key so it's not a key specific incident
-everything has worked fine since the original amp water mishap

Any ideas...
__________________
e90 LCI w/ -= VRSF 7" FMIC =-
-= Cobb: Stg1 +FMIC Aggressive ST =-
Last Install: BMS DCI + Caliper/Drum Paint

"If you're not 1st, you're last" -Ricky Bobby
Greatdane84 is offline   United_States
0
Reply With Quote
      01-29-2014, 10:35 AM   #2
Greatdane84
Leeeroy Jankins
 
Greatdane84's Avatar
 
Drives: 335i e90 LCI
Join Date: Jan 2013
Location: SW Florida

Posts: 401
iTrader: (1)

Garage List
2009 335i  [5.00]
Help!
__________________
e90 LCI w/ -= VRSF 7" FMIC =-
-= Cobb: Stg1 +FMIC Aggressive ST =-
Last Install: BMS DCI + Caliper/Drum Paint

"If you're not 1st, you're last" -Ricky Bobby
Greatdane84 is offline   United_States
0
Reply With Quote
      01-29-2014, 10:51 AM   #3
Technic
Lieutenant General
 
Technic's Avatar
 
Drives: 2015 320i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

Posts: 11,109
iTrader: (17)

Garage List
2004 M3  [0.00]
MOST ring broken - one or more of the MOST modules (TCU, Logic7 OEM amp, Sirius or HD Radio external tuners) is defective.

Please search for troubleshooting procedures (identification and replacement of damaged MOST device) or just dealer-time.
__________________
-2015 F30 320i, Imperial/Oyster, 8AT: August 2014 ED
-2012 E92 M3 Jerez Black/Rust Brown, M-DCT: Gone
-2008 E90 M3 Melbourne Red/Bamboo, 6MT: Gone
-2007 MK5 GTI United Grey/Grey, DSG: Gone
-2004 E46 M3 Carbon Black/Cinnamon, 6MT: Gone
Technic is offline   United_States
0
Reply With Quote
      01-29-2014, 10:57 AM   #4
e90Mark
Captain
 
e90Mark's Avatar
 
Drives: 2008 BMW 335xi
Join Date: Aug 2013
Location: Warren, MI

Posts: 709
iTrader: (4)

Garage List
2008 BMW 335xi  [5.00]
Been chasing iDrive issues too. From what I've read, the SOS malfunction is most likely the TCU.
__________________
e90Mark is offline   Philippines
0
Reply With Quote
      01-29-2014, 10:59 AM   #5
Dracon
BimmerPost Supporting Vendor

 
Drives: 2006 330i E90
Join Date: Apr 2009
Location: Nashville, TN

Posts: 964
iTrader: (18)

Quote:
Originally Posted by Technic View Post
MOST ring broken - one or more of the MOST modules (TCU, Logic7 OEM amp, Sirius or HD Radio external tuners) is defective.

Please search for troubleshooting procedures (identification and replacement of damaged MOST device) or just dealer-time.
I would suspect that the Logic7 Amplifier finally died and now there's a break in the MOST ring.

But it would need to still be properly troubleshot as Technic suggests before blindly replacing components.
Dracon is offline   United_States
0
Reply With Quote
      01-29-2014, 10:14 PM   #6
Greatdane84
Leeeroy Jankins
 
Greatdane84's Avatar
 
Drives: 335i e90 LCI
Join Date: Jan 2013
Location: SW Florida

Posts: 401
iTrader: (1)

Garage List
2009 335i  [5.00]
Quote:
Originally Posted by Dracon
Quote:
Originally Posted by Technic View Post
MOST ring broken - one or more of the MOST modules (TCU, Logic7 OEM amp, Sirius or HD Radio external tuners) is defective.

Please search for troubleshooting procedures (identification and replacement of damaged MOST device) or just dealer-time.
I would suspect that the Logic7 Amplifier finally died and now there's a break in the MOST ring.

But it would need to still be properly troubleshot as Technic suggests before blindly replacing components.
Thanks ill start there
__________________
e90 LCI w/ -= VRSF 7" FMIC =-
-= Cobb: Stg1 +FMIC Aggressive ST =-
Last Install: BMS DCI + Caliper/Drum Paint

"If you're not 1st, you're last" -Ricky Bobby
Greatdane84 is offline   United_States
0
Reply With Quote
      02-07-2014, 08:05 AM   #7
Greatdane84
Leeeroy Jankins
 
Greatdane84's Avatar
 
Drives: 335i e90 LCI
Join Date: Jan 2013
Location: SW Florida

Posts: 401
iTrader: (1)

Garage List
2009 335i  [5.00]
Quote:
Originally Posted by Technic
MOST ring broken - one or more of the MOST modules (TCU, Logic7 OEM amp, Sirius or HD Radio external tuners) is defective.

Please search for troubleshooting procedures (identification and replacement of damaged MOST device) or just dealer-time.
Pm sent!

JL XD600/6 ordered as I know the OEM is damaged. Hopefully this will fix the other problems that started!
__________________
e90 LCI w/ -= VRSF 7" FMIC =-
-= Cobb: Stg1 +FMIC Aggressive ST =-
Last Install: BMS DCI + Caliper/Drum Paint

"If you're not 1st, you're last" -Ricky Bobby
Greatdane84 is offline   United_States
0
Reply With Quote
      03-08-2014, 12:15 AM   #8
Greatdane84
Leeeroy Jankins
 
Greatdane84's Avatar
 
Drives: 335i e90 LCI
Join Date: Jan 2013
Location: SW Florida

Posts: 401
iTrader: (1)

Garage List
2009 335i  [5.00]
Well I dropped in the JL Audio amp and speakers/bass working again from water on OEM amp accident.

Still getting SOS System malfunction error that started a couple months after OEM amp blew....

What TCU test can I attempt. Hard finding any specific answers regarding this
__________________
e90 LCI w/ -= VRSF 7" FMIC =-
-= Cobb: Stg1 +FMIC Aggressive ST =-
Last Install: BMS DCI + Caliper/Drum Paint

"If you're not 1st, you're last" -Ricky Bobby
Greatdane84 is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:35 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST