E90Post
 


GTB Performance
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > 2 code faults - DSC / TC Fluid [54C6 C998]



Reply
 
Thread Tools Search this Thread
      01-24-2014, 11:49 PM   #1
cband
Enlisted Member
 
Drives: 330xi (2006)
Join Date: Jan 2014
Location: Northen USA

Posts: 33
iTrader: (0)

2 code faults - DSC / TC Fluid [54C6 C998]

Reset all codes, then drove car around and rescanned... two codes popped up. 2006 E90. Below is the INPA readouts. No lights showing up on dash. Car is working fine.

Code:
DATE:		24.01.2014 16:50:30
ECU:		VGSG90
JobStatus: 	OKAY
VAriant: 	VGSG90

Result: 1 error in error memory !

54C6 54C6 ÖlVerschleiss
Error Counter: 3
Logistic Counter: 39

1. Umweltsatz
Mileage 			237640 km
Eingangsspannung KL30		12.25 Volt
KL15 Status CAN 		CAN Signal OK -- KL15 ein 0-n
KL15 Intern 			KL15 ein 0-n
Motordrehzahl			CAN Signal OK -- VKM ein 0-n
Reset-Quelle 			NO RESET 0-n
MKSOLL 				0.00 Nm
MSperrIstPosLim 		0.00 Nm
deltaPhiSperreCal 		-42.00 Grad
SperreError 			0.00 1
SperreState 			48.00 1
SperreMainState 		3.00 1

2. Umweltsatz
Mileage 			0 km
Eingangsspannung KL30 		0.00 Volt
KL15 Status CAN 		CAN Signal OK -- KL15 aus 0-n
KL15 Intern 			KL15 aus 0-n
Motordrehzahl CAN 		Signal OK -- VKM aus 0-n
Reset-Quelle 			UNKOWN_SOURCE 0-n
MKSOLL 				0.00 Nm
MSperrIstPosLim 		0.00 Nm
deltaPhiSperreCal 		0.00 Grad
SperreError 			0.00 1
SperreState 			0.00 1
SperreMainState 		0.00 1

Signal oder Wer oberhalb Schwelle
Testbedingungen noch nicht erfullt
Fehler momentan vorhanden und bereits gespeichert
Fehler wurde kein Aufleuchten einer Warnlampe verursachen

Signal above threshold
Not yet fulfilled Test Conditions
Error currently available and already stored
Error was not cause illumination of a warning lamp

Error Code: 54 C6 71 03 27 74 09 62 ED 00 00 2A 00 30 03 00 00 00 00 00 00 00 00 00 00
So from searching and reading on here and other sites it appears that this fault code is the sensor in the transfer case noticing that the fluid needs to be changed. Since I am near 150k, I plan on changing this fluid very soon. Other reason for this error would be a bad sensor in the transfer case... Correct?

Code:
Error Memory

DATE:		24.01.2014 16:50:30
ECU:		DXC_90
JobStatus: 	OKAY
VAriant: 	DXC_90

Result: 1 error in error memory !

SZL Fehlereintrag fuer: LWS-Fehler: Signal oder Wert unterhalb Schwelle Radtoleranzabgleich < -5%: F-CAN Radtoleranzabgleich, Kommunikation mit DSC

SSL error entry for: LWS error: Signal or value below threshold Radtoleranzabgleich <-5%: F-CAN Radtoleranzabgleich, communication with DSC

Error Counter: 3
Logistic Counter: 40

Mileage				237640 	km
Fahrzeuggeschwindigkeit		0.00 	km/h
ACB				0.00	0/1
DBC				0.00	0/1
ECD				0.00	0/1
HDC (nur 4x4)			0.00	0/1
DSC				0.00	0/1
ABS				0.00	0/1
BLS				1.00	0/1
ASC				0.00	0/1

kein passendes Fahlersymptom
Testbedingungen erfullt
Fehler momentan vorhanden und bereits gespeichert
Fehler wurde das Aufleuchten einer WArnlampe verursachen

no suitable error symptom
Fulfills test conditions
Error currently available and already stored
Error was causing the illumination of a warning lamp

Error Code: C9 98 E0 03 28 74 09 00 00 40
Something to do with DSC? not sure what the fault code is talking about. Why is BLS 1.00 and others are 0.00?

Last edited by cband; 01-25-2014 at 01:20 AM.
cband is offline  
0
Reply With Quote
      01-25-2014, 10:10 PM   #2
cband
Enlisted Member
 
Drives: 330xi (2006)
Join Date: Jan 2014
Location: Northen USA

Posts: 33
iTrader: (0)

Changed the transfer case fluid. 54C6 comes back even after clearing code. Looks like I need to do an adaptation reset on the xdrive / VGSG. Car drives fine after (tested 4 miles). Just want to clear the fault code.
cband is offline  
0
Reply With Quote
      01-27-2014, 10:21 PM   #3
cband
Enlisted Member
 
Drives: 330xi (2006)
Join Date: Jan 2014
Location: Northen USA

Posts: 33
iTrader: (0)

Quote:
Originally Posted by cband View Post
Changed the transfer case fluid. 54C6 comes back even after clearing code. Looks like I need to do an adaptation reset on the xdrive / VGSG. Car drives fine after (tested 4 miles). Just want to clear the fault code.
was able to clear the code for good by doing adaptation reset on transfer case via DIS and then clearing the code via INPA.
cband is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:08 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST