E90Post
 


Horizon LED
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > Persistent Mixture Control Codes



Reply
 
Thread Tools Search this Thread
      02-21-2014, 08:02 AM   #1
BMW..
Lieutenant
10
Rep
596
Posts

 
Drives: E46 M3 /E90
Join Date: May 2013
Location: Boca Raton FL

iTrader: (0)

Persistent Mixture Control Codes

Hello guys. My MAF sensor (I assume was damaged) was replaced. I would stall out at stops have bad gas mileage slow acceleration etc. Now that I have replaced the sensor, I still experience some sputtering and even a stall. Another member on here has experienced the same issue as well. Is there anything else that could be causing a fuel mixture issue?
__________________
Mystic Blue E90
Phoenix Yellow E46
Appreciate 0
      02-21-2014, 08:16 AM   #2
Rockyca
Second Lieutenant
2
Rep
234
Posts

 
Drives: E90 325i
Join Date: Jan 2012
Location: Toronto

iTrader: (1)

o2 sensors?
Appreciate 0
      02-21-2014, 08:51 AM   #3
jeguth1s
Private First Class
jeguth1s's Avatar
United_States
1
Rep
191
Posts

 
Drives: 2006 BMW 330xi
Join Date: Nov 2010
Location: Cincinnati

iTrader: (1)

Quote:
Originally Posted by BMW.. View Post
Hello guys. My MAF sensor (I assume was damaged) was replaced. I would stall out at stops have bad gas mileage slow acceleration etc. Now that I have replaced the sensor, I still experience some sputtering and even a stall. Another member on here has experienced the same issue as well. Is there anything else that could be causing a fuel mixture issue?
I had the same issue. It was my intake gaskets. My oil separator hose and crankcase vent hoses were cracked as well...
__________________
Bilstein+Eibach, UUC F&R sways, Powerflex bushings, PE+Supersprint 2nd cat delete, Euro Intake+Silicone Intake hose, SS Brake Lines
Appreciate 0
      02-24-2014, 08:30 PM   #4
cuco
First Lieutenant
cuco's Avatar
United_States
5
Rep
321
Posts

 
Drives: 85 BMW R80
Join Date: May 2012
Location: Cincinnati OH

iTrader: (1)

Quote:
Originally Posted by jeguth1s View Post
I had the same issue. It was my intake gaskets. My oil separator hose and crankcase vent hoses were cracked as well...
__________________
Airhead//Caffeine//Junky//Beemer//Fan
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:15 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST