E90Post
 


GT Haus
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Help: paddle shifters and DS mode doesn't work



Reply
 
Thread Tools Search this Thread
      02-28-2014, 01:48 AM   #1
igor_ki
Major
igor_ki's Avatar
United_States
12
Rep
1,261
Posts

 
Drives: A LIL BIMMER
Join Date: Jan 2013
Location: Sacramento, CA

iTrader: (6)

Help: paddle shifters and DS mode doesn't work

Hello all, I've read through countless threads and nothing works, my wires rant broken and the mechanism irks on another car i tried it on,
.......i need help, i just changed the shifter assembly from another e90 i have and it worked on that car but still doesn't work on mine, I noticed that when the car is off and i move through the gears, it shows D and when moved to the left it shows DS, but when the car is started and i move the shifter the left it only shows M2 or M1 and doesn't up or down shift, also the paddle shifters don't work. please help, whats wrong? my wires are all good and when the car is off it displays the DS mode...
__________________
PRESENT: 2010 E90 335XI, 2008 e92 6AT,

HISTORY: 2008 e92xi 6MT, 2009 e90 6AT, 2008 E90 6MT, 2011 E90 6AT, and 2 Hondas
Appreciate 0
      02-28-2014, 01:49 AM   #2
igor_ki
Major
igor_ki's Avatar
United_States
12
Rep
1,261
Posts

 
Drives: A LIL BIMMER
Join Date: Jan 2013
Location: Sacramento, CA

iTrader: (6)

I have a 2008 328i e92 if that matters
__________________
PRESENT: 2010 E90 335XI, 2008 e92 6AT,

HISTORY: 2008 e92xi 6MT, 2009 e90 6AT, 2008 E90 6MT, 2011 E90 6AT, and 2 Hondas
Appreciate 0
      02-28-2014, 12:40 PM   #3
Sean_335i
New Member
0
Rep
15
Posts

 
Drives: 2007 335i E92
Join Date: Dec 2013
Location: Los Angeles

iTrader: (0)

The paddle shifters should work whether you're in D or DS. It might just be an issue with paddles. Does your car shift when you move the shifter up or down in DS mode? Even if you are in M1 mode, it should shift automatically when the rpm hits the rev limiter.
Appreciate 0
      02-28-2014, 01:31 PM   #4
igor_ki
Major
igor_ki's Avatar
United_States
12
Rep
1,261
Posts

 
Drives: A LIL BIMMER
Join Date: Jan 2013
Location: Sacramento, CA

iTrader: (6)

Quote:
Originally Posted by Sean_335i View Post
The paddle shifters should work whether you're in D or DS. It might just be an issue with paddles. Does your car shift when you move the shifter up or down in DS mode? Even if you are in M1 mode, it should shift automatically when the rpm hits the rev limiter.
The paddle shifters don't work at all, not in D or DS. And moving the shift assembly to +/- doenst do anything either, when my car isn't started, only ignition on, and i move the gear selector to "D" it shows D on my cluster, when i move it left to DS it shows DS on the cluster. But when i start the car, and every time i move it into "D", it would go into M2 by itself, even though I'm in D. SO i have to move the shifter to the left (DS) and the cluster still shoes M2, and then when i move it back into D it goes into D. So its really weird. like the orange lights by the gear selector all work, and the car shows DS but only when car is off. If I'm driving and move the shifter into "DS" it will show me the gear I'm in, for example it would be M4 or M5, and it just stays there, when i brake and stop completely it still shows M4 and when i start accelerating it still would show M4 but i know its in a lower gear, but it then it quickly shift back to M4, so its under revving to motor which is bad.... I'm so confused because i have no idea what it can be, when the car is in D it drives fine, and when its in M4 or M5 and i floor it passed the click it will downshift, but none of the manual shift options work, not paddles or shift lever.....
__________________
PRESENT: 2010 E90 335XI, 2008 e92 6AT,

HISTORY: 2008 e92xi 6MT, 2009 e90 6AT, 2008 E90 6MT, 2011 E90 6AT, and 2 Hondas
Appreciate 0
      02-28-2014, 02:49 PM   #5
Sean_335i
New Member
0
Rep
15
Posts

 
Drives: 2007 335i E92
Join Date: Dec 2013
Location: Los Angeles

iTrader: (0)

From what you are describing, it sounds like either a software or electrical issue. Have you updated your software? If not, you might want to start there.
Appreciate 0
      02-28-2014, 03:08 PM   #6
igor_ki
Major
igor_ki's Avatar
United_States
12
Rep
1,261
Posts

 
Drives: A LIL BIMMER
Join Date: Jan 2013
Location: Sacramento, CA

iTrader: (6)

Quote:
Originally Posted by Sean_335i View Post
From what you are describing, it sounds like either a software or electrical issue. Have you updated your software? If not, you might want to start there.
No i didn't. how do i do that? I'm not really electrically inclined, mostly mechanically, and what do you think needs updating? i was thinking maybe the control module inside the transmission is acting up.
__________________
PRESENT: 2010 E90 335XI, 2008 e92 6AT,

HISTORY: 2008 e92xi 6MT, 2009 e90 6AT, 2008 E90 6MT, 2011 E90 6AT, and 2 Hondas
Appreciate 0
      02-28-2014, 03:18 PM   #7
DetectiveLoki
First Lieutenant
DetectiveLoki's Avatar
3
Rep
304
Posts

 
Drives: 2008 BMW 335i Convertible
Join Date: Jan 2012
Location: Orange County - SOCAL

iTrader: (4)

Your wires in the shifter got cut. You have to open it and repair it.

http://www.e90post.com/forums/showth...won%27t+engage
Appreciate 0
      02-28-2014, 03:22 PM   #8
igor_ki
Major
igor_ki's Avatar
United_States
12
Rep
1,261
Posts

 
Drives: A LIL BIMMER
Join Date: Jan 2013
Location: Sacramento, CA

iTrader: (6)

Quote:
Originally Posted by DetectiveLoki View Post
Your wires in the shifter got cut. You have to open it and repair it.

http://www.e90post.com/forums/showth...won%27t+engage
they are not cut, i opened and checked them, used a tester to check of signal through the wires, and then replaced the whole shifter assembly from a 2009 328i e90 and same problem, but my old shifter assembly from the e92 works flawlessly on the 2009 328i e90. so its not the wires or the assembly. and also i tried swapping the PRND thing and it didn't help.
__________________
PRESENT: 2010 E90 335XI, 2008 e92 6AT,

HISTORY: 2008 e92xi 6MT, 2009 e90 6AT, 2008 E90 6MT, 2011 E90 6AT, and 2 Hondas
Appreciate 0
      02-28-2014, 03:26 PM   #9
DetectiveLoki
First Lieutenant
DetectiveLoki's Avatar
3
Rep
304
Posts

 
Drives: 2008 BMW 335i Convertible
Join Date: Jan 2012
Location: Orange County - SOCAL

iTrader: (4)

I read on an older thread that if you swap the shifter, you may need a software update
Appreciate 0
      02-28-2014, 03:27 PM   #10
igor_ki
Major
igor_ki's Avatar
United_States
12
Rep
1,261
Posts

 
Drives: A LIL BIMMER
Join Date: Jan 2013
Location: Sacramento, CA

iTrader: (6)

Quote:
Originally Posted by DetectiveLoki View Post
I read on an older thread that if you swap the shifter, you may need a software update
i don't see why, because the e92 shifter works good on the e90, but i wouldn't mind and update, maybe my car went retarded and isn't right with its head, where and who can do the update? can anyone shed some light on this?
__________________
PRESENT: 2010 E90 335XI, 2008 e92 6AT,

HISTORY: 2008 e92xi 6MT, 2009 e90 6AT, 2008 E90 6MT, 2011 E90 6AT, and 2 Hondas
Appreciate 0
      02-28-2014, 03:41 PM   #11
igor_ki
Major
igor_ki's Avatar
United_States
12
Rep
1,261
Posts

 
Drives: A LIL BIMMER
Join Date: Jan 2013
Location: Sacramento, CA

iTrader: (6)

Quote:
Originally Posted by DetectiveLoki View Post
I read on an older thread that if you swap the shifter, you may need a software update
i don't see why, because the e92 shifter works good on the e90, but i wouldn't mind and update, maybe my car went retarded and isn't right with its head, where and who can do the update? can anyone shed some light on this?
__________________
PRESENT: 2010 E90 335XI, 2008 e92 6AT,

HISTORY: 2008 e92xi 6MT, 2009 e90 6AT, 2008 E90 6MT, 2011 E90 6AT, and 2 Hondas
Appreciate 0
      02-28-2014, 03:47 PM   #12
mike-y
just another bmw douche bag
United_States
36
Rep
3,398
Posts

 
Drives: 1.9L of fury
Join Date: Nov 2008
Location: Los Angeles, CA

iTrader: (4)

there's got to be a break in the connection somewhere else then, possibly somewhere on the main harness. when you tested the wires, from what point did you test to? did you go all the way back to the DCM/computer pinouts?
Appreciate 0
      02-28-2014, 04:20 PM   #13
igor_ki
Major
igor_ki's Avatar
United_States
12
Rep
1,261
Posts

 
Drives: A LIL BIMMER
Join Date: Jan 2013
Location: Sacramento, CA

iTrader: (6)

Quote:
Originally Posted by mike-y View Post
there's got to be a break in the connection somewhere else then, possibly somewhere on the main harness. when you tested the wires, from what point did you test to? did you go all the way back to the DCM/computer pinouts?
hi Mike,
no not all the way back to the computer pinouts, do you happen to have a diagram of electrical wiring of the car? that'll help out a lot, do u know what connector on the module/modules control the manual shifting?
__________________
PRESENT: 2010 E90 335XI, 2008 e92 6AT,

HISTORY: 2008 e92xi 6MT, 2009 e90 6AT, 2008 E90 6MT, 2011 E90 6AT, and 2 Hondas
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:26 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST