E90Post
 


European Auto Source
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > Subwoofer issues & Tuning



Reply
 
Thread Tools Search this Thread
      03-07-2014, 08:20 AM   #1
itsgoco
Private First Class
 
itsgoco's Avatar
 
Drives: SGM E90 328i
Join Date: Jun 2010
Location: Monterey Park, CA

Posts: 179
iTrader: (0)

Subwoofer issues & Tuning

Hey guys!

I have a question that hopefully some of you guys may be able to answer. I currently have Two 12" Alpine Type R's (Dual 4ohm voice coil) & a Alpine MRX-M100 amp. Sealed box in the trunk

I currently have it set up from the sub to the amp, bridged @ 4ohms. When I first had the subs installed in my car, the subwoofers would sound perfect, and hits the usual frequencies that I like.

A couple of weeks ago, I had my friend rewire, and tuck everything, so there aren't any exposed wires. That muffled the bass coming into the cabin, so he bridged both subs after. After, it hits fine, but I do have a slight problem.

After bridging, the subs would hit low frequencies perfectly, delivering very boomy basslines, and it sounds great in the car. When it came to higher frequencies, it practically doesn't exist unless the volume is turned up all of the way. And even then, it doesn't hit the way it should. Does anyone know what's wrong?

I have my gains set to NOM (Normal), subsonic at about 25Hz, Low Pass filter is set at 120. Bass EQ, doesn't make much different when I'm trying to have my subs hit midrange-higher frequencies. But currently, it's at +2db I believe.
__________________
Automotive Photographer | Southern California | 626 | 12.5" Club
http://www.facebook.com/gocophoto | IG: itsgoco
#TeamStretchNPoke
itsgoco is offline   United_States
0
Reply With Quote
      03-07-2014, 10:33 AM   #2
bmw325i
Brigadier General
 
Drives: 2006 BMW 325i
Join Date: Oct 2010
Location: United States

Posts: 3,958
iTrader: (5)

Set bass eq to 0 and Lpf around 50-60hz. You should have got the dual 2 ohm subs to get a 2 ohm load or an amp that is 1 ohm stable. The subs should be wired in parallel and the voice coils wired in series for a 4 ohm load.
__________________
2006 BMW 325i Titanium Silver
Mods- 19" AG M310's hypersilver, LCI xenons, drilled and slotted rotors, OEM rear spoiler, OEM exhaust tips, brushed black interior trim, Viper 5904 alarm + remote start
Audio upgrades- Alpine S920HD, JL XD600/6, Jehnert XE200, Morel Hybrid Ovation II, Audioque 2200D, 2 Alpine SWR 12d4's (forward facing sealed from trunk)
bmw325i is offline  
0
Reply With Quote
      03-07-2014, 12:27 PM   #3
itsgoco
Private First Class
 
itsgoco's Avatar
 
Drives: SGM E90 328i
Join Date: Jun 2010
Location: Monterey Park, CA

Posts: 179
iTrader: (0)

Quote:
Originally Posted by bmw325i View Post
Set bass eq to 0 and Lpf around 50-60hz. You should have got the dual 2 ohm subs to get a 2 ohm load or an amp that is 1 ohm stable. The subs should be wired in parallel and the voice coils wired in series for a 4 ohm load.
I'll try that out! Thanks. I got the set up from a forum member here, so at the time I wasn't too familiar in regards too car audio, and the importance of impedance.
itsgoco is offline   United_States
0
Reply With Quote
      03-07-2014, 02:32 PM   #4
bmw325i
Brigadier General
 
Drives: 2006 BMW 325i
Join Date: Oct 2010
Location: United States

Posts: 3,958
iTrader: (5)

Quote:
Originally Posted by itsgoco View Post
I'll try that out! Thanks. I got the set up from a forum member here, so at the time I wasn't too familiar in regards too car audio, and the importance of impedance.
You could always upgrade the amp later if you decide you need more power. Here is my setup, I have an Audioque 2200d which does 2200 watts at 1 ohm. The box is prefabbed and I built the front baffle which attaches using neodymium magnets.
Attached Images
  
__________________
2006 BMW 325i Titanium Silver
Mods- 19" AG M310's hypersilver, LCI xenons, drilled and slotted rotors, OEM rear spoiler, OEM exhaust tips, brushed black interior trim, Viper 5904 alarm + remote start
Audio upgrades- Alpine S920HD, JL XD600/6, Jehnert XE200, Morel Hybrid Ovation II, Audioque 2200D, 2 Alpine SWR 12d4's (forward facing sealed from trunk)
bmw325i is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:35 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST