E90Post
 


MINHS Auto Care Center
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > USB hard drives that work with 6FL



Reply
 
Thread Tools Search this Thread
      12-30-2007, 07:00 PM   #67
OverDrive
CHEAT TO WIN!!
OverDrive's Avatar
Canada
24
Rep
1,328
Posts

 
Drives: M3
Join Date: Oct 2007
Location: Toronto

iTrader: (0)

Quote:
Originally Posted by jtmccabe View Post
Well, I went to CompUSA only to find that the 4200 RPM SmartDisk FireLite advertised on their site is actually 5400 RPM. They had no 4200 RPM drives in stock.

I decided to give the 160 GB Iomega drive a try since I remembered reading that someone got an Iomega to work. I also bought a cigarette lighter-to-USB jack adapter so that I could try giving the drive some more power. It did actually work like that, although there is one big problem. When you shut the car off, the drive needs some time to shut down. Unfortunately the cigarette lighter power goes away as soon as the ignition turns off. Then the drive sits there still sort-of on and unable to power itself off, making some sad little repetitive noise as it tries over and over to power down.

The weak USB power stays on for a good 30 seconds or so after you turn the car off. I'm thinking that the solution might be to tap into the USB power lead and drive a relay with that. Does anyone know how much current the USB jack delivers? This would probably work if we can find a relay that requires less than whatever it is. Of course, it would also require running a power wire to the fuse box.

I think this is starting to become more of a PITA than it's worth. I would just buy a 160 GB iPod, except that I've already had two of them and they both had more problems than I could deal with. I'm starting to think I may never have access to all of my tunes in my car.
But 5400 RPM is better than 4200 RPM because its faster therefore there will be no delays on uploading (showing) the songs on the iDrive. There is also 7200RPM ones out there but those are expensive. Is 4200 RPM recommended by BMW or r u just saying? If 4200 is recommended then i guess its because it has to be compatible with the USB drive in the car since the USB Drive might not be able to generate info at higher speeds.
__________________
Current: 2013 E92 M3, 6MT, SSII on Fox Red Extended
Previous: 2008 E92 335xi, 6MT, AW on Saddle Brown
Appreciate 0
      12-30-2007, 10:49 PM   #68
mid-corner fun
Major
United_States
15
Rep
1,418
Posts

 
Drives: e92
Join Date: Jun 2005
Location: NE

iTrader: (4)

Quote:
Originally Posted by OverDrive View Post
But 5400 RPM is better than 4200 RPM because its faster therefore there will be no delays on uploading (showing) the songs on the iDrive. There is also 7200RPM ones out there but those are expensive. Is 4200 RPM recommended by BMW or r u just saying? If 4200 is recommended then i guess its because it has to be compatible with the USB drive in the car since the USB Drive might not be able to generate info at higher speeds.
BMW does not support any hard drives for 6FL. 4200RPM drives draw less power on startup and thus are more likely to work with the 6FL USB port without requiring additional external power. There are also reports of successful 5400RPM installations and also the occasional one-off overpowered USB port (100mph's car).

4200RPM vs 5400RPM may make a difference for indexing large collections (first time only) and even have a slightly bigger pause between songs but should have otherwise no other effect on playback. If you follow the recommendations here for genre-based letter sorting, directory listings should be fast.
Appreciate 0
      12-31-2007, 01:01 AM   #69
jct0518
Private First Class
1
Rep
139
Posts

 
Drives: 2008 328i
Join Date: Nov 2007
Location: Boston

iTrader: (1)

Its a little of topic but does someone know how to create M3U playlists in a mac?? I couldnt get windows media player to work and there is no winamp for mac..any help??
Appreciate 0
      12-31-2007, 01:28 AM   #70
dmichael
Lieutenant
United_States
8
Rep
452
Posts

 
Drives: 2011 GTI
Join Date: Jun 2007
Location: Massachusetts

iTrader: (1)

Quote:
Originally Posted by PeterM1 View Post
There are also reports of successful 5400RPM installations and also the occasional one-off overpowered USB port (100mph's car).


How do you determine the power level of the USB port?
__________________
2008 E90 328i - Sparkling Graphite/Terra/Dark Burl, 6MT, Sport, Premuim, Fold-down seats, iPod/USB(6FL). M-Sport Steering Wheel, ZHP M-Sport Shift knob, Euro fog lights. Euro Split Armrest
Appreciate 0
      12-31-2007, 07:19 AM   #71
nano
Private
0
Rep
92
Posts

 
Drives: stolen
Join Date: Nov 2007
Location: Finland

iTrader: (0)

Just ordered Buffalo 300 GB MiniStation TurboUSB 2.0. Hopefully it works... How do you guys recommend the files to be stored there? I was thinking something like creating directories like this: "John" - > "Rap" "Pop" - > "Artist" -> "Disc"

I have a one question though.. If i choose play and shuffle the whole "John" directory does it shuffle and play all the files and directories under it and in "Rap" "Pop" directories also?
Appreciate 0
      12-31-2007, 08:24 AM   #72
AWD Addict
Chief Executive
AWD Addict's Avatar
35
Rep
2,483
Posts

 
Drives: 2008 335xi 6spd Coupe
Join Date: Dec 2007
Location: Boston

iTrader: (1)

Garage List
2008 335xi  [0.00]
Anyone know if my PSP will work? I also havea FireLite 60g Flash Drive.

Thanks!
Appreciate 0
      12-31-2007, 08:34 AM   #73
mid-corner fun
Major
United_States
15
Rep
1,418
Posts

 
Drives: e92
Join Date: Jun 2005
Location: NE

iTrader: (4)

Quote:
Originally Posted by dmichael View Post
How do you determine the power level of the USB port?
AFAIK, by testing different drives. The drives will click/won't spin up if they can't get enough power from the port. I've tested 2 drives so far that other members have reported as working, no go in my car. That's the WD Passport 80 & 160GB versions. Going for the Iomega 120GB now, a 4200RPM drive.
Appreciate 0
      12-31-2007, 05:48 PM   #74
tonyes
New Member
tonyes's Avatar
United_States
0
Rep
18
Posts

 
Drives: 2008 335i space gray
Join Date: Dec 2007
Location: Santa Clara, CA

iTrader: (0)

SimpleTech 160GB, 5400RPM did not work in my 2008 335i with Idrive.
Appreciate 0
      12-31-2007, 05:50 PM   #75
cpippolo
Second Lieutenant
United_States
7
Rep
204
Posts

 
Drives: 2013 Cadillac ATS 3.6
Join Date: Oct 2007
Location: TX

iTrader: (0)

Iomega 80gb silver portable hard drive works - sort of

My Iomega 4200rpm works, but not very well. When trying to play the files in one folder (I have separate folders for each CD), it usually plays every other song (i.e., skips songs for no reason). Also, it will only random play songs in a folder, so I set up another folder with about a thousand songs and it doesn't seem to want to play those. Maybe it can't handle that many files in one folder. Also, it loses the connection to the USB hard drive and switches to the tuner on occasion...the FM switching problem that others have noted (I just had the programming updated by the dealer last week, so it should be the latest version). I don't know if these problems occur with USB sticks. I may try one of those when the prices come down and storage capacity goes up.
Appreciate 0
      01-04-2008, 10:26 PM   #76
mid-corner fun
Major
United_States
15
Rep
1,418
Posts

 
Drives: e92
Join Date: Jun 2005
Location: NE

iTrader: (4)

Quote:
Another thing about cables -- the Iomega drive had difficulty starting up once when I used a long cable. I am using 2 cables now that are much shorter - 5" and maybe 6" - and I have not encountered any startup clicking errors with either drive.
Where do you guys get such short cables? I'm on my 3rd test drive (WD, Simpletech 160GB & Iomega 120GB 4200RPM - none working so far) and I'm beginning to believe that the cable is as important as the rest of the other suggestions (low-level fat32 format etc.).
The WD had a ~2-3 inch cable, but I returned it already.

Any ideas where to source such a cable?
Appreciate 0
      01-04-2008, 11:36 PM   #77
mid-corner fun
Major
United_States
15
Rep
1,418
Posts

 
Drives: e92
Join Date: Jun 2005
Location: NE

iTrader: (4)

...and another thing, do your USB drives fully power up as of radio readiness or does the engine have to be running?
Appreciate 0
      01-04-2008, 11:42 PM   #78
bimmernupe
Captain
bimmernupe's Avatar
United_States
16
Rep
932
Posts

 
Drives: 08 E92 335i
Join Date: Oct 2006
Location: N. Va via DC (college) via NJ

iTrader: (1)

Garage List
2008 E92 335i  [0.00]
I posted this in a similar thread, so just for those that don't like searching.

I had the same issue with the 250GB Passport. It would not connect. The light would not stay bright.
So I ordered the Iomega eGo 250GB and it worked as soon as I plugged it into the port. It comes with the Y-cable, but I did not need supplemental power. Got it from Amazon.com for $169.99
It does take 10-20 sec for it to come up when you start the car. I did nothing special to my files. On my main HD I have my music set up in Artist/Album folders and transferred them this way to the Iomega and I am able to find my music just like when I have an Ipod hooked up.
The Passport I did reformat like the OP stated and it still did not work. The Iomega was plug and play. The Passport is 5400, but the Iomega does not say. Nor does it say on the site. If it is not not then so be it. I am able to scroll between artist and albums and main directory quickly. It also indexed quickly. I'm sold. By the way it is the 250GB Red model.
Just for those wondering about how to remove the IPod pouch from the underside of the arm rest. If open the pouch, you can lift up the back board. It is held in by velcro at the bottom. Underneath you will find four Torx type screws.
I only bring this up because I put the Euro split armrest in my car and decided to put the holder on the armrest.
__________________
MY FAMOUS INDEPTH ED TRIP REPORTED Welt 27.10.07 l Drop-Off Bremerhaven 05.11.07 l Port NJ 26.11.07 l PCD 21.12.07
2008 E92 335i Barbera Red l Saddle Brown l Aluminum Trim l ZSP l ZCW l ZPP l CA l Nav l HD Radio l 6MT l PDC l 6FL
Appreciate 0
      01-05-2008, 09:43 AM   #79
hov333
Captain
Armenia
23
Rep
959
Posts

 
Drives: 2008 e92 335xi
Join Date: Sep 2007
Location: Boston, MA

iTrader: (0)

Send a message via AIM to hov333
so the flash/hard drive will work with and without a folder hierarcy setup? I dont have so many songs and just want it to play from start to finish rather than select specific folders...
Appreciate 0
      01-05-2008, 04:21 PM   #80
bimmernupe
Captain
bimmernupe's Avatar
United_States
16
Rep
932
Posts

 
Drives: 08 E92 335i
Join Date: Oct 2006
Location: N. Va via DC (college) via NJ

iTrader: (1)

Garage List
2008 E92 335i  [0.00]
File system

Quote:
Originally Posted by hov333 View Post
so the flash/hard drive will work with and without a folder hierarcy setup? I dont have so many songs and just want it to play from start to finish rather than select specific folders...
The first choice I have when I open the USB in the I-Drive is Directory. This is where how I transferred the files to the drive appear. Then there are choices for artist, genre, playlist, album and there may be another choice or two.
Hope this answers your question.
__________________
MY FAMOUS INDEPTH ED TRIP REPORTED Welt 27.10.07 l Drop-Off Bremerhaven 05.11.07 l Port NJ 26.11.07 l PCD 21.12.07
2008 E92 335i Barbera Red l Saddle Brown l Aluminum Trim l ZSP l ZCW l ZPP l CA l Nav l HD Radio l 6MT l PDC l 6FL
Appreciate 0
      01-05-2008, 07:19 PM   #81
mid-corner fun
Major
United_States
15
Rep
1,418
Posts

 
Drives: e92
Join Date: Jun 2005
Location: NE

iTrader: (4)

Well, my hard drive research is coming to an end. The IOMagic 40GB drive from Staples works out of the box, although it's nowhere near the capacity I need for my collection. (~110GB).

Drives that did not work for me:

WD Passport 80GB 5400RPM
Simpletech 160GB 5400RPM
Iomega 120GB 4200RPM

These are all bus-powered, I'm not interested in supplemental power. I was surprised that the Iomega did not work but I'm attributing this to USB cable length, I'm keeping the drive and will try to find an extremely short USB cable and retry it at that time.

An interesting point, the only drive that worked in my car takes a regular USB -> USB cable (+10" length), all the non-working drives require mini-USB cables.

Last edited by mid-corner fun; 01-05-2008 at 11:51 PM.
Appreciate 0
      01-07-2008, 07:25 PM   #82
rugbyguy
New Member
0
Rep
22
Posts

 
Drives: E92 335
Join Date: Jun 2007
Location: Bala Cynwyd, PA

iTrader: (1)

Finally picked up a hard drive this afternoon. Grabbed a Toshiba 120GB (model HDDR120E02X, USB 1.1/2.0, 5400 rpm) from the local Microcenter on sale for $79.95. Plugged it into my computer and started ripping some files from flac to mp3 225kbps directly to the Toshiba. Drive was all ready formatted with fat32. After about 10 songs I decided to give it a try. Plugged the HD into my cars USB port using some generic 4' USB 1.1/2.0 cable. Argggg...the dreaded clicking spinning noise. Hmm, the cable seems a bit long and thin so decided to try the one supplied with the HD which was about 10" and much thicker. Success, no clicking noise and after about 5 seconds of spinning it's reading the files. However, either the drive, cable or USB connection is a bit temperamantal. I grabbed the drive while it was running to see if it fit in the ipod pouch and it starting clicking and not playing. Unplugged the HD and reattached and it seems to be working fine now. I'll be sure to update once I load some additional files and spend some time with it.

BTW, for the people interested in just using flash drives, Microcenter has their house branded 8GB drives for only $29.95
__________________
Appreciate 0
      01-09-2008, 05:03 PM   #83
tonyes
New Member
tonyes's Avatar
United_States
0
Rep
18
Posts

 
Drives: 2008 335i space gray
Join Date: Dec 2007
Location: Santa Clara, CA

iTrader: (0)

I received a WD Passport 80GB yesterday and loaded it with music and it worked fine for the first day. I thought I had a drive that would work fine with my 335I. On the next day it would not work, the blue light keeps on blinking and it will not connect. The drive is fine when i connect it to my computer. This drive came with a 11 inch cable. Any one have any ideas regarding this problem?
Appreciate 0
      01-09-2008, 05:54 PM   #84
Stin
New Member
United_States
0
Rep
9
Posts

 
Drives: E90 335I AW
Join Date: Dec 2007
Location: Seattle, WA

iTrader: (0)

I have the IOMagic 40GB drive and it works great. I do have a question, if I don't unplug the drive each time I am in the car, it will not recognize the connnection. Is this true for everyone?
Appreciate 0
      01-09-2008, 07:44 PM   #85
mid-corner fun
Major
United_States
15
Rep
1,418
Posts

 
Drives: e92
Join Date: Jun 2005
Location: NE

iTrader: (4)

Quote:
Originally Posted by Stin View Post
I have the IOMagic 40GB drive and it works great. I do have a question, if I don't unplug the drive each time I am in the car, it will not recognize the connnection. Is this true for everyone?
I have the same drive, no need to unplug it. However, it takes 20-30 seconds for the car to see the drive and resume playing where it left off.
Appreciate 0
      01-10-2008, 08:55 AM   #86
rugbyguy
New Member
0
Rep
22
Posts

 
Drives: E92 335
Join Date: Jun 2007
Location: Bala Cynwyd, PA

iTrader: (1)

Quote:
Originally Posted by tonyes View Post
I received a WD Passport 80GB yesterday and loaded it with music and it worked fine for the first day. I thought I had a drive that would work fine with my 335I. On the next day it would not work, the blue light keeps on blinking and it will not connect. The drive is fine when i connect it to my computer. This drive came with a 11 inch cable. Any one have any ideas regarding this problem?
My 120GB Toshiba started experiencing the same symptoms, needless to say it's going back and will try another.
__________________
Appreciate 0
      01-10-2008, 11:58 AM   #87
Stin
New Member
United_States
0
Rep
9
Posts

 
Drives: E90 335I AW
Join Date: Dec 2007
Location: Seattle, WA

iTrader: (0)

Quote:
Originally Posted by PeterM1 View Post
I have the same drive, no need to unplug it. However, it takes 20-30 seconds for the car to see the drive and resume playing where it left off.
So I have a dumb question, I see the light "on" on the drive when the car is off. Do I need to worry about the battery or any additional draw. Thanks for your help.
Appreciate 0
      01-10-2008, 01:10 PM   #88
mid-corner fun
Major
United_States
15
Rep
1,418
Posts

 
Drives: e92
Join Date: Jun 2005
Location: NE

iTrader: (4)

Quote:
Originally Posted by Stin View Post
So I have a dumb question, I see the light "on" on the drive when the car is off. Do I need to worry about the battery or any additional draw. Thanks for your help.
Wait 10mins after turning the car off, is the drive's light still on? If yes, it's not normal. Mine powers down after 10 (or 5?) mins.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:12 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST