E90Post
 


E92 Lighting
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Am I hearing Detonation?



Reply
 
Thread Tools Search this Thread
      11-22-2007, 03:13 PM   #1
RMRC
Lieutenant
RMRC's Avatar
5
Rep
473
Posts

Drives: 2011 E90 335d
Join Date: Nov 2006
Location: West

iTrader: (0)

Am I hearing Detonation?

I fear I may be experiencing a bit of detonation during full throttle 6k rpm or higher 1-2 shifts. When I go for a gear change I hear one ďpingĒ as when a car is pinging from detonation. Iím testing a tuning device and am wondering if you think what Iím hearing is detonation or something else? For the purpose of the question I wonít mention the manufacturer of the tuning device since Iím hoping for totally unbiased opinions as to what this may be. If you think itís detonation I want to take it out asap.

I've experienced the same thing on both Chevron 91 and Shell 91 so I don't think it's a case of bad gas.
Appreciate 0
      11-22-2007, 03:18 PM   #2
zenmaster
Lieutenant Colonel
United_States
20
Rep
1,628
Posts

Drives: '13 AH3
Join Date: Mar 2007
Location: Atlanta

iTrader: (1)

What is your AFR and boost at that RPM?
Appreciate 0
      11-22-2007, 03:27 PM   #3
Jeff@Eurobahn.us
Captain
Jeff@Eurobahn.us's Avatar
United_States
11
Rep
752
Posts

Drives: European
Join Date: Feb 2007
Location: USA

iTrader: (0)

Quote:
Originally Posted by reb03 View Post
I fear I may be experiencing a bit of detonation during full throttle 6k rpm or higher 1-2 shifts. When I go for a gear change I hear one ďpingĒ as when a car is pinging from detonation. Iím testing a tuning device and am wondering if you think what Iím hearing is detonation or something else? For the purpose of the question I wonít mention the manufacturer of the tuning device since Iím hoping for totally unbiased opinions as to what this may be. If you think itís detonation I want to take it out asap.

I've experienced the same thing on both Chevron 91 and Shell 91 so I don't think it's a case of bad gas.
Well if I am not mixing you up with another customer you are running a Turbo Tuner are you not? IF so you should bring it by the shop so we can take a listen with you. If there is any "detonation" it would the first that we have ever heard of so I doubt that is what you are hearing. But we also have a 6 speed car so we can compare with you and help figure out what that noise is

Jeff
Eurobahn
Appreciate 0
      11-22-2007, 03:27 PM   #4
san~man
Tired
san~man's Avatar
48
Rep
2,627
Posts

Drives: BMW-less
Join Date: Nov 2007
Location: USA

iTrader: (7)

Quote:
Originally Posted by zenmaster View Post
What is your AFR and boost at that RPM?
And timing too, if it's adjusted.
Appreciate 0
      11-22-2007, 04:12 PM   #5
Dan335i
Lieutenant Colonel
Dan335i's Avatar
18
Rep
1,788
Posts

Drives: 07 335i coupe 6MT,w/sp. pack.
Join Date: Oct 2007
Location: orange county NY

iTrader: (2)

Try throwing in some good octane booster,or if you can get 93 octane gas or even a gallon of 100 octane unleaded race fuel.Then if your ping, if thats what your hearing goes away you know you will need to use a higher octane gas if its available in your area.
Appreciate 0
      11-22-2007, 04:36 PM   #6
Terry335
Banned
United_States
42
Rep
2,587
Posts

Drives: 335i
Join Date: Jan 2007
Location: Socal

iTrader: (0)

I would add some race gas, and if it goes away it might be. Best option is scanning software.
Appreciate 0
      11-22-2007, 04:44 PM   #7
e.n335
Moderator
e.n335's Avatar
Austria
101
Rep
4,480
Posts

Drives: e93 ///M3 DCT, 07/2009
Join Date: Feb 2007
Location: Switzerland, ZH

iTrader: (0)

Quote:
Originally Posted by Terry335 View Post
I would add some race gas, and if it goes away it might be. Best option is scanning software.
If you are using OBDII software please tell , I need a good one and the cable.

Thanks,
Eugen
__________________
Not more than 500 chp for my daily driver. Well, ... .
Appreciate 0
      11-22-2007, 04:46 PM   #8
Terry335
Banned
United_States
42
Rep
2,587
Posts

Drives: 335i
Join Date: Jan 2007
Location: Socal

iTrader: (0)

Quote:
Originally Posted by e.n335 View Post
If you are using OBDII software please tell , I need a good one and the cable.

Thanks,
Eugen
I use Auterra Dynoscan and it works very well, make sure you get the newer version with the CAN and ISO bus, that way it will work on all 335s. The old version does not connect.

It does not read extended codes, but another company claims they will have extended software out early next year.
Appreciate 0
      11-22-2007, 04:48 PM   #9
e.n335
Moderator
e.n335's Avatar
Austria
101
Rep
4,480
Posts

Drives: e93 ///M3 DCT, 07/2009
Join Date: Feb 2007
Location: Switzerland, ZH

iTrader: (0)

+1

Thank you
__________________
Not more than 500 chp for my daily driver. Well, ... .
Appreciate 0
      11-22-2007, 05:13 PM   #10
RMRC
Lieutenant
RMRC's Avatar
5
Rep
473
Posts

Drives: 2011 E90 335d
Join Date: Nov 2006
Location: West

iTrader: (0)

Ok thanks guys. I will stop by the 76 in Newport Beach and get a few gallons of $7.99 100 octane to see if this goes away.

As Jeff suggested, I am trying the Turbo Tuner and my ECU has had a couple thousand miles with many WOTs to adjust. My concern is that the stock ECU isn't going rich enough at higher rpm and boost.

Jeff, if the 100 doesn't help I will swing by at your earliest convenience.

Now to get a scanning tool.
Appreciate 0
      11-22-2007, 05:21 PM   #11
Calgary Agent
Captain
Canada
7
Rep
703
Posts

Drives: '11 550i
Join Date: Oct 2007
Location: Calgary, Canada

iTrader: (0)

Garage List
2011 F10 550i  [0.00]
~subscribe~

Last edited by Calgary Agent; 11-22-2007 at 07:56 PM.
Appreciate 0
      11-22-2007, 05:23 PM   #12
Jeff@Eurobahn.us
Captain
Jeff@Eurobahn.us's Avatar
United_States
11
Rep
752
Posts

Drives: European
Join Date: Feb 2007
Location: USA

iTrader: (0)

We are here for you any time

Jeff
Eurobahn
Appreciate 0
      11-22-2007, 05:33 PM   #13
5soko
Brigadier General
5soko's Avatar
80
Rep
4,239
Posts

Drives: M5
Join Date: Aug 2007
Location: Brooklyn, NY

iTrader: (4)

without hearing it, its hard to say. but i have never heard of the turbo tuner causing PING.. take off the turbo tuner and see if its still there. 20 sec uninstall
drop by Jeff's shop see what up if anything.
Appreciate 0
      11-22-2007, 05:35 PM   #14
RiXst3r
RiXst3r's Avatar
158
Rep
6,510
Posts

Drives: M235i
Join Date: Sep 2006
Location: Ohio

iTrader: (14)

Send a message via AIM to RiXst3r
unplug the negative terminal on your battery for about an hour and let your ECU reset. Then try again.
Appreciate 0
      11-22-2007, 06:33 PM   #15
Jeff@Eurobahn.us
Captain
Jeff@Eurobahn.us's Avatar
United_States
11
Rep
752
Posts

Drives: European
Join Date: Feb 2007
Location: USA

iTrader: (0)

Quote:
Originally Posted by RiXst3r View Post
unplug the negative terminal on your battery for about an hour and let your ECU reset. Then try again.
That was going to be my next suggestion after pulling the TT and running without it for a day

jeff
Eurobahn
Appreciate 0
      11-22-2007, 07:02 PM   #16
RMRC
Lieutenant
RMRC's Avatar
5
Rep
473
Posts

Drives: 2011 E90 335d
Join Date: Nov 2006
Location: West

iTrader: (0)

So should I pull the TT and unplug the battery first or do you think I should try adding some 100 octane to see if it goes away? Realistically I won't mix 100 in every tank so maybe unplugging the neg terminal and resetting the ECU should be the first step...?
Appreciate 0
      11-22-2007, 07:36 PM   #17
5soko
Brigadier General
5soko's Avatar
80
Rep
4,239
Posts

Drives: M5
Join Date: Aug 2007
Location: Brooklyn, NY

iTrader: (4)

take off the TT and see if that helps. u can easily see if it is the issue that way. drive ur car around for a day or two and see what happens
Appreciate 0
      11-22-2007, 09:30 PM   #18
2e9x's
Major
2e9x's's Avatar
United_States
16
Rep
1,137
Posts

Drives: 335i ED 7/07
Join Date: Dec 2006
Location: A Sunny Place

iTrader: (2)

The other thought is to drive my car back to back with yours, and vice versa (since we have the same tune). It may be a normal sound you are hearing. Or it could be something else. I am around all week-end so let me know if you want to drive my car.

One of the nice things about the TT is that it is really easy to take out and experiment!
__________________
2010 Evo X - silver with a big, stupid wing on the back
2009 VW CC - Black/Black - with a 2011 328i on order to replace it - ED 8/1/11
Appreciate 0
      11-22-2007, 10:28 PM   #19
bman5150
Private First Class
2
Rep
154
Posts

Drives: 2011 335i XDrive
Join Date: Apr 2007
Location: Cowtown

iTrader: (0)

subscribing
Appreciate 0
      11-22-2007, 10:29 PM   #20
midlife
ocasionally in crisis
midlife's Avatar
28
Rep
2,359
Posts

Drives: '08 335i cabrio
Join Date: Jun 2007
Location: ..........

iTrader: (0)

Quote:
Originally Posted by Jeff@Eurobahn.us View Post
Well if I am not mixing you up with another customer you are running a Turbo Tuner are you not? IF so you should bring it by the shop so we can take a listen with you. If there is any "detonation" it would the first that we have ever heard of so I doubt that is what you are hearing. But we also have a 6 speed car so we can compare with you and help figure out what that noise is

Jeff
Eurobahn
would not the ECU throw u into LIMP mode before it lets the engine ping/detonate/ damage itself ??
__________________
If your car isn't scary - it's just not fast enough !
RPI IC / UR catless DPs / JB3 2.0 beta / UR CAI / Quaife LSD / Snow Methanol Injection / VK oil cooler upgrade / Forge DVs /
M3 rear sway / Riss catch can / Paddle shifting 6AT / M Sport steering wheel / Logic 7 / Dunlop Direzza Z1 255/235 /
Appreciate 0
      11-22-2007, 10:37 PM   #21
RMRC
Lieutenant
RMRC's Avatar
5
Rep
473
Posts

Drives: 2011 E90 335d
Join Date: Nov 2006
Location: West

iTrader: (0)

I just unplugged the neg terminal on the battery and left the TT on. After an hour I will hook the battery back up and see what happens tomorrow. I've had the TT on and off several times and never heard this pinging sound without the TT installed. I'm certain of this as I beat the piss out of the car without it on since it feels so much slower.

Will report back tomorrow after the ECU reset. I hope this is all that's needed.
Appreciate 0
      11-22-2007, 10:39 PM   #22
RMRC
Lieutenant
RMRC's Avatar
5
Rep
473
Posts

Drives: 2011 E90 335d
Join Date: Nov 2006
Location: West

iTrader: (0)

Quote:
Originally Posted by White05X3 View Post
The other thought is to drive my car back to back with yours, and vice versa (since we have the same tune). It may be a normal sound you are hearing. Or it could be something else. I am around all week-end so let me know if you want to drive my car.

One of the nice things about the TT is that it is really easy to take out and experiment!
Thanks, I may take you up on this. Let's see what happens after the ECU reset tonight.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 03:09 AM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST