E90Post
 


TireRack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Am I hearing Detonation?



Reply
 
Thread Tools Search this Thread
      11-22-2007, 09:39 PM   #23
midlife
ocasionally in crisis
 
midlife's Avatar
 
Drives: '08 335i cabrio
Join Date: Jun 2007
Location: ..........

Posts: 2,359
iTrader: (0)

Quote:
Originally Posted by RiXst3r View Post
unplug the negative terminal on your battery for about an hour and let your ECU reset. Then try again.
besides having to reset the clock & date, any other consequences when unplugging the battery?
__________________
If your car isn't scary - it's just not fast enough !
RPI IC / UR catless DPs / JB3 2.0 beta / UR CAI / Quaife LSD / Snow Methanol Injection / VK oil cooler upgrade / Forge DVs /
M3 rear sway / Riss catch can / Paddle shifting 6AT / M Sport steering wheel / Logic 7 / Dunlop Direzza Z1 255/235 /
midlife is offline  
0
Reply With Quote
      11-22-2007, 09:44 PM   #24
RMRC
Lieutenant
 
RMRC's Avatar
 
Drives: 2011 E90 335d
Join Date: Nov 2006
Location: West

Posts: 473
iTrader: (0)

Quote:
Originally Posted by midlife View Post
besides having to reset the clock & date, any other consequences when unplugging the battery?
Ha, I'll let you know since my battery has been unplugged for 20 mins now.
RMRC is offline  
0
Reply With Quote
      11-23-2007, 01:07 AM   #25
Tuned335i
Major
 
Drives: E92 335i
Join Date: Jun 2007
Location: World of Torque

Posts: 1,310
iTrader: (0)

Quote:
Originally Posted by midlife View Post
would not the ECU throw u into LIMP mode before it lets the engine ping/detonate/ damage itself ??
Quote:
Originally Posted by lumi335 View Post
i was thinking the same thing
+1

I think you get a few pings and then it yanks the timing back and throws a limp mode. I don't think it can predict detonation, only sense it and react. That's what happened the first time out with my PROcede on the crap gas we get here in Phoenix. I immediately went to a 100/91 mix since it's readily available all over town and I haven't had a limp mode since that first day
__________________
Torque - The One You Love...
Tuned335i is offline  
0
Reply With Quote
      11-23-2007, 11:19 AM   #26
Jeff@Eurobahn.us
Captain
 
Jeff@Eurobahn.us's Avatar
 
Drives: European
Join Date: Feb 2007
Location: USA

Posts: 752
iTrader: (0)

Great suggestions all! The computer and sensors on this vehicle are extremely sensitive to knock and ping. I feel we have perhaps either bad gas or something else going on. The car would definitely go limp if detonations was occuring at a level that is audible.

There are a couple of sounds at wot that I hear now and then when shifting that could be mistaken for ping.

Jeff
Eurobahn
Jeff@Eurobahn.us is offline   United_States
0
Reply With Quote
      11-23-2007, 11:35 AM   #27
Former_Boosted_IS
Major General
 
Drives: 4 Wheels
Join Date: Aug 2007
Location: Planet Earth!

Posts: 5,180
iTrader: (15)

If this guy is getting audible detonation, shouldn't he discontinue driving WOT immediately until the exact reason can be determined. This can be engine ending if he is hearing the detonation from the driver's seat of a very well insulated car.
Former_Boosted_IS is offline  
0
Reply With Quote
      11-23-2007, 02:03 PM   #28
RMRC
Lieutenant
 
RMRC's Avatar
 
Drives: 2011 E90 335d
Join Date: Nov 2006
Location: West

Posts: 473
iTrader: (0)

Well it appears my ECU just needed to be reset. This morning in relatively cool 60 degree temps I did several WOT 0-60 blasts with 6k rpm + 1-2 shifts and could not duplicate the pinging I heard before. I'm not sure if the cool temps had any affect.

Someone asked about any other consequences related to unplugging the battery - the only thing I had to reset was the clock. I lost the data for avg mph, avg mpg and my trip mileage but other than that all my sirius and regular radio stations remained.

It could be in my head but the car may even seem a little stronger than before the ECU reset.

Thanks for all the suggestions. It's great to have so many knowledgeable gearheads on this forum.

Last edited by RMRC; 11-23-2007 at 04:32 PM.
RMRC is offline  
0
Reply With Quote
      11-23-2007, 02:30 PM   #29
Jeff@Eurobahn.us
Captain
 
Jeff@Eurobahn.us's Avatar
 
Drives: European
Join Date: Feb 2007
Location: USA

Posts: 752
iTrader: (0)

Smile

Quote:
Originally Posted by reb03 View Post
Well it appears my ECU just needed to be reset. This morning in relatively cool 60 degree temps I did several WOT 0-60 blasts with 6k rpm + 1-2 shifts and could not duplicate the pinging I heard before. I'm not sure if the cool temps had any affect.

Someone asked about any other consequences related to unplugging the battery - the only thing I had to reset was the clock. I lost the data for avg mph, avg mpg and my trip mileage but other than that all my sirius and regular radio stations remained.

It could be in my head but the car may even seem a little stronger than before the ECU reset.

Thanks for all the suggestions. It's great to have such a wealth of knowledgeable gearheads on this forum.
Great news I would still bet you might have gotten some bad gas (:

Glad the reset let you re-adapt!

Jeff
Eurobahn
Jeff@Eurobahn.us is offline   United_States
0
Reply With Quote
      11-23-2007, 02:39 PM   #30
wahoo
Bangin' my head against the wall
 
Drives: '08 335i
Join Date: Jul 2005
Location: atlanta

Posts: 455
iTrader: (0)

I hear dead people...
wahoo is offline  
0
Reply With Quote
      11-23-2007, 04:09 PM   #31
midlife
ocasionally in crisis
 
midlife's Avatar
 
Drives: '08 335i cabrio
Join Date: Jun 2007
Location: ..........

Posts: 2,359
iTrader: (0)

Quote:
Originally Posted by Tuned335i View Post
+1

I think you get a few pings and then it yanks the timing back and throws a limp mode. I don't think it can predict detonation, only sense it and react. That's what happened the first time out with my PROcede on the crap gas we get here in Phoenix. I immediately went to a 100/91 mix since it's readily available all over town and I haven't had a limp mode since that first day
i am curious. so u used crap gas, got a ping or two, then your car went into limp mode correct?

i never got a limp mode (hope i never do), but when u got your limp mode - what did you do, shut it down and wait say 5 minutes?
then all is fine, and u start it right up like nothing happened?

thanks
__________________
If your car isn't scary - it's just not fast enough !
RPI IC / UR catless DPs / JB3 2.0 beta / UR CAI / Quaife LSD / Snow Methanol Injection / VK oil cooler upgrade / Forge DVs /
M3 rear sway / Riss catch can / Paddle shifting 6AT / M Sport steering wheel / Logic 7 / Dunlop Direzza Z1 255/235 /
midlife is offline  
0
Reply With Quote
      11-23-2007, 04:36 PM   #32
RMRC
Lieutenant
 
RMRC's Avatar
 
Drives: 2011 E90 335d
Join Date: Nov 2006
Location: West

Posts: 473
iTrader: (0)

Quote:
Originally Posted by Jeff@Eurobahn.us View Post
Great news I would still bet you might have gotten some bad gas (:
Jeff
Eurobahn
You'd think but it's the same gas as yesterday and I've heard the pinging with both Chevron 91 and Shell 91 and on different tanks. Let's just hope the ECU had to reset and I don't hear it again.
RMRC is offline  
0
Reply With Quote
      11-26-2007, 01:56 AM   #33
Beer Goggles
First Lieutenant
 
Drives: 2007 335i E92, 6MT, Sport
Join Date: Aug 2007
Location: Riverside, CA

Posts: 311
iTrader: (0)

Detonation is never a "ping" it sounds like bee bees in a can. Are you sure you just weren't hearing the BOV? If it's auto you should be able to hear it pretty well and more so with a tuning option. I was pretty surprised to hear that durning a test drive. I've not heard it with my MT.
Beer Goggles is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:56 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST