E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > Issues with LOGIC 7



Reply
 
Thread Tools Search this Thread
      04-14-2014, 02:21 PM   #1
EZ_TUR90
Ez tur90
 
EZ_TUR90's Avatar
 
Drives: E90 & E92
Join Date: Jul 2008
Location: San Francisco

Posts: 3,089
iTrader: (10)

Issues with LOGIC 7

I recently had my car serviced for the first time at an unauthorized dealership and I have some concerns. The car is 2008 e92 335i.

The car was at the shop for service, and maintenance. A day into it, I received a call from the shop stating that my battery harness was corroded and they would need to replace it. Two days later another call, and this time my logic7 amplifier had been damaged and would also need to be replaced. So another day went on and the shop asked if I can bring my key in because the car would need to be "coded".

Now here are the issues I am having, however I am hesitate to return to the shop because it took them about 2 weeks to have the car ready:

-One of my keys no longer locks/ unlocks the car. Doesn't function other then when inserted into the slot inside car. (I don't have comfort access)

-The car has issues cranking when starting up, and today the low battery light came on (I'm guessing battery damage due to corrosion)

-Most Important***** When the settings are switched for Logic7 it would regularly pause then the setting would be applied. An obvious change for each setting. Now, it no longer pauses and I can't tell the difference of each setting.
(the setting which I am referring to is Off, Concert Hall, Theater)

I have attached photos of the amp in my trunk that I took prior to posting, I can't tell if the correct amp was used to replace my damaged amp.
Attached Images
     
__________________

Last edited by EZ_TUR90; 04-14-2014 at 02:57 PM.
EZ_TUR90 is offline   Armenia
0
Reply With Quote
      04-14-2014, 08:05 PM   #2
EZ_TUR90
Ez tur90
 
EZ_TUR90's Avatar
 
Drives: E90 & E92
Join Date: Jul 2008
Location: San Francisco

Posts: 3,089
iTrader: (10)

anyone?
__________________
EZ_TUR90 is offline   Armenia
0
Reply With Quote
      04-14-2014, 08:10 PM   #3
itsstock02
Private First Class
 
Drives: 2008 335i
Join Date: Aug 2013
Location: MI

Posts: 162
iTrader: (2)

The thing on the left is your satellite radio and the right is bluetooth. The amp is on the opposite side of your battery (drivers side) underneath that little grey cover.

Did you ever have the recall done for the positive battery cable?
itsstock02 is online now  
0
Reply With Quote
      04-14-2014, 08:19 PM   #4
EZ_TUR90
Ez tur90
 
EZ_TUR90's Avatar
 
Drives: E90 & E92
Join Date: Jul 2008
Location: San Francisco

Posts: 3,089
iTrader: (10)

Quote:
Originally Posted by itsstock02 View Post
The thing on the left is your satellite radio and the right is bluetooth. The amp is on the opposite side of your battery (drivers side) underneath that little grey cover.

Did you ever have the recall done for the positive battery cable?
The car is back at the dealer today for faulty water pump. I'll snap pics of the amp once I get the car back.

Didn't know there was a recall on the battery cable. Is that what could have caused the cable to corrode?
__________________
EZ_TUR90 is offline   Armenia
0
Reply With Quote
      04-14-2014, 08:20 PM   #5
itsstock02
Private First Class
 
Drives: 2008 335i
Join Date: Aug 2013
Location: MI

Posts: 162
iTrader: (2)

possibly

http://www.e90post.com/forums/showthread.php?t=804545
itsstock02 is online now  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:09 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST