E90Post
 


Extreme Power House
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > limp mode with catless downpipes - procede v1.47 related?



Reply
 
Thread Tools Search this Thread
      11-25-2007, 07:44 PM   #1
nico335
Guest
 
Drives:

Posts: n/a
limp mode with catless downpipes - procede v1.47 related?

i had my UR catless downpipes installed about 2-3 weeks ago and ever since, i have been getting limp modes and or CELs. the CEL is not surprising - i know, especially with catless DPs, that you will get them for sure but is the limp mode normal also?

i've only gotten limp mode two times before the catless DPs but that was before i had the LBT map. after the DPs were put on i uploaded the LBT map as well, thinking it would fix the limp mode that i get more now, but it still didnt fix anything.

so basically, is it because i have catless downpipes that im going into limp? or would a DP tune with v 1.47 (which i doubt will never come out) maybe fix it, if there was such thing available?

thanks in advance guys
 
0
Reply With Quote
      11-25-2007, 10:19 PM   #2
nico335
Guest
 
Drives:

Posts: n/a
bump. please help...
 
0
Reply With Quote
      11-25-2007, 10:24 PM   #3
shiv@vishnu
Tuner
 
Drives: X1, 335i
Join Date: Sep 2006
Location: SF Bay, CA

Posts: 17,616
iTrader: (0)

Under what condition is the limp mode being triggered? Running full catless is somewhat of a crapshoot at this point, IMHO. As soon as we get our catless DPs from Riss, we'll calibrate a map and get it sorted out. Until then, I'm kinda guessing.

shiv
shiv@vishnu is offline   United_States
0
Reply With Quote
      11-25-2007, 10:29 PM   #4
midlife
ocasionally in crisis
 
midlife's Avatar
 
Drives: '08 335i cabrio
Join Date: Jun 2007
Location: ..........

Posts: 2,359
iTrader: (0)

Quote:
Originally Posted by that guy nico View Post
i had my UR catless downpipes installed about 2-3 weeks ago and ever since, i have been getting limp modes and or CELs. the CEL is not surprising - i know, especially with catless DPs, that you will get them for sure but is the limp mode normal also?

i've only gotten limp mode two times before the catless DPs but that was before i had the LBT map. after the DPs were put on i uploaded the LBT map as well, thinking it would fix the limp mode that i get more now, but it still didnt fix anything.

so basically, is it because i have catless downpipes that im going into limp? or would a DP tune with v 1.47 (which i doubt will never come out) maybe fix it, if there was such thing available?

thanks in advance guys
where in ca are u that u need a LBT map?
i think u should insist that PROCEED fix your problem, as opposed to trying to get help in this forum. proceed should give u a faster and a better "fix".

good luck
__________________
If your car isn't scary - it's just not fast enough !
RPI IC / UR catless DPs / JB3 2.0 beta / UR CAI / Quaife LSD / Snow Methanol Injection / VK oil cooler upgrade / Forge DVs /
M3 rear sway / Riss catch can / Paddle shifting 6AT / M Sport steering wheel / Logic 7 / Dunlop Direzza Z1 255/235 /
midlife is offline  
0
Reply With Quote
      11-25-2007, 10:30 PM   #5
e90AW335i
Major General
 
Drives: e90 335i
Join Date: Sep 2007
Location: ......

Posts: 6,608
iTrader: (4)

Quote:
Originally Posted by midlife View Post
where in ca are u that u need a LBT map?
i think u should insist that PROCEED fix your problem, as opposed to trying to get help in this forum. proceed should give u a faster and a better "fix".

good luck
e90AW335i is offline   United_States
0
Reply With Quote
      11-25-2007, 10:30 PM   #6
shiv@vishnu
Tuner
 
Drives: X1, 335i
Join Date: Sep 2006
Location: SF Bay, CA

Posts: 17,616
iTrader: (0)

Quote:
Originally Posted by midlife View Post
where in ca are u that u need a LBT map?
i think u should insist that PROCEED fix your problem, as opposed to trying to get help in this forum. proceed should give u a faster and a better "fix".

good luck
huh?
shiv@vishnu is offline   United_States
0
Reply With Quote
      11-25-2007, 10:31 PM   #7
e90AW335i
Major General
 
Drives: e90 335i
Join Date: Sep 2007
Location: ......

Posts: 6,608
iTrader: (4)

Quote:
Originally Posted by shiv@vishnu View Post
huh?
didnt really make sense to me either....
e90AW335i is offline   United_States
0
Reply With Quote
      11-25-2007, 10:46 PM   #8
B00sted335BMW
Banned
 
Drives: Boosted
Join Date: Nov 2007
Location: NY

Posts: 173
iTrader: (0)

wwwhhaammmmmiiiiiiiiiiiiii.................:confus ed2
B00sted335BMW is offline  
0
Reply With Quote
      11-25-2007, 11:40 PM   #9
l4wr3nc3
The Law.
 
l4wr3nc3's Avatar
 
Drives: BMW
Join Date: Apr 2005
Location: Rowland Heights, CA

Posts: 14,281
iTrader: (17)

Send a message via AIM to l4wr3nc3
Maybe if you switch PROCEED with Vishnu it kinda makes more sense, although im still
__________________

2008 Lotus Exige S240 | 2007 BMW 335i
l4wr3nc3 is offline   Taiwan
0
Reply With Quote
      11-26-2007, 01:05 AM   #10
jerrygarcia
Lieutenant
 
Drives: 335 sedan eventually
Join Date: Sep 2006
Location: Houston

Posts: 491
iTrader: (0)

obviously midlife did not read shiv's post. LIke it says, when they get their catless dp they will develop a map for the dp. Until then the proceede/dp cars will have to wait.
__________________
jerrygarcia is offline  
0
Reply With Quote
      11-26-2007, 01:17 AM   #11
ArmyBimmerDude
Major General
 
ArmyBimmerDude's Avatar
 
Drives: Lola
Join Date: Nov 2006
Location: Georgia

Posts: 5,503
iTrader: (3)

Garage List
Send a message via AIM to ArmyBimmerDude Send a message via Yahoo to ArmyBimmerDude
Quote:
Originally Posted by kyleh4852 View Post
didnt really make sense to me either....
+1
__________________
2007 E92 Montego Blue 335i
ArmyBimmerDude is offline   United_States
0
Reply With Quote
      11-26-2007, 01:24 AM   #12
Neema
Major General
 
Neema's Avatar
 
Drives: a few BMWs
Join Date: Dec 2006
Location: SoCal

Posts: 7,224
iTrader: (12)

shiiiiiiii nicos going limp after he's done givin his girl some DP lovin? haha
__________________

LTMW Widebody+1M front bumper+Slek CF Lip|M3 Hood|StopTech BBK|M-Sport Rear Bumper+DD CF Diffuser|Custom Recaro Seats|KW V2|BavX LS3|M3 Side Skirts+Custom CF Lip|BBS CHR 19x10.5+BBS Lugs|LCI Taillights|RD Sport Anti-Sway Bars|GIAC S2|ER Intercooler+CF Shroud+Charge Pipe|Tial BOV|Injen Intake|MS downpipes|Custom Exhaust|BMS Oil Catch Can|M3 DCT wheel+TiD CF Paddles|BMW CF Trunk Spoiler|Aluminum Pedals
Neema is offline   United_States
0
Reply With Quote
      11-26-2007, 01:53 AM   #13
nico335
Guest
 
Drives:

Posts: n/a
Quote:
Originally Posted by shiv@vishnu View Post
Under what condition is the limp mode being triggered? Running full catless is somewhat of a crapshoot at this point, IMHO. As soon as we get our catless DPs from Riss, we'll calibrate a map and get it sorted out. Until then, I'm kinda guessing.

shiv
not sure what you mean when you say condition (weather, engine load, etc etc) but it happens randomly if im lets say, just crusing at 45mph in 4th or 5th gear and also seems to happen SOMETIMES after i redline 2 or 3 gears.

im planning on taking the procede out to see if i can produce the limp with the DPs only. that way it will let me know if its the downpipes or procede.

i also forgot to say that after i installed the DPs and i started encountering the limps, i disconnected the battery for 16 minutes (to reset the ECU) and i did some hard driving afterwards but still got the limp

the CEL usually happens after i restart the car to clear the limp mode. when i turn it off theres no service engine soon light but when i turn the car back on it shows up.

sometimes when i get the limp, though, the CEL also turns on at the same time....


i dont know, its all confusing but i think once V2 gets here it SHOULD fix it but who knows?
 
0
Reply With Quote
      11-26-2007, 03:14 AM   #14
M&M
Captain
 
M&M's Avatar
 
Drives: E92 M3 Competition Pack
Join Date: Mar 2007
Location: Johannesburg, South Africa

Posts: 661
iTrader: (0)

V2 won't fix it. You are getting errors 420 & 430, which are catalyst efficiency errors. You need to buy some cat cheaters and thread them into youe rear 02 sensors on each bank.
M&M is offline   South Africa
0
Reply With Quote
      11-26-2007, 03:15 AM   #15
nico335
Guest
 
Drives:

Posts: n/a
Quote:
Originally Posted by M&M View Post
V2 won't fix it. You are getting errors 420 & 430, which are catalyst efficiency errors. You need to buy some cat cheaters and thread them into youe rear 02 sensors on each bank.
where can i get them, and which ones?

wonder if this would fix the limp mode problem as well...
 
0
Reply With Quote
      11-26-2007, 03:56 AM   #16
shiv@vishnu
Tuner
 
Drives: X1, 335i
Join Date: Sep 2006
Location: SF Bay, CA

Posts: 17,616
iTrader: (0)

Quote:
Originally Posted by that guy nico View Post
where can i get them, and which ones?

wonder if this would fix the limp mode problem as well...
Are you getting limp mode right after WOT shifts near redline? If so, you catless system may be generating excessive boost pressure in the intercooler pipe once the throttle closes. We addressed this in the mapping with v2. Never really had to do with with v1 due to the reduced boost pressures it runs above 5500rpm. But it is conceivable that with no cats in the system, boost can go a bit unchecked. Try the o2 sensor cheats first. They WILL fix the 420 and 430 catalyst inefficiency codes you are getting. If the limp is still induced, we can modify a v1 map to address that. But I suspect we will get dps on our car before then and see for ourselves what is needed.

Shiv
shiv@vishnu is offline   United_States
0
Reply With Quote
      11-26-2007, 04:22 AM   #17
nico335
Guest
 
Drives:

Posts: n/a
Quote:
Originally Posted by shiv@vishnu View Post
Are you getting limp mode right after WOT shifts near redline? If so, you catless system may be generating excessive boost pressure in the intercooler pipe once the throttle closes. We addressed this in the mapping with v2. Never really had to do with with v1 due to the reduced boost pressures it runs above 5500rpm. But it is conceivable that with no cats in the system, boost can go a bit unchecked. Try the o2 sensor cheats first. They WILL fix the 420 and 430 catalyst inefficiency codes you are getting. If the limp is still induced, we can modify a v1 map to address that. But I suspect we will get dps on our car before then and see for ourselves what is needed.

Shiv
the limp comes on after the WOT shifts near redline when i am just cruising at normal speeds (35-50mph).

i'll look into the o2 sensor cheats and i will let you, or whomever it may concern - know if the limps go away
 
0
Reply With Quote
      12-10-2007, 11:33 PM   #18
nico335
Guest
 
Drives:

Posts: n/a
well had my procede removed today and just wanted to say that im no longer getting limp or cel. this, of course, was after 30 minutes of hard driving. ill check again tomorrow to see if theres anything but i highly doubt it....
 
0
Reply With Quote
      12-10-2007, 11:41 PM   #19
nico335
Guest
 
Drives:

Posts: n/a
oh yeah and what i dont get is that the codes i was throwing were because of the downpipes but without procede im not getting them anymore
 
0
Reply With Quote
      12-11-2007, 12:17 AM   #20
shiv@vishnu
Tuner
 
Drives: X1, 335i
Join Date: Sep 2006
Location: SF Bay, CA

Posts: 17,616
iTrader: (0)

Quote:
Originally Posted by that guy nico View Post
the limp comes on after the WOT shifts near redline when i am just cruising at normal speeds (35-50mph).

i'll look into the o2 sensor cheats and i will let you, or whomever it may concern - know if the limps go away
The limp mode is caused by an intercooler pressure spike that occurs near redline when the throttle closes. The more boost pressure you run when the throttle starts to close, the bigger the pressure spike will be. You don't get it without the PROcede because you are back to running low/stock-like boost pressures.

The v1.47 map does not have any mapping for spike suppression because it is not designed to run much boost above 6000rpm. But with downpipes, the lack of exhaust backpressure allows boost to creep up a bit higher than intended, hence the intercooler pressure spike and resultant code.

v1.48 will incorporate the spike suppression mapping (like v2.x) and will fix the issue you are seeing.

Shiv
shiv@vishnu is offline   United_States
0
Reply With Quote
      12-11-2007, 01:11 AM   #21
nico335
Guest
 
Drives:

Posts: n/a
Quote:
Originally Posted by shiv@vishnu View Post

v1.48 will incorporate the spike suppression mapping (like v2.x) and will fix the issue you are seeing.

Shiv
nice! i actually already have V2 but just havent put it on yet (have to bring the car in for service).

so with the 2.0.2 map... i shouldnt be getting those limp/cels anymore? i have an auto btw...
 
0
Reply With Quote
      12-11-2007, 01:15 AM   #22
shiv@vishnu
Tuner
 
Drives: X1, 335i
Join Date: Sep 2006
Location: SF Bay, CA

Posts: 17,616
iTrader: (0)

Quote:
Originally Posted by that guy nico View Post
nice! i actually already have V2 but just havent put it on yet (have to bring the car in for service).

so with the 2.0.2 map... i shouldnt be getting those limp/cels anymore? i have an auto btw...
6AT huh? Ask me that tomorrow

Shiv
shiv@vishnu is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:38 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST