E90Post
 


MINHS Auto Care Center
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Dynamic Stability Control



Reply
 
Thread Tools Search this Thread
      06-21-2014, 09:35 AM   #1
matthatchett
Private
matthatchett's Avatar
0
Rep
69
Posts

 
Drives: 2006 BMW 325i
Join Date: Apr 2013
Location: Columbus, Indiana

iTrader: (0)

Dynamic Stability Control

BIMMERPOST
     Featured on BIMMERPOST.com
Any ideas as to why my DSC is CONSTANTLY kicking on and causing me to lose power? Where would you look first?
Appreciate 0
      06-21-2014, 10:31 AM   #2
Gizm0
Major
Gizm0's Avatar
United_States
31
Rep
1,478
Posts

 
Drives: 08 e92 335i 6mt
Join Date: Jan 2013
Location: Virginia

iTrader: (1)

Better tires
Appreciate 0
      06-21-2014, 10:35 AM   #3
GB-335xiCoupe
Libertarian
GB-335xiCoupe's Avatar
United_States
37
Rep
1,369
Posts

 
Drives: his wife crazy.
Join Date: Sep 2013
Location: Green Bay area

iTrader: (0)

DME might just need a reset.

Or try turning it off completely (hold the button down for a while, until it displays

Drive around a bit and then turn it back on.
__________________
2011 335xi Coupe Black Sapphire Metallic (e92/N55/ZPP/ZCW/Vishnu Procede, Alpina Flash)
Bought 08/09/2013@53,340mi Current 12/17/2014@104,100mi
Fail(s): tstat hous/water pump 89k http://www.e90post.com/forums/showpo...57&postcount=9
Walnut blast 101k, Transmission/Transfer Case Fluid 103k
Appreciate 0
      06-21-2014, 10:43 AM   #4
GB-335xiCoupe
Libertarian
GB-335xiCoupe's Avatar
United_States
37
Rep
1,369
Posts

 
Drives: his wife crazy.
Join Date: Sep 2013
Location: Green Bay area

iTrader: (0)

Quote:
Originally Posted by Gizm0 View Post
Better tires
^ or this. But I would think that's pretty obvious if that were the problem.
Your car isn't ridiculously stanced, is it?
__________________
2011 335xi Coupe Black Sapphire Metallic (e92/N55/ZPP/ZCW/Vishnu Procede, Alpina Flash)
Bought 08/09/2013@53,340mi Current 12/17/2014@104,100mi
Fail(s): tstat hous/water pump 89k http://www.e90post.com/forums/showpo...57&postcount=9
Walnut blast 101k, Transmission/Transfer Case Fluid 103k
Appreciate 0
      06-30-2014, 02:22 AM   #5
matthatchett
Private
matthatchett's Avatar
0
Rep
69
Posts

 
Drives: 2006 BMW 325i
Join Date: Apr 2013
Location: Columbus, Indiana

iTrader: (0)

It started out just kicking on randomly. Now it is constantly kicking on. It's to the point where I turn it off as soon as I get in the car. 5 minutes later my dash looks like a Christmas tree with ABS, BRAKE, and DSC lights all on. I'm starting to lean towards a wheel speed sensor but looking for input.
Appreciate 0
      06-30-2014, 04:28 AM   #6
Gizm0
Major
Gizm0's Avatar
United_States
31
Rep
1,478
Posts

 
Drives: 08 e92 335i 6mt
Join Date: Jan 2013
Location: Virginia

iTrader: (1)

Wheel speed sensor or yaw rate sensor...
Appreciate 0
      06-30-2014, 05:06 AM   #7
Dark_Knight_335
Came to the N55 Darkside
Dark_Knight_335's Avatar
United_States
156
Rep
10,698
Posts

 
Drives: 2011 335 E93 M-Sport
Join Date: May 2010
Location: NY/NJ

iTrader: (27)

Get an LSD- problem solved

JK, it seems you have another issue- but it definitely doesn't hurt to have one (an LSD that is!)
Appreciate 0
      06-30-2014, 06:26 AM   #8
juliano
New Member
0
Rep
21
Posts

 
Drives: E90, 320d, Touring
Join Date: Jan 2012
Location: UK

iTrader: (0)

..wheel alignment checked?
Appreciate 0
      07-02-2014, 11:38 AM   #9
matthatchett
Private
matthatchett's Avatar
0
Rep
69
Posts

 
Drives: 2006 BMW 325i
Join Date: Apr 2013
Location: Columbus, Indiana

iTrader: (0)

Wheel alignment was just done about 3 months ago. I'm reading through a bunch of threads about this but none of them seem to have the issue of their DSC actually kicking on. I can't even drive the car unless I turn the DSC off. Then all of the lights come on after a few minutes.
Appreciate 0
      07-02-2014, 12:35 PM   #10
docedkin
New Member
0
Rep
8
Posts

 
Drives: '15 435i, M-Sport, October ED
Join Date: Jun 2014
Location: Blossvale, NY

iTrader: (0)

Put a Battery Tender on for a few hours and see if it makes a difference. Sometimes a weak battery can cause odd fault code indications.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:10 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST