E90Post
 


GTB Performance
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N55 Turbo Engine Tuning and Exhaust Modifications - 335i Tuning > RESOLVED: JB4 ISO Waterpump (fix in 1st post)



Reply
 
Thread Tools Search this Thread
      06-06-2014, 01:37 AM   #1
JcLusso
JcLusso
 
JcLusso's Avatar
 
Drives: 2011 BMW 335i xDrive
Join Date: Mar 2011
Location: Bethpage NY

Posts: 205
iTrader: (1)

Unhappy RESOLVED: JB4 ISO Waterpump (fix in 1st post)

I saw a thread about this, but the fix wasn't clear. All of a sudden my water pump randomly comes on and then kills the battery. This happens everytime I shut off and lock the car now. Is there a fix besides unplugging the boost sensor.... I recently installed the Flex Fuel adapter but I believe this was happening on a less often basis prior since I recently have been seeing my car display the "battery drain icon" in the dash sometimes.

Resolved: Terry Emailed me a fix this morning
__________________

Car: 2011 BMW 335i xDrive
My Websites: Exit Monitor | Boostgram | Cache Ventures

Last edited by JcLusso; 06-06-2014 at 10:19 AM.
JcLusso is offline   United_States
0
Reply With Quote
      06-06-2014, 08:07 AM   #2
JETmn
Lieutenant
 
Drives: 2011 335i xDrive Msport
Join Date: Apr 2013
Location: Minneapolis

Posts: 445
iTrader: (0)

Do you have the oil catch can? That is the only time I have seen this reported is when they are used in conjunction.
JETmn is offline   United_States
0
Reply With Quote
      06-06-2014, 10:13 AM   #3
JcLusso
JcLusso
 
JcLusso's Avatar
 
Drives: 2011 BMW 335i xDrive
Join Date: Mar 2011
Location: Bethpage NY

Posts: 205
iTrader: (1)

Quote:
Originally Posted by JETmn View Post
Do you have the oil catch can? That is the only time I have seen this reported is when they are used in conjunction.
I do not.
__________________

Car: 2011 BMW 335i xDrive
My Websites: Exit Monitor | Boostgram | Cache Ventures
JcLusso is offline   United_States
0
Reply With Quote
      06-06-2014, 10:18 AM   #4
JcLusso
JcLusso
 
JcLusso's Avatar
 
Drives: 2011 BMW 335i xDrive
Join Date: Mar 2011
Location: Bethpage NY

Posts: 205
iTrader: (1)

Good News Terry emailed me a fix. See first post.
__________________

Car: 2011 BMW 335i xDrive
My Websites: Exit Monitor | Boostgram | Cache Ventures
JcLusso is offline   United_States
0
Reply With Quote
      06-13-2014, 02:11 PM   #5
ZeroSix
Private First Class
 
ZeroSix's Avatar
 
Drives: 2013 BMW 335i
Join Date: Dec 2011
Location: California

Posts: 110
iTrader: (1)

Garage List
2013 BMW 335i  [5.00]
Samething happened to me on second start up of the car however I cleared the code with the JB4 and it never came back nor does my battery die.
ZeroSix is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:33 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST