View Single Post
      09-27-2021, 02:06 PM   #13
rjahl
Colonel
rjahl's Avatar
845
Rep
2,103
Posts

Drives: Z4 35is
Join Date: Jun 2011
Location: Tampa

iTrader: (0)

Garage List
2012 Z4 35is  [0.00]
Quote:
Originally Posted by bpalmer7440 View Post
Quote:
Originally Posted by rjahl View Post
Recovery mode is just the state the DME will enter when it boots up with an incomplete or invalid flash. The DME will usually still accept flash commands but most CAN communications are limited. Sometimes, the UIF sections are so messed up the DME can no longer broadcast it's ZF numbers. Therefor programs like WINFKP can't talk to it easily.

WINFKP expert mode mostly forces the flash to the DME without most of the checks in comfort mode. The Bimmerlabs flash batch files are expert mode scripts and should work without valid UIF data.

Try this, connect your car to INPA in expert mode use the DME diagnostics page in INPA. If you can get the DME to respond to the ECU temperature request, The DME is at least running and the boot code is probably intact. Use the same configuration settings as found in Bimmerlabs flash Batch file. DME address, IPO file name etc.



Don't try to flash anything at this point. Just see if it's alive and talking.

It's possible you simply have a bad flash and you have some other hardware or setup related issue preventing you from completing a flash. Do you remember how long it took the flash to reach 50% were it failed?
rjahl I am not sure what you mean by "INPA in expert mode", but I did run INPA as Administrator. I could not find the "ECU Temperature Request" in INPA, but believe that I have seen that in Winkfp expert mode?. I did get the component errors list printed from INPA https://drive.google.com/file/d/1D284IrJm_pKy5sXA36EyFqpZb5WCZNXl/view?usp=sharing,
which shows 578E, CF1C, and 5821 errors for the DME.

Please help me understand how to get to the "ECU Temperature Request" that you referred to in INPA.

Also, I recall it being a little shy of 15 minutes to get to the 55% RSA Delete. This was our first attempt after replacing the battery and having the charger hooked up to the car. We have not been able to get back to this point.

Thank you for your edification.
Ya sorry, winfkp in expert mode.

The DME section has diagnostic tools, one of them being temperature

I'll try to pull up a screen shot later tonight.
Appreciate 0