View Single Post
      05-21-2022, 06:42 PM   #1
dailyis
New Member
0
Rep
9
Posts

Drives: 335is
Join Date: Apr 2022
Location: 90001

iTrader: (0)

Car won't turn on on cold start, or will start but is very weak

I have a electrical issue on my 2011 BMW 335is.

Recently I had decided to try and get taller tires (255/45/19 from 255/30/19) because I kept getting flat tires. In fact it's my sixth time getting a new tire. After those tires started rubbing, I noticed that it wasn't my tires but because I needed an alignment (inside of tire is balding as if there is a camber, last time I got an alignment around ~6 months). Since the tire rubbed, it ripped my fender liner out, and frayed the wiring underneath the fender liner in my rear passenger, which connects to the battery in the trunk. I've gotten all of these electrical codes (which do not pop up anymore, since re wiring and reinforcing the wiring)

I don't know how to add videos to show the hesitant startup, but it sometimes seems the car is dead.. and won't start at all. but how would it die? It was starting up perfectly since I've gotten it, up until those wires frayed and I rewired them (yes I matched each color correctly). Whilst I was driving before I fixed it, all of the electronics turned off in the car (nav, gauges, infotainment screen on dash etc) but still drove. Now it sounds like it won't start at all.

- Since I rewired those frayed wires, I never got any codes besides the throttle code (that happened when trying to retune to raise the idle in MHD), resetting codes makes it go away. Could it be my battery? What are the odds it's the alternator or starter, because the starter clicks fine? People also have said it could be my hpfp, but my line pressure and lpfp pressure is perfect?
Attached Images
    
Appreciate 0