E90Post
 


ECS BMW
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > SOS error, No radio - Need verification of problem



Reply
 
Thread Tools Search this Thread
      03-01-2019, 03:27 PM   #1
wootang_clan
Private
wootang_clan's Avatar
United_States
3
Rep
77
Posts

Drives: E90 330i & E46 M3 Vert
Join Date: Feb 2010
Location: Dayton, OH

iTrader: (1)

SOS error, No radio - Need verification of problem

I've searched and read many posts about this issue. With the information I've gathered from here, I tried to figure out the culprit. I have the BMW Professional CD/radio head unit, the L7 amp with the bluetooth module - no satellite radio module. I started with the trunk and I'm not seeing any red light from the optical wires on either the amp or the bluetooth module. Does this mean my head unit is bad? If so, is there a way to test or check if it is the head unit - ie. optical line into the head unit or some way to test the unit?
Appreciate 0
      03-01-2019, 03:55 PM   #2
N54Society
Major Private First Class
N54Society's Avatar
United_States
368
Rep
1,324
Posts

Drives: 2010 E90 335i M Sport
Join Date: Mar 2014
Location: US, NA, Earth, Milky Way Galaxy

iTrader: (2)

Sorry, I don't how to diagnose it but I do know that when I replaced the stock unit with an aftermarket Android unit, I had to code out the SOS error.
__________________
2008 E92 335i 6MT: FBO + MMP Silicone Inlets | Stage 1 LPFP | 335is clutch + MFactory SMFW | Custom BuraQ + MHD tune | 3.5Bar N20 sensor [SOLD]

2010 E90 335i M-Sport AT: 5" Stepped FMIC, Stage 2 LPFP - MHD V7 E60 Tune running 100% E85 - VRSF DPs
Appreciate 0
      03-01-2019, 04:05 PM   #3
Nickco43
Major
Nickco43's Avatar
805
Rep
1,395
Posts

Drives: 06 BMW 330i
Join Date: Apr 2018
Location: Philadelphia, PA

iTrader: (0)

Garage List
2006 BMW 330i  [0.00]
Quote:
Originally Posted by wootang_clan View Post
I've searched and read many posts about this issue. With the information I've gathered from here, I tried to figure out the culprit. I have the BMW Professional CD/radio head unit, the L7 amp with the bluetooth module - no satellite radio module. I started with the trunk and I'm not seeing any red light from the optical wires on either the amp or the bluetooth module. Does this mean my head unit is bad? If so, is there a way to test or check if it is the head unit - ie. optical line into the head unit or some way to test the unit?
Buy this: 61136917541

Check for power at each most module. Then go around and plug this in and test for a dead module.

Appreciate 0
      03-01-2019, 06:19 PM   #4
ctuna
Lieutenant General
1150
Rep
10,306
Posts

Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

Water on the amp is most common problem followed
by Sat Radio and TCU/Mulf going out.

There are status Led's o the L7 amp that can tell you a few
things.

See first link below.


Logic 7
http://www.bmwlogicseven.com/?p=3837
http://www.e90post.com/forums/attach...2&d=1260829447
https://www.teacremotes.com/bmwgm5/
http://www.google.fr/url?sa=t&rct=j&...slMu2A&cad=rjt
https://www.bmwgm5.com/Logic7_E90_91_92_93.htm
http://www.bimmerfest.com/forums/sho...d.php?t=982666
http://www.e90post.com/forums/attach...1&d=1209780605
Most
http://www.e90post.com/forums/showthread.php?t=727663
http://www.e90post.com/forums/showthread.php?t=347222
https://www.google.com/search?q=BMW+...VCkMqy2aCK09M:
http://www.1addicts.com/forums/showt...php?p=19256760
https://www.teacremotes.com/bmwgm5/
Appreciate 0
      03-04-2019, 09:33 PM   #5
wootang_clan
Private
wootang_clan's Avatar
United_States
3
Rep
77
Posts

Drives: E90 330i & E46 M3 Vert
Join Date: Feb 2010
Location: Dayton, OH

iTrader: (1)

Thanks for the info. I looked at all of the modules and I don't have the red optical light on any of them, including the head unit and the optical cord under the steering wheel. It was on for a second and it went off. Any ideas?
Appreciate 0
      03-05-2019, 12:03 AM   #6
callmetofo
New Member
0
Rep
16
Posts

Drives: 2009 335i e92
Join Date: Jun 2016
Location: San Francisco Bay Area

iTrader: (0)

Having similar issue

Amp, TCU, and Sat have solid red blinking light. I checked the headunit's MOST connection under my steering wheel (left hand drive) and it DOES have a light but it is very faint.

I took this to mean that my Sat is bad and I put my optical bypass loop on it. The Headunit's Most connect remained weak.... I then tried the TCU and AMP still weak....

Does weak red light mean that the fiber optical wires in my car has been broken???
Appreciate 0
      03-05-2019, 12:47 AM   #7
ctuna
Lieutenant General
1150
Rep
10,306
Posts

Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

Is your battery so low that the IBS is turning off the stereo
as a device deemed as to much of a battery drain to keep the car running.

electical e90 pdf
http://www.google.com/url?sa=t&rct=j...,d.cGU&cad=rja
http://www.google.com/url?sa=t&rct=j...85464276,d.cGU
http://www.google.com/url?sa=t&rct=j...85464276,d.cGU
Appreciate 0
      03-06-2019, 06:40 AM   #8
wootang_clan
Private
wootang_clan's Avatar
United_States
3
Rep
77
Posts

Drives: E90 330i & E46 M3 Vert
Join Date: Feb 2010
Location: Dayton, OH

iTrader: (1)

It was low but I charged it. Is the SOS light something that needs to be reset or should reset itself?
Appreciate 0
      03-06-2019, 06:56 AM   #9
Greyfox
Colonel
Greyfox's Avatar
United_States
857
Rep
2,634
Posts

Drives: 2007 328xi E91 - 295k+
Join Date: Feb 2014
Location: USA

iTrader: (2)

Quote:
Originally Posted by wootang_clan View Post
It was low but I charged it. Is the SOS light something that needs to be reset or should reset itself?
Charging a battery is only a temporary solution. Soon as you stop charging, if the battery is weak, it will start to loose charge and be back in the same point you were.
Appreciate 0
      03-12-2019, 08:34 PM   #10
wootang_clan
Private
wootang_clan's Avatar
United_States
3
Rep
77
Posts

Drives: E90 330i & E46 M3 Vert
Join Date: Feb 2010
Location: Dayton, OH

iTrader: (1)

Fiber Optic Light

So, it turns out that my battery and alternator are fine. I ended up taking it to an indy shop and they said it was my head unit. I am thinking about putting in one of those Eonon units in but I wanted to make sure that my optical cables are working. If I pull the head unit, and looked at the optical cable, should I be able to see the red light?
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 08:17 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST