E90Post
 


Extreme Powerhouse
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > ConnectedDrive / I-Drive / Navigation Related Discussion > iDrive CIC constant rebooting



Reply
 
Thread Tools Search this Thread
      12-01-2022, 07:10 AM   #1
Bunkermentality
New Member
3
Rep
12
Posts

Drives: E93 2012 Sport Plus
Join Date: Jan 2015
Location: Gretare London, UK

iTrader: (0)

iDrive CIC constant rebooting

Just recently my 2012 E93 iDrive CIC started to repeatedly reboot. Regular as clockwork after about 35 seconds. I've tried a soft reboot by holding the volume button down for 15 seconds but this doesn't help. Various articles on here suggest that the problem could be that the HDD is failing.

I'd appreciate some advice/opinions on a couple of questions.
  1. Is a faulty HDD the likely cause?
  2. If so should I remove it and clone it onto a replacement HDD or is it better to use a fresh disk image in case the clone process copies bad data?
  3. HDD is old technology. Is it smarter to replace with a SSD?
  4. What is the ideal spec for the replacement drive? Capacity etc?
  5. Are there any reset codes and other similar issues to be wary of?
Thanks in advance,
Paul
Appreciate 0
      12-01-2022, 03:26 PM   #2
opjose
Major
opjose's Avatar
223
Rep
1,315
Posts

Drives: 335xi
Join Date: May 2016
Location: Md

iTrader: (0)

Start by pulling the drive and see if the rebooting stops.

If it does you've found the problem.
Appreciate 0
      12-04-2022, 10:46 AM   #3
Bunkermentality
New Member
3
Rep
12
Posts

Drives: E93 2012 Sport Plus
Join Date: Jan 2015
Location: Gretare London, UK

iTrader: (0)

Drive is out and rebooting has stopped so that seems pretty conclusive. I have managed to take a full backup of the disk using an external caddy but now the disk appears to have ceased working and I can't hear it spinning up any more. The disk is 80GB HDD2G17. Does anyone know a modern equivalent for this? Would a SSD be more appropriate?
Appreciate 0
      12-05-2022, 04:23 PM   #4
opjose
Major
opjose's Avatar
223
Rep
1,315
Posts

Drives: 335xi
Join Date: May 2016
Location: Md

iTrader: (0)

There is a long thread here about upgrading the HDD to SSD.

I did mine over four years ago and it has worked very well.

Thankfully you cloned the drive which will avoid all sorts of issues if you restore it to the new drive.

The original drive is an eide drive which is difficult to find as an SSD.

More info is available on the thread.
Appreciate 0
      12-13-2022, 09:59 AM   #5
Bunkermentality
New Member
3
Rep
12
Posts

Drives: E93 2012 Sport Plus
Join Date: Jan 2015
Location: Gretare London, UK

iTrader: (0)

Thanks for the advice opjose . I found the thread about upgrading HDD to SSD here https://www.e90post.com/forums/showthread.php?t=1426773

Based on this I sourced an IDE Interface adaptor(https://www.amazon.co.uk/gp/product/...0?ie=UTF8&th=1) and internal SSD (https://www.amazon.co.uk/gp/product/...0?ie=UTF8&th=1).

Using the disk image I managed to save before my original disk finally failed I managed to create a new volume. (See attached image.) This has six partitions plus 44GB unallocated as the original disk is 80GB and new disk is 120 GB.

When I reinsert the disk into CIC and reboot CIC I see a navigation system starting up message but this ends with "Function Not Available" and Navigation is greyed out on CIC main menu.

Is there something wrong with the new disk volume that I created?

Any ideas very welcome.

Thanks Paul
Attached Images
 
Appreciate 0
      12-21-2022, 08:07 AM   #6
Bunkermentality
New Member
3
Rep
12
Posts

Drives: E93 2012 Sport Plus
Join Date: Jan 2015
Location: Gretare London, UK

iTrader: (0)

Recommend IDE adaptor for CIC

I have followed thread https://www.e90post.com/forums/showp...03&postcount=1 DIY: Install SSD in CIC and conclude that the SSD to IDE adaptor sled I have selected is not compatible with the CIC see my post here https://www.e90post.com/forums/showp...&postcount=267 All seems good but the Navigation option is greyed out.

So I need a mSATA Mini SSD to IDE adaptor that is proven to work and is available in UK. There are various recommended solutions but all seem out of date. Can anyone recommend a solution?

Thanks Paul
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:53 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2023, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST