E90Post
 


Extreme Powerhouse
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > Phone/Bluetooth Menu Option Missing (Logic7)



Reply
 
Thread Tools Search this Thread
      08-20-2019, 11:52 AM   #1
Isoleucine
New Member
0
Rep
8
Posts

Drives: 2008 335i
Join Date: Aug 2019
Location: CO

iTrader: (0)

Phone/Bluetooth Menu Option Missing (Logic7)

I recently purchased my first BMW last Saturday and was mildly disappointed when the car didn't have Bluetooth like the seller stated it did, but figured it was no big deal and they just misremembered.

Then I got to reading more and I found out that the car absolutely should have Bluetooth, and now I'm just left kind of confused. The car is a 2008 335i, built in late 2007, with the SOS option and the Logic7 amp. Everything I have read shows that the SOS option was always paired with the Bluetooth, you couldn't have the SOS without Bluetooth. Unfortunately my car doesn't show anything to do with phones or Bluetooth regardless of if I check the menus or if I hold the phone button to attempt to force a new phone to pair.

It also sounds like the MOST loop would have a fit if there was a bad component in the loop, so would it be expected that the physical Bluetooth module has been removed from the MOST loop after it failed? Or could it simply be that someone coded out the Bluetooth option from the head unit for one reason or another, with the hardware still working fine?

I'm just a bit confused since the other items from the MOST loop seem to still work just fine, it's only the SOS and Bluetooth with issues (SOS warning and Bluetooth is just completely missing).




Appreciate 0
      08-20-2019, 03:40 PM   #2
ctuna
Major General
944
Rep
9,357
Posts

Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

Does your cd and usb work?

In the early car builds you got a TCU to do bluetooth phone and
SOS and a Mulf 2 Hi to do USB.
Mulf is under the TCU.
If you have an SOS error with Logic 7 most people report there is no
audio as the Logic 7 amp is part of the Most Loop and if anything is
disrupted on it nothing works.

There is no support for SOS anymore and the Mulf 2 Hi will support
bluetooth phone. You need to reprogram the Mulf to turn on
its bluetooth function and repin the Mulf connector for the Microrphone.
And also program out the TCU SOS function and remove the tcU.

First thing look at the TCU to see if there is a Most bypass loop there that
is the only way you could have audio with Logic 7 and SOS error.

Logic 7
https://www.e90post.com/forums/showthread.php?t=1056432
http://www.bmwlogicseven.com/?p=3837
http://www.bmwgm5.com/
https://www.e90post.com/forums/showt...5#post24455335
http://www.e90post.com/forums/attach...2&d=1260829447
http://www.google.fr/url?sa=t&rct=j&...slMu2A&cad=rjt
https://www.bmwgm5.com/Logic7_E90_91_92_93.htm
http://www.bimmerfest.com/forums/sho...d.php?t=982666


http://www.e90post.com/forums/attach...1&d=1209780605
Most
http://www.e90post.com/forums/showthread.php?t=727663
http://www.e90post.com/forums/showthread.php?t=347222
https://www.google.com/search?q=BMW+...VCkMqy2aCK09M:
http://www.1addicts.com/forums/showt...php?p=19256760
https://www.teacremotes.com/bmwgm5/

http://www.e90post.com/forums/showthread.php?t=1181654
This last one is pertinent to your situation.

Last edited by ctuna; 08-20-2019 at 03:51 PM..
Appreciate 0
      08-20-2019, 03:43 PM   #3
Isoleucine
New Member
0
Rep
8
Posts

Drives: 2008 335i
Join Date: Aug 2019
Location: CO

iTrader: (0)

Much appreciated, I'll take a closer look at the exact wiring of the components in the trunk this evening. Your help is exactly what I was hoping since I just wanted to get an idea of what to be looking for when I removed the carpet to inspect it all.
Appreciate 0
      08-20-2019, 03:49 PM   #4
ctuna
Major General
944
Rep
9,357
Posts

Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

somebody must of hacked up the area around the TCU.

BMW stereo types
http://www.e90post.com/forums/showthread.php?t=352586
http://www.e90post.com/forums/attach...2&d=1266451970
http://www.e90post.com/forums/attach...2&d=1260829447
http://www.e90post.com/forums/showthread.php?t=343673
http://www.e90post.com/forums/showthread.php?t=138949
http://www.e90post.com/forums/attach...1&d=1209780605
http://www.e90post.com/forums/attach...1&d=1209780865
http://www.e90post.com/forums/showthread.php?t=641323
http://bmwcoders.com/forum/3-er-8/bm...1-e92-e93-291/
http://technicpnp.com/menuDiagrams/d...e90_92_93.html
http://www.musicarnw.com/page-2/
http://www.e90post.com/forums/attach...3&d=1169133185
http://www.e90post.com/forums/attach...4&d=1278871872

Read the third link at least.

And the following link is most of keys to the Kingdom,
georges links
https://www.bimmerfest.com/forums/at...9&d=1539905743
Appreciate 0
      08-21-2019, 11:17 AM   #5
Isoleucine
New Member
0
Rep
8
Posts

Drives: 2008 335i
Join Date: Aug 2019
Location: CO

iTrader: (0)

So I dug around the trunk area and figured out what was going on.

The TCU was bypassed with a fiber loop and there was an additional plug back there (likely for later addition of satellite radio) with a fiber loop bypass. I found that the TCU is definitely dead since it would kill the audio and door dings if I connected it with any of the 3 present MOST connectors.

Just as something to try I've disassembled the TCU and tossed the parts into my ultrasonic cleaner filled with rubbing alcohol. This afternoon I'll try giving a gentle scrub with a toothbrush and putting it back together again to see if that fixes a corroded connection of some kind. Otherwise it looks like the easiest fix might be to just program and wire the Bluetooth calling features into the MULF2 box from the trunk.
Appreciate 0
      08-22-2019, 11:30 AM   #6
ctuna
Major General
944
Rep
9,357
Posts

Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

There no reason to have a TCU if you have the Mulf 2 .
Also hanging Most connectors that aren't causing the sound
to disappear are not routed into the Most Loop at the Most Hub.
If you don't want to use the Factory solution there is this.

https://www.e90post.com/forums/showt...ight=bluetooth

Gives you Bluetooth Music Streaming and Phone as well as USB/SD card
playback and another aux.
Appreciate 0
      08-22-2019, 04:28 PM   #7
Isoleucine
New Member
0
Rep
8
Posts

Drives: 2008 335i
Join Date: Aug 2019
Location: CO

iTrader: (0)

All of the most connectors currently present in the trunk do cause the sound to disappear when the fiber loop isn't connected to them, so they are all a part of the most loop.

The only real reason I'd like to try and see if I could get the TCU working again is simply to have bluetooth calling restored to my car quickly and easily. I intend to replace the head unit eventually with a Dynavin or Eonon model so that I can have Android Auto, but this would be a quick and easy fix in the meantime to restore Bluetooth calling functionality if it works. I'm currently just using a Tunai Firefly for the Bluetooth audio streaming, and that works fine for now.

I should hopefully receive the K+DCAN cable from Bimmergeeks in the next week or two to allow me to program out the SOS warning, and when it arrives if I haven't yet ordered a new head unit I can always just re-program the MULF2 to do Bluetooth calling in the meantime. I just figured that if taking apart and cleaning the TCU would work it might be the quickest and easiest temporary fix. I'm reassembling and re-installing it this evening as a test so I will report back later this evening whether or not that worked.
Appreciate 0
      08-22-2019, 07:06 PM   #8
Isoleucine
New Member
0
Rep
8
Posts

Drives: 2008 335i
Join Date: Aug 2019
Location: CO

iTrader: (0)

It's official, the TCU is toast so it looks like I'll just be reprogramming my MULF2 whenever it is that I receive my cable.

Thanks for the assistance.
Appreciate 0
      08-22-2019, 08:29 PM   #9
ctuna
Major General
944
Rep
9,357
Posts

Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

You need some hardware changes to Repinning the Mike see
supplied link on TCU and Mullf differences.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 02:49 PM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST