E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > UK > UK Technical Forum > Alpine Hifi upgrade



Reply
 
Thread Tools Search this Thread
      04-06-2014, 01:24 PM   #969
jammy78
Colonel
United Kingdom
79
Rep
2,003
Posts

Drives: F31 328i
Join Date: Nov 2012
Location: Windsor

iTrader: (21)

Quote:
Originally Posted by jammy78 View Post
I've installed this kit & it makes a MASSIVE difference!

The only issue, it doesn't sound right.... the frequency is slightly strange, uncomfortable I would say!

Is this due cos it needs coding to hifi? I have pre 03/09 & CIC retrofit?
Get in..... I managed to code my cic to hifi & wow what a difference...... the uncomfortable frequency is gone & it's so much clear! I'm now really pleased with this upgrade!

It is such a simple DIY, it'll take a few hours but nothing is difficult!

Bring on the L7 subs!

Appreciate 0
      04-08-2014, 04:52 AM   #970
Jermainiac
Enlisted Member
United Kingdom
2
Rep
44
Posts

Drives: E90 325i M Sport
Join Date: Apr 2014
Location: London

iTrader: (0)

I'm not too sure if I have missed anything....... Is there anyway of just upgrading my BMW professional speaker system as the current speakers are not the best at high volume? I get distortion with the bass which I have got used to just tweaking the volume to remedy the issue. Is there a simple all round speaker upgrade that I can get which just means me swapping out the stock speakers?

If I didn't have the distorted sound I would be happy!

E90 325i M sport 2006
Appreciate 0
      04-09-2014, 12:05 PM   #971
jammy78
Colonel
United Kingdom
79
Rep
2,003
Posts

Drives: F31 328i
Join Date: Nov 2012
Location: Windsor

iTrader: (21)

Ok, after a few days with this alpine upgrade..... my conclusion is that it is shit!

Granted the sound is louder (it should be with a amp) but at a normal sound level, it is no better than Base with tweeters added, in fact I would say its worst as the sound is uncomfortable!

I have coded my CIC to hifi & check & double checked the wiring..... so there's nothing I can see I've done wrong in my install!

I'm not even going to bother installing the L7 subs when they arrive!

Would I recommend this retrofit...... HELL NO!

I will be uninstalling it, when I get some spare time! Complete waste of money! You've been warned!
Appreciate 0
      04-09-2014, 12:18 PM   #972
bungleaio
Second Lieutenant
2
Rep
295
Posts

Drives: Pug 208
Join Date: Mar 2013
Location: Leicester UK

iTrader: (0)

I'm surprised, I thought it was a very good upgrade. I've stripped mine out as I'm selling my car and I'm missing the sound and clarity. You do need to run the speakers in to get the absolute best from them. Maxing out new speakers is not good for them

You have got your tweeters installed the right way haven't you? it's very easy to connect the wires the wrong way around.
Appreciate 0
      04-09-2014, 12:33 PM   #973
jammy78
Colonel
United Kingdom
79
Rep
2,003
Posts

Drives: F31 328i
Join Date: Nov 2012
Location: Windsor

iTrader: (21)

Quote:
Originally Posted by bungleaio View Post
I'm surprised, I thought it was a very good upgrade. I've stripped mine out as I'm selling my car and I'm missing the sound and clarity. You do need to run the speakers in to get the absolute best from them. Maxing out new speakers is not good for them

You have got your tweeters installed the right way haven't you? it's very easy to connect the wires the wrong way around.
Yep, I have them installed correctly.

I have had them running in for 4 days..... I would not recommend this at all!

I'd even say this makes it sound cheap - like back in the day when adding a cheapo amp in your Astra with a Kenwood flip HU!


I'll be back to base & tweeters!
Appreciate 0
      04-10-2014, 12:41 AM   #974
Shafz325
325i 6MT Arctic
Shafz325's Avatar
England
5
Rep
224
Posts

Drives: 2005 325i SE Arctic Metallic
Join Date: Aug 2009
Location: London, UK

iTrader: (0)

Wow, didn't expect this after you saying it was good a few days ago, mines still being installed on Saturday with L7 subs and I'll let you know my thoughts then, if don't like it I'll probably end up going with MB quart anyway but thanks for the heads up
Appreciate 0
      04-10-2014, 04:30 AM   #975
jammy78
Colonel
United Kingdom
79
Rep
2,003
Posts

Drives: F31 328i
Join Date: Nov 2012
Location: Windsor

iTrader: (21)

Quote:
Originally Posted by Shafz325 View Post
Wow, didn't expect this after you saying it was good a few days ago, mines still being installed on Saturday with L7 subs and I'll let you know my thoughts then, if don't like it I'll probably end up going with MB quart anyway but thanks for the heads up
I think it was the euphoria if installing it without any damage / issues had an effect!?

IMO it's not worth 400+...... maybe the addition of better subs will help or maybe it does need fine tuning - when I see Sam next, i'll ask what he thinks or compare it other installs!
Appreciate 0
      04-10-2014, 04:49 AM   #976
Shafz325
325i 6MT Arctic
Shafz325's Avatar
England
5
Rep
224
Posts

Drives: 2005 325i SE Arctic Metallic
Join Date: Aug 2009
Location: London, UK

iTrader: (0)

I'm seeing Sam on saturday, luckily for me the upgrade was a birthday gift so all I paid for was the Logic7 subs and now the fitting.. so it won't have cost me that much all in so if I don't like it someone local to me has the MBQuart stuff and I'll think of a solution for the bass. I have confidence in Sam anyway because of reviews on this forum that he can get my system sounding the best it can, with the resources he has.
__________________
Daily: 2005 BMW 325i SE Arctic Metallic 6MT | Black Dakota Leather | BMS CDV | E90 LCI Halogen Headlights | HorizonLEDs 20W CREE Angel Eyes | OEM Blacklines | CREE Foglights | BMW Alpine Upgrade | Logic7 Subwoofers | ACS Style Roof Spoiler | BMWP Style Boot Spoiler

Toy: 2002 Honda Civic Type-R EP3 | Too Much To List...

Last edited by Shafz325; 04-10-2014 at 05:05 AM.
Appreciate 0
      04-10-2014, 12:22 PM   #977
markymark34
First Lieutenant
15
Rep
307
Posts

Drives: 2007 325d M Sport
Join Date: Jul 2009
Location: NI

iTrader: (0)

Quote:
Originally Posted by jammy78 View Post
Yep, I have them installed correctly.

I have had them running in for 4 days..... I would not recommend this at all!

I'd even say this makes it sound cheap - like back in the day when adding a cheapo amp in your Astra with a Kenwood flip HU!


I'll be back to base & tweeters!
something not right with your install. Ive had 3 e90s one with this kit and 2 without. Every day i wish i had ripped the kit out of the car before i sold it. massive difference to the sound.
Appreciate 0
      04-10-2014, 02:00 PM   #978
jammy78
Colonel
United Kingdom
79
Rep
2,003
Posts

Drives: F31 328i
Join Date: Nov 2012
Location: Windsor

iTrader: (21)

Quote:
Originally Posted by markymark34 View Post
something not right with your install. Ive had 3 e90s one with this kit and 2 without. Every day i wish i had ripped the kit out of the car before i sold it. massive difference to the sound.

Tbh - you can't really mess up the install..... I will check all the connections at the weekend, case something has come loose.

I think the issue is with the bass..... I wonder if I've blown one of the standard subs?

Every time I the radio is on, I get earache & no, I haven't got it playing loud!
Appreciate 0
      04-10-2014, 05:45 PM   #979
BMWChap
Major
198
Rep
1,287
Posts

Drives: F32
Join Date: Jun 2012
Location: UK

iTrader: (0)

Lol! you want your tweeters back! I actually have a pair of MacAudio Tweeters which my mate swears by, I just need the cable connector+pin to wire them up as I dont want to cut off the original connectors off the BMW tweeters.

Quote:
Originally Posted by jammy78 View Post
Yep, I have them installed correctly.

I have had them running in for 4 days..... I would not recommend this at all!

I'd even say this makes it sound cheap - like back in the day when adding a cheapo amp in your Astra with a Kenwood flip HU!


I'll be back to base & tweeters!
Appreciate 0
      04-12-2014, 04:41 PM   #980
PixelVogue
Private First Class
United Kingdom
3
Rep
159
Posts

Drives: BMW
Join Date: Jan 2011
Location: UK

iTrader: (0)

Hey you guys
hope someone can help out...

I went to install some SWS8 subs in my 130i, but the cabling seems to be similar to like Robbie99 has posted here, although it looks like I have the blue ones coming from the HU aswell...
where can I tap into the cables so I can add a RCA converter and connect to my JL Audio amp, will the OEM sub cable be ok?



Mine on the drivers side...the Brown/White & Red/Blue are the OEM sub cable..



Thanks

Edit, looks like the wiring on my car has changed like some e90 lci models

Last edited by PixelVogue; 04-12-2014 at 06:52 PM.
Appreciate 0
      04-17-2014, 08:03 PM   #981
rav.k
Enlisted Member
1
Rep
34
Posts

Drives: 2008 E92 320i
Join Date: Apr 2014
Location: South Yorkshire

iTrader: (0)

Can someone tell me HOW they installed their L7 subs on a pre-lci? im looking to invest in some at the same time as buying the alpine kit but not sure on whether the subs will be simply plug & play
Appreciate 0
      04-18-2014, 05:02 AM   #982
Per Hansson
Private
Sweden
12
Rep
75
Posts

Drives: BMW 325 E90 '06
Join Date: Oct 2011
Location: Sweden

iTrader: (0)

rav.k: http://www.e90post.com/forums/showpo...&postcount=872
Appreciate 0
      04-18-2014, 06:24 AM   #983
rav.k
Enlisted Member
1
Rep
34
Posts

Drives: 2008 E92 320i
Join Date: Apr 2014
Location: South Yorkshire

iTrader: (0)

Quote:
Originally Posted by Per Hansson View Post
Thanks! Since my car is a 2008 pre-lci, would I need L7 subs from another pre-lci? It's just I have seen some on ebay from a 2010 e90 which include the enclosures, and wondered if they would be compatible? I've read somewhere on the forum I need to make sure the subs have a 2-pin connector for pre-lci
Appreciate 0
      04-22-2014, 12:57 PM   #984
jammy78
Colonel
United Kingdom
79
Rep
2,003
Posts

Drives: F31 328i
Join Date: Nov 2012
Location: Windsor

iTrader: (21)

I've now got L7 subs installed & the improvement is massive.... now I'm happy with this upgrade!

I installed them in my base enclosures, does it matter?
Appreciate 0
      04-23-2014, 05:23 PM   #985
Shafz325
325i 6MT Arctic
Shafz325's Avatar
England
5
Rep
224
Posts

Drives: 2005 325i SE Arctic Metallic
Join Date: Aug 2009
Location: London, UK

iTrader: (0)

I knew you would be, I love the Logic7 subwoofers in my car! Such a big improvement not that I've heard the alpine upgrade with stock subs!
__________________
Daily: 2005 BMW 325i SE Arctic Metallic 6MT | Black Dakota Leather | BMS CDV | E90 LCI Halogen Headlights | HorizonLEDs 20W CREE Angel Eyes | OEM Blacklines | CREE Foglights | BMW Alpine Upgrade | Logic7 Subwoofers | ACS Style Roof Spoiler | BMWP Style Boot Spoiler

Toy: 2002 Honda Civic Type-R EP3 | Too Much To List...
Appreciate 0
      04-24-2014, 06:04 AM   #986
BMWChap
Major
198
Rep
1,287
Posts

Drives: F32
Join Date: Jun 2012
Location: UK

iTrader: (0)

Quote:
Originally Posted by jammy78 View Post
I've now got L7 subs installed & the improvement is massive.... now I'm happy with this upgrade!

I installed them in my base enclosures, does it matter?
good stuff!, i'm deffo doing this upgrade now
Appreciate 0
      04-27-2014, 10:51 AM   #987
Ibo24
New BMW owner
Ibo24's Avatar
Belgium
28
Rep
234
Posts

Drives: BMW 320d
Join Date: Jan 2012
Location: Belgium

iTrader: (0)

Garage List
Don't know about you guys, but I have installed the Alpine kit along side with the Hifi subwoofers. Before coding I was like.. Uhhh... After coding I was

So I really don't get it how you think this is a waiste of money, but then again it's your thought so all respect for it.
Appreciate 0
      05-05-2014, 05:47 AM   #988
mike1973
Private First Class
Portugal
4
Rep
101
Posts

Drives: E91
Join Date: Jan 2012
Location: Portugal

iTrader: (0)

Alpine Installation Question

Hi,

I have ordered an Alpine hifi retrofit to install in my E91 from 2007 and have a questions regarding the coding.

I have read the thread and according instructions no coding is necessary, however the sound result from coding the car seem to be better after coding!

In order to code my car I would have to add SA676 into the VO and update the CAS and RAD2 modules correct, or do I just alter all the settings in RAD2 from e90_estereo to hifi and update the RAD2 module?

Thanks
Appreciate 0
      05-15-2014, 07:55 AM   #989
Hope
First Lieutenant
10
Rep
380
Posts

Drives: M5, 435i
Join Date: May 2011
Location: Manchester

iTrader: (1)

I need mine coding in/around Manchester

Kept missing Makkan when I was in London due to time constraints unfortunately.
Appreciate 0
      05-24-2014, 05:48 PM   #990
mike1973
Private First Class
Portugal
4
Rep
101
Posts

Drives: E91
Join Date: Jan 2012
Location: Portugal

iTrader: (0)

Quote:
Originally Posted by mike1973 View Post
Hi,

I have ordered an Alpine hifi retrofit to install in my E91 from 2007 and have a questions regarding the coding.

I have read the thread and according instructions no coding is necessary, however the sound result from coding the car seem to be better after coding!

In order to code my car I would have to add SA676 into the VO and update the CAS and RAD2 modules correct, or do I just alter all the settings in RAD2 from e90_estereo to hifi and update the RAD2 module?

Thanks
Just finished the install and coded the unit to hifi.. sounds great.. balanced sound with good midrange and soundstage.. the bass could be better I will have to get the L7 subwoofers soon

Thanks all for the info posted.
Appreciate 0
Reply

Bookmarks

Tags
alpine

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 04:57 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST