E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > All-Wheel-Drive (Xi / xDrive) Talk > Is this a bad transfer case or what? Please help!



Reply
 
Thread Tools Search this Thread
      07-26-2019, 05:10 PM   #1
BMWsandDobermansGirl
New Member
Canada
0
Rep
28
Posts

Drives: BMW 325xi
Join Date: Jun 2019
Location: Toronto, Ontario, Canada

iTrader: (0)

Is this a bad transfer case or what? Please help!

2007 325xi automatic

First I was driving on the highway and got the 4x4, AWD, DSC, ABS, EBV symbols and cruise control wasn't working either. The gears shift fine, on time and no shutters taking off. I had a break sensor triggered before, that brake light went away when those symbols came out. There was a slight noise when driving coming from the back tire, I think because those brakes might have needed changing. I was able to drive home that day. *The lights don't show up until and only when I start driving.*

Next days; Drove it for a bit like that but then when I decided to take it to the mechanic the car stopped in the middle of the road in front of my house as if something got stuck and wouldn't let it move forward anymore accompanied by a very loud squealing noise from under the car which stopped when the car stopped moving. Had it towed and at the garage they told me it started driving again giving those symbols. That's when they ignored me for a week, told me it was a transfer case but gave me no pricing at all. They almost didn't want to do anything so I just drove it home and they were happy.

I had to meet my brother's family at Disney for 10 days but when I got back...;the unexplainable symptoms now..
No more warning lights! Dash is clear! Even when I try driving it.

All gears shift in and out of smoothly with no delay or noise. Engine is clean. The car goes in reverse but when I put it in D or M1, it starts to roll but then stops as if something stuck stopping it and starts to roll again a bit but stops again. There is a squealing noise that accompanies it when it stops.

Again no lights are turning on anymore! The dash is clear no engine light.. No 4x4, brake light, nothing.
Car goes reverse but not drive. Moves a bit then stops as if something is stuck inside it stopping it on one side of the spin. (If that makes sense)

Remember this happened but then started driving again and now it looks like it's stuck for good. I'm waiting on a obd2 cable that should arrive on Monday. Hopefully I can pull out some codes from the history.

Can anyone say what this could be? There are no oil leaks under the car from what I can see. Transfer case and transmission oil were changed 3 years ago. I just had an engine oil change. The car is 240k kms but very clean engine, oil change every 5k max since 190k kms.

Also if it's the transfer case, if I unplug it, would the car drive again? I would be grateful for any help or advice. If you had issues with a transfer case can you tell me about your symptoms and if they were similar or not? What sucks is that there are no lights on the dash anymore.
Appreciate 0
Reply

Bookmarks

Tags
4x4, clear dash, diagnosis help, transfer case

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 08:15 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST