E90Post
 


Extreme Powerhouse
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > BMW Coding > FRM3 Resurrection Thread



Reply
 
Thread Tools Search this Thread
      04-25-2016, 02:19 PM   #45
Sensible_
Colonel
440
Rep
2,468
Posts

Drives: 2008 E90
Join Date: Feb 2012
Location: London

iTrader: (1)

Quote:
Originally Posted by dumitru.o
Quote:
Originally Posted by Sensible_ View Post
What programmer are you using?
xprog 5.55 china

thanks
Can you show me log and take photo of the PCB please...
Appreciate 0
      04-25-2016, 02:36 PM   #46
dumitru.o
coding BMW.....
dumitru.o's Avatar
Romania
17
Rep
98
Posts

Drives: e92
Join Date: Jun 2013
Location: Bucuresti

iTrader: (0)

i will do that at the end of the week when i am hope. the thing is that i was able to delete and write the EEE and then i read the p-flash without problem, then i delete the p-flash to with the new one i had from dump and since that moment i was unable to do anything else then delete (EEE and p-flash). if i try to delete it say s that it s secured. i try with the secure profile but does nothing when i try to reset security....

will be back with pics and log
Appreciate 0
      04-25-2016, 04:19 PM   #47
Mik325tds
Major
Mik325tds's Avatar
United_States
654
Rep
1,081
Posts

Drives: 335d M-Sport
Join Date: Jul 2014
Location: Greater Detroit

iTrader: (0)

Quote:
Originally Posted by dumitru.o View Post
i will do that at the end of the week when i am hope. the thing is that i was able to delete and write the EEE and then i read the p-flash without problem, then i delete the p-flash to with the new one i had from dump and since that moment i was unable to do anything else then delete (EEE and p-flash). if i try to delete it say s that it s secured. i try with the secure profile but does nothing when i try to reset security....

will be back with pics and log
Try using the non-secured profile. That has worked for mine after something similar happened.
Appreciate 0
      04-26-2016, 02:09 PM   #48
dumitru.o
coding BMW.....
dumitru.o's Avatar
Romania
17
Rep
98
Posts

Drives: e92
Join Date: Jun 2013
Location: Bucuresti

iTrader: (0)

tried without success
Appreciate 0
      04-27-2016, 05:57 AM   #49
Mik325tds
Major
Mik325tds's Avatar
United_States
654
Rep
1,081
Posts

Drives: 335d M-Sport
Join Date: Jul 2014
Location: Greater Detroit

iTrader: (0)

Quote:
Originally Posted by dumitru.o View Post
tried without success
Are you powering the Xbox by USB only? Mine had problems with that. After using an external power supply it worked much better. The reads are still flaky but the writes usually work fine.
Appreciate 0
      04-27-2016, 03:56 PM   #50
dumitru.o
coding BMW.....
dumitru.o's Avatar
Romania
17
Rep
98
Posts

Drives: e92
Join Date: Jun 2013
Location: Bucuresti

iTrader: (0)

i also used external power supply , but without any difference.
Appreciate 0
      04-27-2016, 06:45 PM   #51
Sensible_
Colonel
440
Rep
2,468
Posts

Drives: 2008 E90
Join Date: Feb 2012
Location: London

iTrader: (1)

Maybe it's a problem with your XProg. Have you confirmed its working on other MCU's?
Appreciate 0
      05-21-2016, 09:26 PM   #52
Levanime
Levanime's Avatar
United_States
146
Rep
743
Posts

Drives: E92 335
Join Date: Dec 2014
Location: Atlanta

iTrader: (0)

Garage List
2007 BMW 335  [0.00]
Quote:
Originally Posted by Sensible_ View Post
Maybe it's a problem with your XProg. Have you confirmed its working on other MCU's?
Could you please recommend good source for good quality Xprog?
i want to try doing this

thanks!
Appreciate 0
      05-22-2016, 04:05 AM   #53
Sensible_
Colonel
440
Rep
2,468
Posts

Drives: 2008 E90
Join Date: Feb 2012
Location: London

iTrader: (1)

Quote:
Originally Posted by Levanime
Quote:
Originally Posted by Sensible_ View Post
Maybe it's a problem with your XProg. Have you confirmed its working on other MCU's?
Could you please recommend good source for good quality Xprog?
i want to try doing this

thanks!
This one has good reviewed and is latest 5.55. A clone obviously but quality seems ok.

http://s.aliexpress.com/AzEJBbmA
2016 Lastest version Xprog M 5.55 ECU Programmer Xprog-M V5.55 ECU Chip Tuning Tool with full set X prog m V5.48
Appreciate 0
      05-22-2016, 11:34 AM   #54
Levanime
Levanime's Avatar
United_States
146
Rep
743
Posts

Drives: E92 335
Join Date: Dec 2014
Location: Atlanta

iTrader: (0)

Garage List
2007 BMW 335  [0.00]
Quote:
Originally Posted by Sensible_ View Post
This one has good reviewed and is latest 5.55. A clone obviously but quality seems ok.

http://s.aliexpress.com/AzEJBbmA
2016 Lastest version Xprog M 5.55 ECU Programmer Xprog-M V5.55 ECU Chip Tuning Tool with full set X prog m V5.48
thank you!
Appreciate 0
      06-08-2016, 06:54 PM   #55
Levanime
Levanime's Avatar
United_States
146
Rep
743
Posts

Drives: E92 335
Join Date: Dec 2014
Location: Atlanta

iTrader: (0)

Garage List
2007 BMW 335  [0.00]
deleted

Last edited by Levanime; 06-08-2016 at 08:02 PM..
Appreciate 0
      07-04-2016, 03:34 AM   #56
y3k10
New Member
0
Rep
7
Posts

Drives: 1
Join Date: Jun 2015
Location: Germany

iTrader: (0)

I found this p-flash in your collection : FRM E87 E92 E93 6135 9240528-01 SW 132001 HW 07.rar and its the same like my bad FRM. But there is only p-flash in it and not eee. is it enough to write p-flash without eee dump?
i tried to read p-flash but i am getting device is silent.
Appreciate 0
      07-04-2016, 12:27 PM   #57
Levanime
Levanime's Avatar
United_States
146
Rep
743
Posts

Drives: E92 335
Join Date: Dec 2014
Location: Atlanta

iTrader: (0)

Garage List
2007 BMW 335  [0.00]
no, you need eeprom
Appreciate 0
      07-05-2016, 01:30 AM   #58
y3k10
New Member
0
Rep
7
Posts

Drives: 1
Join Date: Jun 2015
Location: Germany

iTrader: (0)

I changed latency in driversettings from 16ms to 1ms. Then it Starts Reading p-flash but Same Problem with Device is silent. Eee i can read just Fine. Any suggestions where to get eee Dump for this frm? Will it fix the Reading error for pflash if i flash eee First?
Appreciate 0
      07-05-2016, 01:37 AM   #59
Levanime
Levanime's Avatar
United_States
146
Rep
743
Posts

Drives: E92 335
Join Date: Dec 2014
Location: Atlanta

iTrader: (0)

Garage List
2007 BMW 335  [0.00]
looks like your programmer problem,
good eee will not help P-Flash reading problem
Appreciate 0
      07-05-2016, 02:23 AM   #60
y3k10
New Member
0
Rep
7
Posts

Drives: 1
Join Date: Jun 2015
Location: Germany

iTrader: (0)

I have 5.55 clone. With Dongle Tool does not start up. So i tried with no Dongle Tool. Eee can read and it says wrong Partition Table but i can Read eee with Partition set to 16.
You have a Suggestion what to do? And which dump to take?
Appreciate 0
      07-05-2016, 02:44 AM   #61
y3k10
New Member
0
Rep
7
Posts

Drives: 1
Join Date: Jun 2015
Location: Germany

iTrader: (0)

can eee flash make frm work in car to flash again or is eee and p-flash neccessary?
Appreciate 0
      07-08-2016, 02:58 AM   #62
y3k10
New Member
0
Rep
7
Posts

Drives: 1
Join Date: Jun 2015
Location: Germany

iTrader: (0)

Tried everything. Only using serial cable instead of USB solved the problem. Now its working fine. Only verification does not work and gives errors but should be no problem
Appreciate 0
      07-12-2016, 03:53 PM   #63
Bl@nquito
New Member
2
Rep
9
Posts

Drives: E93
Join Date: Jul 2016
Location: Madrid - Spain

iTrader: (0)

Hi to all! I'm new here

I've been reading some information about the FRM module since mine is kind of bricked...

Maybe you can help me. The problem is that dealer was coding and suddenly the update failed. He wasn't able to connect to the module anymore.
He got it repaired but now the obd is working, but if we try to update it, it fails. Just no chance.

All this is using the official ISTA with the license to operate connected to Munich

Do you have any ideas? Also the diagnostic throws an error with the ambient light sensor that was not present before... In case it helps

The reference must be for the VIN E766945 61359390491
Adaptative headlights, memory seats, interior lights, LCI since its 2011, etc.
Appreciate 0
      07-12-2016, 04:18 PM   #64
Levanime
Levanime's Avatar
United_States
146
Rep
743
Posts

Drives: E92 335
Join Date: Dec 2014
Location: Atlanta

iTrader: (0)

Garage List
2007 BMW 335  [0.00]
its fried,

you need good eep
Appreciate 0
      07-12-2016, 04:24 PM   #65
Bl@nquito
New Member
2
Rep
9
Posts

Drives: E93
Join Date: Jul 2016
Location: Madrid - Spain

iTrader: (0)

Quote:
Originally Posted by Levanime View Post
its fried,

you need good eep
Thanks for replying!

Do you know which eep from the google drive posted before could fit?
Unfortunately dealer didn't make any backup of it...
Appreciate 0
      07-12-2016, 07:09 PM   #66
Levanime
Levanime's Avatar
United_States
146
Rep
743
Posts

Drives: E92 335
Join Date: Dec 2014
Location: Atlanta

iTrader: (0)

Garage List
2007 BMW 335  [0.00]
post picture of the unit itself where numbers are written,
you need to chose by part number
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:26 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST