E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > DIY Guides > DIY: Automatic to Manual Swap 2007 335i Sedan



Reply
 
Thread Tools Search this Thread
      05-27-2019, 07:05 PM   #111
Wrecker 426
New Member
Wrecker 426's Avatar
9
Rep
28
Posts

Drives: 07 335xi
Join Date: Nov 2016
Location: NC

iTrader: (0)

Quote:
Originally Posted by CeeWhizzle View Post
Correct. And the CAN Bus wires are the ones that are twisted together. You need to either create your own way of looping them with the plug or simply snip the wires and connect each of the 2 twisted pairs together to close the loop. The other wires can simply be tucked away or forgotten about.
So find the twisted ones and cut and splice them together thatís it?

Already have the manual harness in and all mechanical parts, having issues bleeding the clutch. I used the drives side tap front eh brake resivoir and it only pushes air into my clutch system
Appreciate 0
      05-27-2019, 07:13 PM   #112
Wrecker 426
New Member
Wrecker 426's Avatar
9
Rep
28
Posts

Drives: 07 335xi
Join Date: Nov 2016
Location: NC

iTrader: (0)

For those wondering where the clutch hard line runs
Attached Images
 
Appreciate 1
8081M18.00

      05-31-2019, 05:49 PM   #113
Wrecker 426
New Member
Wrecker 426's Avatar
9
Rep
28
Posts

Drives: 07 335xi
Join Date: Nov 2016
Location: NC

iTrader: (0)

Quote:
Originally Posted by stuta View Post
the clutch switch has 4 wires running to it.
no.1 wire is brown and should be connected to other ground wires underneath the dash
no.2 wire which should be blue runs to no. 18 on the ECU/DME
no.3 wire which is a bit greenish or so... goes to number 3 on CAS
no.4 wire goes to no.41 on CAS

there is no connector at no.3 position on CAS but you can pull off one from old harness and plug it in there

i think there is already a wire running to position 41 and here you simply bridge the wire from clutch switch on to the wire already on CAS and cover it up with insulation tape.

once this is done you should be able to start car with both brake and clutch depressed.

A DDE IS what DME or ECU is to bmw diesel cars...

hope that helps and anyone is free to correct where i might be wrong.....
the likes of dave and nick know better....
Which plug #18 for the DME?
Appreciate 0
      05-31-2019, 06:04 PM   #114
Wrecker 426
New Member
Wrecker 426's Avatar
9
Rep
28
Posts

Drives: 07 335xi
Join Date: Nov 2016
Location: NC

iTrader: (0)

I put it in the grey one, there wasnít a wire there yet, itís were the JB4 2step wire goes
Appreciate 0
      05-31-2019, 06:55 PM   #115
Wrecker 426
New Member
Wrecker 426's Avatar
9
Rep
28
Posts

Drives: 07 335xi
Join Date: Nov 2016
Location: NC

iTrader: (0)

Here is how I did the clutch wiring
Attached Images
     
Appreciate 1
8081M18.00

      05-31-2019, 06:56 PM   #116
Wrecker 426
New Member
Wrecker 426's Avatar
9
Rep
28
Posts

Drives: 07 335xi
Join Date: Nov 2016
Location: NC

iTrader: (0)

So when doing the write is NFRM the same as FRM?
Appreciate 0
      05-31-2019, 08:18 PM   #117
Wrecker 426
New Member
Wrecker 426's Avatar
9
Rep
28
Posts

Drives: 07 335xi
Join Date: Nov 2016
Location: NC

iTrader: (0)

Well I got it to start once but my windshield wipers are on all the time now! And a fuck ton of lights.
Appreciate 0
      05-31-2019, 08:44 PM   #118
Wrecker 426
New Member
Wrecker 426's Avatar
9
Rep
28
Posts

Drives: 07 335xi
Join Date: Nov 2016
Location: NC

iTrader: (0)

Got it to start again wipers stopped, however I get a nasty grinding sound from how far I have to push the clutch in to get it to start, also no rpm indication on the instrument cluster
Appreciate 0
      06-05-2019, 08:31 AM   #119
Maniac0908
Major
Maniac0908's Avatar
United_States
155
Rep
1,428
Posts

Drives: Alpine White 07 335xi Sedan
Join Date: Feb 2013
Location: Towson, MD

iTrader: (2)

Quote:
Originally Posted by Wrecker 426 View Post
Got it to start again wipers stopped, however I get a nasty grinding sound from how far I have to push the clutch in to get it to start, also no rpm indication on the instrument cluster
Figure it out?
__________________
2007 335XI SEDAN // JB4 G5 // BMS METH KIT // VRSF DOWNPIPES // AFE DCI // ER CP W/ TIAL BOV // MMP SILICONE INLETS // XHP STAGE 3 AT FLASH // TREBILA BEF // BMS OCC // VRSF EXHAUST // FUEL-IT STAGE 2 LPFP // VRSF FMIC // PRECISION RACEWORKS IGNITION SYSTEM // CATUNED COILOVERS // CIC AND COMBOX RETROFIT //
Appreciate 0
      06-20-2019, 01:36 AM   #120
stuta
New Member
3
Rep
22
Posts

Drives: bmw e90 330d
Join Date: Sep 2018
Location: windhoek namibia

iTrader: (0)

Quote:
Originally Posted by Wrecker 426 View Post
Got it to start again wipers stopped, however I get a nasty grinding sound from how far I have to push the clutch in to get it to start, also no rpm indication on the instrument cluster
Glad you got it to start...
However, did you figure out what the grinding sound was?
Appreciate 0
      06-20-2019, 10:45 PM   #121
Wrecker 426
New Member
Wrecker 426's Avatar
9
Rep
28
Posts

Drives: 07 335xi
Join Date: Nov 2016
Location: NC

iTrader: (0)

Quote:
Originally Posted by Maniac0908 View Post
Figure it out?
My battery died during the flashing processes so no idea why the wipers were doing that, I was able to drive it around but no speedo or tach, havenít had time to look at it, 16 hour days at work, 1/2 hour drive to and from work, Iíll look at it soon again
Appreciate 1
8081M18.00

      06-20-2019, 10:47 PM   #122
Wrecker 426
New Member
Wrecker 426's Avatar
9
Rep
28
Posts

Drives: 07 335xi
Join Date: Nov 2016
Location: NC

iTrader: (0)

Quote:
Originally Posted by stuta View Post
Glad you got it to start...
However, did you figure out what the grinding sound was?
I believe the grinding is from the bolts I used of the twin disk, the heads are a bit taller then the supplied bolts, I believe the arm that hold the throw out bearing is hitting the tops. I just got a borescope and was going to drill a small hole in the bell housing to get a peak at it
Appreciate 1
8081M18.00

      06-22-2019, 01:38 PM   #123
Wrecker 426
New Member
Wrecker 426's Avatar
9
Rep
28
Posts

Drives: 07 335xi
Join Date: Nov 2016
Location: NC

iTrader: (0)

Does anyone have a list of values that should be in the VO for CAS?
Appreciate 0
      06-22-2019, 07:39 PM   #124
Wrecker 426
New Member
Wrecker 426's Avatar
9
Rep
28
Posts

Drives: 07 335xi
Join Date: Nov 2016
Location: NC

iTrader: (0)

Got it running, for some reason I canít post picture from my phone, I will up load my fuck up soon, canít believe Iv been chasing shit for a couple days on this thing and it was so simple
Appreciate 0
      06-22-2019, 08:15 PM   #125
Wrecker 426
New Member
Wrecker 426's Avatar
9
Rep
28
Posts

Drives: 07 335xi
Join Date: Nov 2016
Location: NC

iTrader: (0)

so the CAN bus wiring was wrong, its supposed to be blue to blue and red to red.

after that i went and reset adaptations for the EKPM DME and TCASE(cant remember module) and the deleted and cleared codes.

Had to do it multiple times. but all lights except brake light are gone.

not advertising, but used bimmer tools to clear codes and do coding after i got in touch with them and their customer service. they helped me through this last bit. would recommend it to anyone.

Car runs as expected, chatter from the twin disk, slower rev due to extra weight on the flywheel, all expected, and awesome.
Attached Images
  
Appreciate 1
8081M18.00

      06-30-2019, 04:54 AM   #126
stuta
New Member
3
Rep
22
Posts

Drives: bmw e90 330d
Join Date: Sep 2018
Location: windhoek namibia

iTrader: (0)

Quote:
Originally Posted by Wrecker 426 View Post
so the CAN bus wiring was wrong, its supposed to be blue to blue and red to red.

after that i went and reset adaptations for the EKPM DME and TCASE(cant remember module) and the deleted and cleared codes.

Had to do it multiple times. but all lights except brake light are gone.

not advertising, but used bimmer tools to clear codes and do coding after i got in touch with them and their customer service. they helped me through this last bit. would recommend it to anyone.

Car runs as expected, chatter from the twin disk, slower rev due to extra weight on the flywheel, all expected, and awesome.
am happy for you.
did you get your reverse lights working?
Appreciate 0
      07-30-2019, 05:46 AM   #127
DenoirN54
New Member
United_States
9
Rep
26
Posts

Drives: 2007 BMW 335i
Join Date: Jan 2018
Location: Seattle, WA

iTrader: (0)

Excellent job man, I'll be finishing my install up later this month.
Appreciate 0
      08-16-2019, 11:18 PM   #128
Wrecker 426
New Member
Wrecker 426's Avatar
9
Rep
28
Posts

Drives: 07 335xi
Join Date: Nov 2016
Location: NC

iTrader: (0)

Quote:
Originally Posted by stuta View Post
am happy for you.
did you get your reverse lights working?
No looks like I may have to do custom wire for it.

The self adjusting clutch after 300-400 miles made it so the throw out bearing arm wasnít hitting the clutch bolts anymore, so I donít have to pull it all back out thankfully.
Appreciate 0
      08-17-2019, 01:50 AM   #129
cozzyman
New Member
9
Rep
23
Posts

Drives: BMW 335d AUDI RS6 AVANT
Join Date: Aug 2019
Location: MANCHESTER UK

iTrader: (0)

Quote:
Originally Posted by Wrecker 426 View Post
No looks like I may have to do custom wire for it.

The self adjusting clutch after 300-400 miles made it so the throw out bearing arm wasnít hitting the clutch bolts anymore, so I donít have to pull it all back out thankfully.
Take one wire to ground on your reverse light switch, run a wire from the other terminal tp pin 19 on your FRM unit. if the car is coded correctly reverse light and proximity sensors will work.
Appreciate 0
      09-08-2019, 03:43 PM   #130
Muz180
New Member
0
Rep
13
Posts

Drives: BMW 335xi
Join Date: Jul 2019
Location: Naperville

iTrader: (0)

Hey man I know this is a super old post and you probably don't own the car now, but I was working on an swapping out my n54 motor as I had a spun rod bearing, anyways just wondering how much easier it would be to do an auto to manual conversion because the engine and transmission are already pulled out of the car. I was thinking about purchasing a wrecked 335 with the engine and manual transmission and just swapping everything over.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 10:12 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST