E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > UK > UK Technical Forum > HELP !! My 320d turbo still not working despite replacement!!!!



Reply
 
Thread Tools Search this Thread
      08-14-2019, 07:14 PM   #1
bfaone
New Member
bfaone's Avatar
United Kingdom
0
Rep
29
Posts

Drives: 320d SE Auto
Join Date: Jul 2017
Location: Londonderry

iTrader: (0)

HELP !! My 320d turbo still not working despite replacement!!!!

I had been limping along with CHECK ENGINE LIGHT for a while. (My car is 2006 320D M47 with 127000 miles and 163bhp diesel)
Occasional erasing errors with Ista D would sometimes make the turbo work briefly off and on.
Lately the car would not get out of limp mode....Very difficult to climb uphills and very little power. The Rpms at times would not go above 2000
The following faults kept on popping up
003F25 DDE: Charge-air tube monitoring
003FF1 DDE: Air-mass flow sensor
004530 DDE: Charge-air pressure control , control deviation
004390 DDE: Charge-air temp sensor, signal
004507 DDE: Exhaust-gas recirculation

The local indy BMW garage advised that The turbo is gone,,,,although there was no whistling or shaft play.... Changed today, a new reconditioned turbo with 2yrs warranty.

THERE IS ABSULUTELY NO CHANGE.......The same fault codes....Check engine light comes up every road trip.... the same mixture of the above faults.....

I have cleaned the AGR.... No improvement......For sure,,, Turbo itself is new,,,,NOT ENGAGING DUE TO SOME OTHER FAULT!!!!!

I HAVE NO CLUE...... ANY SENSOR??? HOW TO CHECK WHICH ONE...

ANY HELP WOULD BE REALLY APPRECIATED
Appreciate 0
      08-15-2019, 01:11 AM   #2
rasa bmw
Major
115
Rep
1,340
Posts

Drives: e92 335d coupe e90 saloon 330d
Join Date: Jul 2017
Location: northumberland

iTrader: (0)

you done vac lines.turbo actuator check yeh ?
Appreciate 0
      08-15-2019, 02:25 AM   #3
therealdb1
Second Lieutenant
33
Rep
266
Posts

Drives: Graphite E93 335i
Join Date: Aug 2017
Location: Norfolk UK

iTrader: (0)

As Rasa says, check every air/vacuum line on the inlet side for leaks especially any rubber ones which always have a tendancy to split on the side you cannot see. So don't just look at them give them a good squeeze along their length with the engine running and listen for leaks.

The other thing that immediately springs out of your post is the MAF fault code. What have you done about that? Try electrically disconnecting it to see if it makes a difference. The EML will not go out because obviously the MAF is disconnected but if the car drives better that could be a source of trouble.
Appreciate 0
      08-15-2019, 03:08 AM   #4
bfaone
New Member
bfaone's Avatar
United Kingdom
0
Rep
29
Posts

Drives: 320d SE Auto
Join Date: Jul 2017
Location: Londonderry

iTrader: (0)

I am going to give a thorough check to vacuum lines and follow the MAF advice.. ...
I will report back to you guys....
Appreciate 0
      08-15-2019, 05:44 AM   #5
aaronblack
New Member
9
Rep
25
Posts

Drives: E92 330i N53 - Manual
Join Date: Apr 2019
Location: London

iTrader: (0)

I had similar issues, on my turbo petrol (S3) it was simple vacuum leak! On my diesel (N47) there was a 1/2cm hole in the intake manifold soon as I changed it everything went back to normal!
Appreciate 0
      08-15-2019, 09:19 AM   #6
rasa bmw
Major
115
Rep
1,340
Posts

Drives: e92 335d coupe e90 saloon 330d
Join Date: Jul 2017
Location: northumberland

iTrader: (0)

Quote:
Originally Posted by bfaone View Post
I am going to give a thorough check to vacuum lines and follow the MAF advice.. ...
I will report back to you guys....
thoriugh ? surely the garage did all this before saying turbo,,id get back to them asap and have it put with them,,specialists my arse
Appreciate 0
      08-15-2019, 08:19 PM   #7
bfaone
New Member
bfaone's Avatar
United Kingdom
0
Rep
29
Posts

Drives: 320d SE Auto
Join Date: Jul 2017
Location: Londonderry

iTrader: (0)

I did find one vacuum pipe a little weak at one end. Changed it. Looked at all of them, they seem OK.
No change after doing Vaccum pipe change.

Repeating to clear DDE faults.....they come back again.

Checked the charge-air pipe circuit for both pipes going to and coming from intercooler....
Turbo is coming on when standing still if revved...but only momentarily when driving and then limp mode....the charge air pipes balloon up slightly which means it is generating pressure for inlet manifold.......
MAP sensor comes to mind.... may be NOT WORKING......????? As there seem to be a fault code about charge air pressure deviation ....
Removed the acoustic covers/ rear one and located and removed MAP / charge pressure sensor..........
THE OPENING IN THE TIP IS FILLED SOLID WITH SOOT / GUNK.....
100% ETHENOL AND A SOFT BRUSH ..... CLEANED IT CAREFULLY, now has a 6mm deep hole again.....
Refitted it.......
Cleared the errors.....
Test drive........VERY GOOD RESULTS.........RUNS WELL, still not 100% but a huge improvement......
Motor way runs for 20 mins....
Some hesitation is still there.....

Ista reports now persistently with ONLY ONE FAULT INSTEAD OF THREE.....
CHECK ENGINE LIGHT DID NOT COME BACK SO FAR,
FINGERS CROSSED.....

THIS IS THE ONLY FAULT LEFT NOW
003FF1 AIR MASS FLOW SENSOR

ORDERED IT ONLINE JUST NOW ........

WAIT TO SEE IF SHE IS FULLY CURED........

WILL REPORT BACK ONCE REPLACEMENT IS HERE ....
Appreciate 0
      08-15-2019, 08:27 PM   #8
bfaone
New Member
bfaone's Avatar
United Kingdom
0
Rep
29
Posts

Drives: 320d SE Auto
Join Date: Jul 2017
Location: Londonderry

iTrader: (0)

I trusted the Garage and am surprised at their MIS-DIAGNOSIS has cost me 5 full days without car and 350 ( for parts only) out of pocket for replacement turbo and Inlet pipes etc , Turbo filtre air filtre, Oil filtre and New oil......
All to see the original problem still there !!!!!!!!!!

Thanks for folks like you I am humbled......

Last edited by bfaone; 08-15-2019 at 08:34 PM..
Appreciate 0
      08-16-2019, 04:00 AM   #9
therealdb1
Second Lieutenant
33
Rep
266
Posts

Drives: Graphite E93 335i
Join Date: Aug 2017
Location: Norfolk UK

iTrader: (0)

Glad you are almost there.

Often that is the value of running diagnostics at home because even if you don't feel like doing the job yourself you can have an idea what the problem is and whether the garage is correctly diagnosing for you.

It is also a benefit of being a member of a forum like this where you have many people with similar cars that may have previously come across the same issues that you have.

Unfortunately, in this case, it seems the garage had less idea than you but without defending them at all you have to remember that they are a commercial enterprise and cannot afford to spend 2 days on a diagnosis that they can only charge 1 hour for.

At least your turbo should be good for a while.

Let us know how the MAF goes.
Appreciate 0
      08-16-2019, 07:18 AM   #10
rasa bmw
Major
115
Rep
1,340
Posts

Drives: e92 335d coupe e90 saloon 330d
Join Date: Jul 2017
Location: northumberland

iTrader: (0)

did ypu keep old turbo,,maybe recoup some money if its still good
Appreciate 0
      08-19-2019, 03:51 AM   #11
bfaone
New Member
bfaone's Avatar
United Kingdom
0
Rep
29
Posts

Drives: 320d SE Auto
Join Date: Jul 2017
Location: Londonderry

iTrader: (0)

Yes. I have it safe and sound. It looks good .
The only thing is , I will have to loose my 2 yrs warranty for Reconditioned turbo as I will not return the old ....🤔
You are right, I should sell it as used good condition removed in error from 320d.....e90 🤞
Still waiting to get MAF in mail.......
Appreciate 0
      08-19-2019, 06:39 PM   #12
bfaone
New Member
bfaone's Avatar
United Kingdom
0
Rep
29
Posts

Drives: 320d SE Auto
Join Date: Jul 2017
Location: Londonderry

iTrader: (0)

So, Changed the MAF. Cleared the EML, Service function in ista, Did the cleared MAF adaptations as recommended after a new MAF.
Started installing for a change, into DDE function.....
Don't know what previously was, but the Mass Air flow is being read... ( May be it was reading previously as well ; not sure as I had not checked
Did a test run......ZERO PROGRESS,,,,,, IN LIMP MODE.......

THE FOLLOWING ERRORS ARE STILL COMING
3F25 charge air tube monitoring
3FF1 Air mass flow sensor

???????

It did kick into turbo off and on only once or twice.......

I don't know what's happening....
Is it leaking at the level of charge-air hose or Intercooler ?????
Appreciate 0
      08-19-2019, 06:41 PM   #13
bfaone
New Member
bfaone's Avatar
United Kingdom
0
Rep
29
Posts

Drives: 320d SE Auto
Join Date: Jul 2017
Location: Londonderry

iTrader: (0)

How to check for a leak at Outflow hose or intercooler ??
Appreciate 0
      08-24-2019, 03:31 PM   #14
bfaone
New Member
bfaone's Avatar
United Kingdom
0
Rep
29
Posts

Drives: 320d SE Auto
Join Date: Jul 2017
Location: Londonderry

iTrader: (0)


I have Solved the riddle.

Paid attention to Charge-air pressure Deviation ERROR
Connected INPA
Into Engine - DDE
Started the Car
Live Data of Sensors .....
Mass air flow Reading matches what it should be.....changes with throttle
Charge-air Pressure DOES NOT match the expected value !!!!!! Its struck at 1024...
That simply means MAP sensor is OUT !!!!!!!!!!!
ITS NOT READING WHAT PRESSURE IS CHARGE-AIR GENERATING UNDER RPM
SO READS STATIC ....NO CHANGE WITH THROTTLE...

New MAPP SENSOR

BINGO......
EVERYTHINGS IS FIXED......
TURBO BACK ON LINE.......

RESET THE TRANSMISSION ADAPTATIONS.....
MASS AIR FLOW ALREADY DONE....

Today I removed the INTAKE MANIFOLD
Giving it a thorough clean .....
Also thorough cleaned EGR .....
White spirit and a plastic bristles brush...

Thanks for everyone's well wishes....
Appreciate 0
      08-25-2019, 02:33 AM   #15
rasa bmw
Major
115
Rep
1,340
Posts

Drives: e92 335d coupe e90 saloon 330d
Join Date: Jul 2017
Location: northumberland

iTrader: (0)

champion,,good luck
Appreciate 0
      08-25-2019, 04:38 AM   #16
Bluewater335D
Private First Class
16
Rep
147
Posts

Drives: E92 LCI 335D, F48 X1 18d
Join Date: Nov 2018
Location: Hampshire, UK

iTrader: (0)

well done
Appreciate 0
      08-25-2019, 08:17 AM   #17
nick46
First Lieutenant
nick46's Avatar
55
Rep
382
Posts

Drives: Bmw E91 lci 330d msport
Join Date: Aug 2017
Location: Bridgwater

iTrader: (0)

Excellent, glad you got to the bottom of it.
Appreciate 0
Reply

Bookmarks

Tags
turbo failure e90 320d m47

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 04:21 PM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST