E90Post
 


Coby Wheel
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > DTC codes A0B1 and A0B6 any experience?



Reply
 
Thread Tools Search this Thread
      02-27-2021, 01:10 PM   #1
Mike335de92
New Member
0
Rep
10
Posts

Drives: BMW 335d e92
Join Date: Feb 2021
Location: Wales

iTrader: (0)

DTC codes A0B1 and A0B6 any experience?

I've had these two codes show up.
[IMG][/IMG]

Has anyone ever had or witnessed these? And repaired it?
Attached Images
 
Appreciate 0
      02-28-2021, 02:36 PM   #2
e91Owner
e91Owner
United_States
34
Rep
174
Posts

Drives: 2011 BMW 328i Wagon
Join Date: Mar 2018
Location: Charleston, SC

iTrader: (0)

Quote:
Originally Posted by Mike335de92 View Post
I've had these two codes show up.
[IMG][/IMG]

Has anyone ever had or witnessed these? And repaired it?
Quote:
Originally Posted by Mike335de92 View Post
I've had these two codes show up.
[IMG][/IMG]

Has anyone ever had or witnessed these? And repaired it?

Well it's your shifter according to those code not matching what the transmission is actually doing. Hopefully it is just the selector itself and not the transmission, but given you aren't showing any other codes, I would assume the former. Not sure if you are LCI or pre-LCI, but if moving the knob through it's paces and clearing it again while in park doesn't clear it, you may have to check the connections or replace it altogether.
Appreciate 0
      03-01-2021, 03:41 AM   #3
Mike335de92
New Member
0
Rep
10
Posts

Drives: BMW 335d e92
Join Date: Feb 2021
Location: Wales

iTrader: (0)

Quote:
Originally Posted by e91Owner View Post
Quote:
Originally Posted by Mike335de92 View Post
I've had these two codes show up.
[IMG][/IMG]

Has anyone ever had or witnessed these? And repaired it?
Quote:
Originally Posted by Mike335de92 View Post
I've had these two codes show up.
[IMG][/IMG]

Has anyone ever had or witnessed these? And repaired it?

Well it's your shifter according to those code not matching what the transmission is actually doing. Hopefully it is just the selector itself and not the transmission, but given you aren't showing any other codes, I would assume the former. Not sure if you are LCI or pre-LCI, but if moving the knob through it's paces and clearing it again while in park doesn't clear it, you may have to check the connections or replace it altogether.
It's a pre lci

Yeah once I clear the codes it goes away completely , and drives as normal, then after a while it will come back, I notice it mostly in sport/manual shifter mode.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 02:59 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST