E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > No Crank, No Start even after replacing starter



Reply
 
Thread Tools Search this Thread
      11-28-2022, 10:02 PM   #1
DeobandiPrince
Enlisted Member
11
Rep
39
Posts

Drives: 2009 328i Manual
Join Date: Mar 2021
Location: Detroit, MI

iTrader: (0)

No Crank, No Start even after replacing starter

Hey All,

My BMW doesn't want to start. When I put the key in the barrel and push the clutch down and press the start button, I can hear the fuel pump prime but no clicking. I tried replacing the starter and same issue. I'm getting codes a0b3 and a0b4.

I can get the car starting with a push start and popping it into gear but can't depend on this method all the time.

FYI my car is not equipped with an IBS sensor from factory.

I also tried hot wiring the starter as shown in the image below (with pin 4 of that green connector with the white wire that goes directly to the starter straight to the + terminal post in the engine bay) and it would get the starter to spin immediately after which the car would turn on but that method no long works.


Also, for a while, once you push started the car and popped the clutch, you could turn the car off and it would turn back on as long as you didn't wait too long. If you let the car sit for like 5-10 minutes, it wouldn't start again and would have to push start it. But now that doesn't work either (I mean to say once you turn the car off, it stays off no matter how fast you turn it back on)

I tried replacing the big black fuse in the glove box fuse box in the top right corner (I believe it's called terminal 30 relay.) It does get warm when I try and start the car multiple times. Not sure what other fuses and relays to check though.

Am ready to have it towed to a indy with good google ratings who say they specialise in euorpean cars but wanted to see if anyone here had any idea before I go ahead with it later this week

Last edited by DeobandiPrince; 11-28-2022 at 10:28 PM..
Appreciate 0
      11-29-2022, 12:33 AM   #2
Guy Fieri
HOLY MOLY STROMBOLI
Guy Fieri's Avatar
841
Rep
1,039
Posts

Drives: RED CAMARO
Join Date: Jul 2016
Location: FLAVORTOWN

iTrader: (4)

Garage List
Worth checking your ground cables
Appreciate 1
      11-30-2022, 11:04 AM   #3
DeobandiPrince
Enlisted Member
11
Rep
39
Posts

Drives: 2009 328i Manual
Join Date: Mar 2021
Location: Detroit, MI

iTrader: (0)

Quote:
Originally Posted by Guy Fieri View Post
Worth checking your ground cables
Any particular ground cables I should look for? There's the one directly on the body of the starter but are there any others that may affect it?
Appreciate 0
      12-05-2022, 02:33 PM   #4
DeobandiPrince
Enlisted Member
11
Rep
39
Posts

Drives: 2009 328i Manual
Join Date: Mar 2021
Location: Detroit, MI

iTrader: (0)

Hey guys. Still at a lost of what I can look into. If you guys have any ideas or potential things I can check or data/INPA info I can provide, please let me know.
Appreciate 0
      12-06-2022, 08:24 AM   #5
Suvorovo
First Lieutenant
Suvorovo's Avatar
153
Rep
343
Posts

Drives: 2006 BMW e90 330xi 6MT
Join Date: Feb 2022
Location: New Jersey

iTrader: (0)

Any chance you didn't buy genuine BMW bolts for the starter. I don't think people have issues with rein bolt either. Some cheap starter bolts don't conduct current.
Appreciate 0
      12-10-2022, 07:58 PM   #6
Serf27
Brigadier General
Serf27's Avatar
United_States
1766
Rep
3,307
Posts

Drives: E90 335i
Join Date: Apr 2018
Location: Sitting in a BMW.

iTrader: (0)

Did you check your battery?
Appreciate 0
      12-11-2022, 11:42 AM   #7
chilledn52
Enlisted Member
Canada
19
Rep
46
Posts

Drives: 2007 BMW 328xi 6MT
Join Date: Sep 2022
Location: Edmonton, Alberta

iTrader: (0)

Starter relay? Or Dead spot in Starter?
Appreciate 0
      12-11-2022, 12:05 PM   #8
desertman123
E82 Mudflap Ambassador
desertman123's Avatar
United_States
2163
Rep
2,211
Posts

Drives: '08 128i
Join Date: May 2016
Location: Orlando, FL

iTrader: (0)

Garage List
1992 Honda Beat  [9.50]
2008 BMW 128i  [10.00]
2014 BMW 528i  [10.00]
Unless your ground straps are really bad, your CAS module is probably toast. Those codes are the tell. Has it ever sounded like a relay is going crazy?

Mine went out too, apparently it's an increasingly common thing. Pull it out and send it off to someone on eBay. I sent mine off and they told me the unit was fried, so I grabbed another from the junkyard and they cloned it for like $120. You need to send off the DME and keys along with it - all these are paired together.
__________________

My 2008 128i - Sparkling Graphite/Beige - Sport pkg - 6MT - Click me!
Parents' 2014 528i - Mineral White/Ivory White - fully loaded
Instagram @Andreys_128i
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 04:21 PM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2023, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST