E90Post
 


ECS BMW
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > USA - Rockies / Midwest > Crankshaft going?



Reply
 
Thread Tools Search this Thread
      11-28-2017, 07:43 PM   #1
Kyden M
Registered
0
Rep
2
Posts

Drives: e90 328i 2008
Join Date: Nov 2017
Location: SLC, UT

iTrader: (0)

Crankshaft going?

Hi so I have a 328i 08’. Just maybe 2 weeks ago it started to have a rough idle and would even die at times. I am getting a check engine light when it dies as well as sometimes when I am on the road, right after I have a stutter shifting, or almost like a jump when accelerating. It almost would seem like a misfire, but I am getting no codes for that. As well just in the past 2 days I am getting a high pitched noise from the engine sounding like a tea kettle, built up with pressure. I got a code for the crankshaft sensor, does this sound correct. I couldn’t find anything connecting the noise to that sensor. Oh and as well with the rough idle, I have some issues with starting, where it takes 4-5secs for it to turn over. Battery and alternator are fine. I will upload a picture of the warning lights that come up.

Appreciate any help!! Thanks,
Attached Images
 
Appreciate 0
      11-28-2017, 08:00 PM   #2
GoRomeo
Brigadier General
GoRomeo's Avatar
521
Rep
3,350
Posts

Drives: 330i
Join Date: Feb 2006
Location: San Diego CA

iTrader: (0)

Garage List
2006 330i  [2.83]
Quote:
Originally Posted by Kyden M View Post
Hi so I have a 328i 08’. Just maybe 2 weeks ago it started to have a rough idle and would even die at times. I am getting a check engine light when it dies as well as sometimes when I am on the road, right after I have a stutter shifting, or almost like a jump when accelerating. It almost would seem like a misfire, but I am getting no codes for that. As well just in the past 2 days I am getting a high pitched noise from the engine sounding like a tea kettle, built up with pressure. I got a code for the crankshaft sensor, does this sound correct. I couldn’t find anything connecting the noise to that sensor. Oh and as well with the rough idle, I have some issues with starting, where it takes 4-5secs for it to turn over. Battery and alternator are fine. I will upload a picture of the warning lights that come up.

Appreciate any help!! Thanks,


I would think that's what the code says but, read about online and see if people had same symptoms as you. You can start from there...
Appreciate 0
      12-12-2017, 11:17 AM   #3
335dlci
Captain
64
Rep
771
Posts

Drives: 335d
Join Date: Apr 2014
Location: Socal

iTrader: (0)

You may be getting close to the crankshaft replacement interval.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 06:24 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST