E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > Intermittent Engine Rattle / Vibration Sound at Idle - Video Added



Reply
 
Thread Tools Search this Thread
      12-04-2013, 12:38 PM   #1
cxc511
Private First Class
cxc511's Avatar
6
Rep
106
Posts

Drives: 2007 E92 328 6MT
Join Date: Jul 2010
Location: Erie, PA

iTrader: (0)

Intermittent Engine Rattle / Vibration Sound at Idle - Video Added

As the title says, I am experiencing an intermittent rattle / vibration sound coming from my engine (N52) at idle in my 2007 328i coupe with 58k miles. Some time ago, I experienced a similar sound and determined my air filter housing was not properly seated in the engine bay and easily fixed myself. Thinking it may be the same issue, I took a look under the hood but quickly determined it was not the cause.

While inspecting the engine, in addition to this noise, I noticed some oil residue on the front and side and decided to take a quick trip up to the dealer on my way to work. My SA was able to hear the sound and thought it could possibly be a drive belt pulley. He stated the oil was possibly a valve cover gasket issue. I was able to get the car in the following week and the source of the oil was actually the oil filter housing gasket which I had replaced. However, the tech did not hear the engine noise I mentioned while he had the car.

Any ideas as to what the cause of this sound could be? My car runs fine otherwise and the sound only seems to occur at idle. If one of the pulleys had a bad bearing or something, I would expect the issue to create noise constantly and increase with engine RPMs.

As an aside, my car had basically no issues under remaining factory warranty or CPO! It has been good to me, so I can't really complain if I have to put some money into it. However, my dealer's labor rate is $120 per hour and they mark up parts over list. The SA and tech are great guys, but I am definitely going to give an independent shop a try as I try to tackle this issue.

Last edited by cxc511; 01-11-2014 at 03:28 PM.
Appreciate 0
      12-04-2013, 02:48 PM   #2
SDemetris
FSAE Dude
United_States
51
Rep
765
Posts

Drives: E90 328xi
Join Date: Jul 2012
Location: Pittsburgh, PA

iTrader: (0)

hmm it might have been some oil on the belt that made it slip, but once the oil wore off the sound went away.
__________________
2007 TiAg 328xi: AA Tune, AFE intake, Full exhaust, 335xi Brakes, H&R RSB, UUC FSB, H&R Sports, Billy Sports...BBS SR 17x8

1985 Gazelle Beige 325e: Poly everything, e24 3.25 LSD, 225 lb weight reduction, Corbeau FX1, Shifter machined by me, roll bar, harness, all the other goodies. My "Racecar"...15x7 BBS RA
Appreciate 0
      12-04-2013, 04:02 PM   #3
cxc511
Private First Class
cxc511's Avatar
6
Rep
106
Posts

Drives: 2007 E92 328 6MT
Join Date: Jul 2010
Location: Erie, PA

iTrader: (0)

Quote:
Originally Posted by SDemetris View Post
hmm it might have been some oil on the belt that made it slip, but once the oil wore off the sound went away.
Thanks for your reply - that is what the tech said after he cleaned up some of the oil residue when the gasket was replaced. However I have been driving the car for a week and a half since and the issue still comes and goes.
Appreciate 0
      01-07-2014, 06:39 PM   #4
cxc511
Private First Class
cxc511's Avatar
6
Rep
106
Posts

Drives: 2007 E92 328 6MT
Join Date: Jul 2010
Location: Erie, PA

iTrader: (0)

I have continued to have this engine rattle / vibration issue and have noticed the it only seems to occur when the car is cold. Given the frigid temps today, it sounded like a small semi at idle! Any ideas what could be the problem? The car continues to run fine otherwise.
Appreciate 0
      01-08-2014, 12:09 PM   #5
David0ff
Combined Applications Group
David0ff's Avatar
Canada
563
Rep
405
Posts

Drives: Lada Scrapus Trofeo R
Join Date: Jan 2014
Location: Classified

iTrader: (1)

does the rattle maintain if you push the clutch in?
these bmw n52`s and all other equipped with the dual mass flywheel can be quite chatterer now and then
Appreciate 0
      01-08-2014, 06:43 PM   #6
cxc511
Private First Class
cxc511's Avatar
6
Rep
106
Posts

Drives: 2007 E92 328 6MT
Join Date: Jul 2010
Location: Erie, PA

iTrader: (0)

Quote:
Originally Posted by David0ff View Post
does the rattle maintain if you push the clutch in?
these bmw n52`s and all other equipped with the dual mass flywheel can be quite chatterer now and then
It occurs whether the clutch is depressed or not. It seems only to occur at or near idle when the car is cold with RPMs below 1,000. If I step on the gas it will go away as the RPMs rise only to recur back at idle. When the car warms up the issue becomes less noticeable or goes away.
Appreciate 0
      01-09-2014, 09:35 AM   #7
Three_thirty_I
Lieutenant Colonel
Three_thirty_I's Avatar
South Africa
142
Rep
1,786
Posts

Drives: '05 E90 330i Manual
Join Date: Aug 2010
Location: Cape Town, South Africa

iTrader: (0)

Garage List
Would you be able to take a video of this noise?
__________________
BMW E90 330i (M) '05 (His) | (Hers) BMW E46 320i f/l (M) '03

Appreciate 0
      01-09-2014, 04:03 PM   #8
Ferg
Master of my own domain!!
Ferg's Avatar
32
Rep
801
Posts

Drives: F82 M4/F15 X5
Join Date: Dec 2006
Location: Huntsville, AL

iTrader: (0)

I think I have the same problem. Mine sounds like when you crack the window and you get that buffeting sound. It is driving me crazy. I ordered some new motor mounts which I hope will fix it, we'll see if they ever come in the mail.
Appreciate 0
      01-11-2014, 03:18 PM   #9
cxc511
Private First Class
cxc511's Avatar
6
Rep
106
Posts

Drives: 2007 E92 328 6MT
Join Date: Jul 2010
Location: Erie, PA

iTrader: (0)

Quote:
Originally Posted by Three_thirty_I View Post
Would you be able to take a video of this noise?
Hopefully this helps. I had filmed a couple of clips with the hood open following a cold start but the sound became the clearest after I closed the hood and the idle had fallen a bit. Hard to tell if it was coming from the front or the top of the engine when I have the hood open. I have read elsewhere the belt tensioner / idler pulley could be consistent with the sound occurring when the car is cold and then moderating somewhat?

Appreciate 0
      01-11-2014, 10:06 PM   #10
Three_thirty_I
Lieutenant Colonel
Three_thirty_I's Avatar
South Africa
142
Rep
1,786
Posts

Drives: '05 E90 330i Manual
Join Date: Aug 2010
Location: Cape Town, South Africa

iTrader: (0)

Garage List
Hmm, will have to download this and listen to it on my sound system, but sort of reminds me of this vid:



Apparently the crank pulley bolt had failed and was causing a strange timing issue. The irregular idle "sound" seems similar, but not sure and not necessarily the same issue at all.
__________________
BMW E90 330i (M) '05 (His) | (Hers) BMW E46 320i f/l (M) '03

Appreciate 0
      05-26-2015, 02:40 PM   #11
left123
Second Lieutenant
left123's Avatar
41
Rep
281
Posts

Drives: TiAg 330i 6MT ZSP
Join Date: Nov 2011
Location: 757

iTrader: (3)

Quote:
Originally Posted by cxc511 View Post
As the title says, I am experiencing an intermittent rattle / vibration sound coming from my engine (N52) at idle in my 2007 328i coupe with 58k miles. Some time ago, I experienced a similar sound and determined my air filter housing was not properly seated in the engine bay and easily fixed myself. Thinking it may be the same issue, I took a look under the hood but quickly determined it was not the cause.

While inspecting the engine, in addition to this noise, I noticed some oil residue on the front and side and decided to take a quick trip up to the dealer on my way to work. My SA was able to hear the sound and thought it could possibly be a drive belt pulley. He stated the oil was possibly a valve cover gasket issue. I was able to get the car in the following week and the source of the oil was actually the oil filter housing gasket which I had replaced. However, the tech did not hear the engine noise I mentioned while he had the car.

Any ideas as to what the cause of this sound could be? My car runs fine otherwise and the sound only seems to occur at idle. If one of the pulleys had a bad bearing or something, I would expect the issue to create noise constantly and increase with engine RPMs.

As an aside, my car had basically no issues under remaining factory warranty or CPO! It has been good to me, so I can't really complain if I have to put some money into it. However, my dealer's labor rate is $120 per hour and they mark up parts over list. The SA and tech are great guys, but I am definitely going to give an independent shop a try as I try to tackle this issue.
OP, did you ever determine the cause of your rattle? I seem to be having the same symptoms and am interested in any headway you were able to make.

Thanks in advance.
__________________
Appreciate 0
      05-27-2015, 11:22 PM   #12
excel
New Member
0
Rep
25
Posts

Drives: 328i
Join Date: May 2008
Location: Canada

iTrader: (0)

I had this issue. It turned out to be the alternator pulley.
Appreciate 0
      06-03-2015, 03:30 PM   #13
left123
Second Lieutenant
left123's Avatar
41
Rep
281
Posts

Drives: TiAg 330i 6MT ZSP
Join Date: Nov 2011
Location: 757

iTrader: (3)

Quote:
Originally Posted by excel View Post
I had this issue. It turned out to be the alternator pulley.
Thanks Excel. Ill take a look at that now that you have given me something to try.

Did you do this yourself or take it in? Easy to fix? Just tighten it up or replace?

Thanks in advance.
__________________
Appreciate 0
      06-03-2015, 10:34 PM   #14
StealYourFace
Lieutenant Colonel
United_States
193
Rep
1,734
Posts

Drives: 2006 330i sport
Join Date: Jul 2009
Location: Shakedown Street, Buffalo NY

iTrader: (1)

Does it go away when you put the clutch in? Could be a noisy throwout bearing.
__________________
Appreciate 0
      06-03-2015, 10:36 PM   #15
SDemetris
FSAE Dude
United_States
51
Rep
765
Posts

Drives: E90 328xi
Join Date: Jul 2012
Location: Pittsburgh, PA

iTrader: (0)

I had a rattle that ended up being this

http://www.ecstuning.com/BMW-E90-328...st/OE/ES39969/
__________________
2007 TiAg 328xi: AA Tune, AFE intake, Full exhaust, 335xi Brakes, H&R RSB, UUC FSB, H&R Sports, Billy Sports...BBS SR 17x8

1985 Gazelle Beige 325e: Poly everything, e24 3.25 LSD, 225 lb weight reduction, Corbeau FX1, Shifter machined by me, roll bar, harness, all the other goodies. My "Racecar"...15x7 BBS RA
Appreciate 0
      06-08-2015, 02:31 PM   #16
excel
New Member
0
Rep
25
Posts

Drives: 328i
Join Date: May 2008
Location: Canada

iTrader: (0)

Quote:
Originally Posted by left123 View Post
Thanks Excel. Ill take a look at that now that you have given me something to try.

Did you do this yourself or take it in? Easy to fix? Just tighten it up or replace?

Thanks in advance.
It was a periodic groaning/rattling noise at idle just like this. First I changed the drive belt, no change, then the idler pulley, still nothing (though it did spin freely so it was time for replacement)

Then I bought an alternator pulley tool kit and a replacement pulley. It was strange - initially after changing it the sound was still there, and I went to bed ready to give up. But next morning it was gone and has not come back since.

I think the root cause may actually be something else and the pulleys wore to a point where the load on the crank was just enough to induce a weird harmonic, and changing the pulleys brought the load out of that range. Just a wild guess though, and I'm not worrying about it until it comes back.
Appreciate 0
      06-08-2015, 02:41 PM   #17
Stream
T667YM86
Stream's Avatar
Russian Federation
55
Rep
244
Posts

Drives: E90 325i 05'
Join Date: Mar 2013
Location: Russia, Surgut

iTrader: (0)

Quote:
Originally Posted by excel View Post
Then I bought an alternator pulley tool kit and a replacement pulley.
Can you please post p/n or link on this kit.
__________________
E90 325i 05MY, ZSP, Koni Sport, Eibach Pro-kit, BBS RK-II squared
Appreciate 0
      06-08-2015, 02:48 PM   #18
excel
New Member
0
Rep
25
Posts

Drives: 328i
Join Date: May 2008
Location: Canada

iTrader: (0)

Quote:
Originally Posted by Stream View Post
Can you please post p/n or link on this kit.
I'm in Canada so not sure it will help, but it was this one:
http://www.princessauto.com/en/detai...et/A-p8466658e

It's similar to the one ECS sells, cheaper even:
http://www.ecstuning.com/Search/Site..._Tool/ES11415/

And similar ones on ebay as well:
http://www.ebay.ca/itm/13-Piece-Alte...item463c19e402
Appreciate 0
      08-14-2018, 02:33 PM   #19
BMWFan02864
Registered
0
Rep
1
Posts

Drives: 2007 328i MT RWD
Join Date: Aug 2018
Location: Rhode Island

iTrader: (0)

OP,

I have the exact same car with the same issue. Did you ever figure it out?

Thanks
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 04:46 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST