E90Post
 


ECS BMW
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > Instrument cluster



Reply
 
Thread Tools Search this Thread
      06-11-2019, 04:01 PM   #1
Popps258
Registered
0
Rep
2
Posts

Drives: BMW E92 2006
Join Date: May 2019
Location: Leeds UK

iTrader: (0)

Instrument cluster

Hi, Pls forgive me if this is the wrong place to post this.
The warning section of my instrument cluster is not working totally black?
BMW E92 2006 330d.
I did buy a good fully working replacement to change out with but the same problem appears on the new cluster??
all the other sections work as they should.
Cant access anything through trip button either
Does anyone have any ideas?
many thanks
in advance.
Appreciate 0
      06-11-2019, 08:56 PM   #2
ctuna
Major General
874
Rep
9,092
Posts

Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

There is an LED test somewhere.
But if you are replacing Instrument Clusters
if requires a virginized new cluster.

Questions about the replacing the intrument cluster
are best answered on the coding sub forum. There are issues
with mileage matching.



https://www.newtis.info/tisv2/a/en/

https://www.newtis.info/tisv2/a/en/e...luster/YNELLWU

Last edited by ctuna; 06-11-2019 at 09:03 PM..
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 07:46 PM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST