E90Post
 


The Tire Rack
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > NEED HELP! P0015 (Vanos? Cam Position Sensor?)



Reply
 
Thread Tools Search this Thread
      10-13-2015, 12:27 PM   #1
JeffakaLucas
New Member
0
Rep
8
Posts

Drives: 3351
Join Date: Apr 2011
Location: Philly

iTrader: (0)

NEED HELP! P0015 (Vanos? Cam Position Sensor?)

Car: 2007 335I (2 door, non nav, non i-drive)
Miles: 134,000
Mods: Vishnu proceed and vishnu intakes

Recent Work Done:
New starter, Spark plugs, belt, new air filters, new front main seal, new water pump, new pulley, new tensioner, new battery, coolant flush.

Problem: P0015: Camshaft Position, Act B - bank 1, timing over retard

A little back story. I changed my spark plugs with OEM spark plugs to rid myself of a misfire under WOT. Upon completion, I started getting intermittent P0015 codes and limp mode.

One day, driving to work, my car stalled and then wouldn't start. I had it towed home and found that somehow in the middle of vanos problems my starter took a dump. So I replaced my starter and the car now starts fine.

So, at this point, I've replaced both the exhaust vanos solenoid and the exhaust cam position sensor. I've tried swapping each to see if the codes changes to P0014 with no dice.

My biggest problem is, my car sounds TERRIBLE right now. It sounds like it's knocking or having valve tap or something. When I turn the car off this awful knock/sequel thing happens so I don't want to keep repeating that.

I've search all over the boards and pretty much anyone that throws P0014/P0015 replace the solenoid and the CPS and they are back in action. I haven't read of anyone having noises associated with these codes. My code reader only reads P0015.

Anyone have any suggestions on what could be wrong? Or what I should try next?

Last edited by JeffakaLucas; 10-14-2015 at 06:02 PM.. Reason: update
Appreciate 0
      10-14-2015, 06:02 PM   #2
JeffakaLucas
New Member
0
Rep
8
Posts

Drives: 3351
Join Date: Apr 2011
Location: Philly

iTrader: (0)

Sorry for posting in the wrong sub. Can someone delete this?
Appreciate 0
Reply

Bookmarks

Tags
cam, p0014, p0015, position, vanos

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:20 PM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST