E90Post
 


The Tire Rack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > BMW Coding > Popping sounds after coding/SG_reset professional HU



Reply
 
Thread Tools Search this Thread
      10-21-2021, 04:58 PM   #1
Alpejohn
New Member
0
Rep
5
Posts

Drives: E87 118d 2007, E39 530d 2003
Join Date: Oct 2021
Location: Norway

iTrader: (0)

Question Popping sounds after coding/SG_reset professional HU

Hi,

This is not directly 3 series relevant but alot of info i found on google was located here, so i figured it must be alot of people that knows alot about this stuff on here, so please forgive me

My problem is that i bought a 09/10 professional HU with usb and bluetooth to retrofit to my 07 E87 with hifi, aux and the business HU (the pro HU also have the MOST connection). I put it in to test, and it worked, it showed bluetooth phone and i paired my phone to it and it worked great, music was playing through the aux and all was good. Did not show USB tho.
When checking the "secret" menu, it said "Stereo" under the Audio menu, and i have Hifi.

After reading alot on here, i changed my VO, removed 662 (business HU) and added 663 (pro HU), also added 6NN and 6FL. This still did not change it to Hifi, so i found out that a SG_reset should do the trick. So i did, and the hifi showed up and all was good. Found out later that the BT phone and voice command dissapeared after this, but i figured i could add them back later.

But after that, it started making popping sounds every 2-3 seconds, and i found out that the popping comes along with the red light (flashing in the back of the HU) from the MOST turning on and off.
My car does not have any MOST connection, so i guess it looks for it for some reason.. Weird thing is that it did not do this before.

It came out of a E91 with "Stereo" as far as i know from the settings in the .trc file i read out with NCS before i reset it.


So i have two problems:

-What can i do to get rid of the popping sound, and deactivate MOST?

-I changed my prod. date to 03/11 and added the 6FL and 6NN again, but bluetooth did not show up again, cant seem to get it back either.. What might be the problem?


Again, sorry for not posting directly related content, but i have looked all over the internet but i cant seem to find anything about this. I might be using the wrong words. Hope you can forgive me.

Regards
Fredrik
Appreciate 0
      10-22-2021, 03:59 AM   #2
ptpending
Colonel
ptpending's Avatar
294
Rep
2,311
Posts

Drives: e91
Join Date: Dec 2013
Location: Poland

iTrader: (1)

one way is to get any most cable and connect it radio quadlock to close most loop
another is to code out MOST, you have to check if you enabled some function which is operated over MOST
__________________
E81 2007 130i 6cylinder Montego blue
Retrofits: Harman Kardon, High-beam assistant, Removable tow hitch.
Appreciate 0
      10-22-2021, 09:47 AM   #3
Alpejohn
New Member
0
Rep
5
Posts

Drives: E87 118d 2007, E39 530d 2003
Join Date: Oct 2021
Location: Norway

iTrader: (0)

ptpending
Only thing i did was adding $6NN and $6FL, then reset the radio.
I have seen those loop back plugs on ebay, but will they fit in the quadlock? I'll check it out some more.

You would'nt happen to know what to look for to deactivate MOST? I tried searching for MOST in the .trc file but i dont think it found anything last time, but i remember seeing it somewhere..
Appreciate 0
      10-22-2021, 03:13 PM   #4
ctuna
Lieutenant General
1422
Rep
11,626
Posts

Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

Hi Fi is option 676 it must be added to the VO then programmed into the
the Radio . Actually it should already be in your VO so you could
try default programming it but since the Radio is slightly different
you may need a different one . See link at bottom of this entry.
Popping sounds often indicate the amplifier is going bad.
I would physically check the amp area for water.
The sounds systems between most of the lower series cars are the same.

The Radio's with a integrated Bluetooth and USB require a different code for the VO problem
I believe it's been mentioned on one of the threads here before.

If you really want to deactivate most there is a single line in the radio file called ring status that
can be set to nicht aktiv. this is found in the Radio File.
Could cause SOS or other errors and those functions would have to be turned off to.

http://www.e90post.com/forums/showthread.php?t=687463

The microphone wiring probably needs to be rerouted as it set to use the mulf 2 hi or combox.

As a check you can read your orignal options with Mdecoder.com

Option 676 is Hi Fi in all years it should be one of the first thing s that come up if you read the Rad File.

Last edited by ctuna; 10-22-2021 at 03:26 PM..
Appreciate 0
      10-23-2021, 02:24 AM   #5
Alpejohn
New Member
0
Rep
5
Posts

Drives: E87 118d 2007, E39 530d 2003
Join Date: Oct 2021
Location: Norway

iTrader: (0)

Quote:
Originally Posted by ctuna View Post
Hi Fi is option 676 it must be added to the VO then programmed into the
the Radio . Actually it should already be in your VO so you could
try default programming it but since the Radio is slightly different
you may need a different one . See link at bottom of this entry.
Popping sounds often indicate the amplifier is going bad.
I would physically check the amp area for water.
The sounds systems between most of the lower series cars are the same.

The Radio's with a integrated Bluetooth and USB require a different code for the VO problem
I believe it's been mentioned on one of the threads here before.

If you really want to deactivate most there is a single line in the radio file called ring status that
can be set to nicht aktiv. this is found in the Radio File.
Could cause SOS or other errors and those functions would have to be turned off to.

http://www.e90post.com/forums/showthread.php?t=687463

The microphone wiring probably needs to be rerouted as it set to use the mulf 2 hi or combox.

As a check you can read your orignal options with Mdecoder.com

Option 676 is Hi Fi in all years it should be one of the first thing s that come up if you read the Rad File.
Hi,

As my car has Hifi 676 from the factory the VO code has already been there so thats ok. Only "stereo codes" i had was 662 and 676.
As far as other codes it seems that i have used the right once, 663 for Pro HU, 6FL for usb audio, and 6NN for bluetooth HF, i have not seen any other mentioned for this. But as far as i have found it should help set the prod.date to 03/11, but i have seen people say 09/11 to, so i might try that also.

I have read the post you link to, not in detail but i have looked through it several times, will dig deeper!

I am 99% sure the amp is fine, as the pro radio did not make any popping sound before i did sg_reset, and the old radio did not make any pop either. I have also checked the amp a few weeks ago, and it was bone dry and no signs of water.
Also the pop comes when the MOST lights up in the back of the radio, then it turns off, and it turns back on and off, it keeps doing this all the time, and the pop comes every time it lights up.

As i dont have either MULF of COMBOX in my car, i dont even have a mic. So there is no reason for me to have the MOST activated, as i dont need it. I checked the radio file i copied to my computer, and it has the RING_STATUS set to aktive, so i will try to deactivate it. Just hope im able to code it, and that i dont need MOST diagnostics.
I'll give it a try and see what happends!

I will report back, thank you very much!
Appreciate 0
      10-23-2021, 12:34 PM   #6
ctuna
Lieutenant General
1422
Rep
11,626
Posts

Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

There is not such thing as Most diagnostics as far as I know.
Inpa in standard toos and Ista D for diagnostics should cover it all.
After a certain production date ,3/07 I believe there can be trouble writing
the Most Bus modules.

Could be the amp doesn't like the speaker outs from the base system instead
of the 5 volt differnetial signal to the amp when Hi Fi is properly coded.
Appreciate 0
      10-23-2021, 03:04 PM   #7
Alpejohn
New Member
0
Rep
5
Posts

Drives: E87 118d 2007, E39 530d 2003
Join Date: Oct 2021
Location: Norway

iTrader: (0)

Quote:
Originally Posted by ctuna View Post
There is not such thing as Most diagnostics as far as I know.
Inpa in standard toos and Ista D for diagnostics should cover it all.
After a certain production date ,3/07 I believe there can be trouble writing
the Most Bus modules.

Could be the amp doesn't like the speaker outs from the base system instead
of the 5 volt differnetial signal to the amp when Hi Fi is properly coded.
I bring very good news!

I found the "Ring_status" and set it to nicht_aktiv, and the popping is gone!
At the same time i enabled the bluetooth function and the usb function in the .trc file. After coding it bluetooth came back, but also USB!

So now everything is awsome, radio works perfect, i just need to make some wiring for the mic and mount the cable for the usb and its all good!

Thanks for pointing me in the direction of the ring_status, that was my biggest issue!
Appreciate 0
      10-23-2021, 03:04 PM   #8
ptpending
Colonel
ptpending's Avatar
294
Rep
2,311
Posts

Drives: e91
Join Date: Dec 2013
Location: Poland

iTrader: (1)

Quote:
Originally Posted by Alpejohn View Post
ptpending
Only thing i did was adding $6NN and $6FL, then reset the radio.
I have seen those loop back plugs on ebay, but will they fit in the quadlock? I'll check it out some more.

You would'nt happen to know what to look for to deactivate MOST? I tried searching for MOST in the .trc file but i dont think it found anything last time, but i remember seeing it somewhere..
you should read all topic about this radio
https://www.e90post.com/forums/showt...&highlight=6nn
and search other topics about 6nn option and you will get all information
__________________
E81 2007 130i 6cylinder Montego blue
Retrofits: Harman Kardon, High-beam assistant, Removable tow hitch.
Appreciate 0
      10-23-2021, 03:06 PM   #9
Alpejohn
New Member
0
Rep
5
Posts

Drives: E87 118d 2007, E39 530d 2003
Join Date: Oct 2021
Location: Norway

iTrader: (0)

Quote:
Originally Posted by ptpending View Post
you should read all topic about this radio
https://www.e90post.com/forums/showt...&highlight=6nn
and search other topics about 6nn option and you will get all information
Think i pretty much have looked in every topic, not read every detail tho.
There was just to much info.

But its fixed now, so im super happy!
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:48 PM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST