E90Post
 


Extreme Powerhouse
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Really rough idle with engine stall after high rpm



Reply
 
Thread Tools Search this Thread
      10-16-2020, 06:31 PM   #1
Cwp1851
Registered
0
Rep
1
Posts

Drives: BMW E90 2006 330i
Join Date: Oct 2020
Location: Salt Lake City, UT

iTrader: (0)

Really rough idle with engine stall after high rpm

First time poster here, I'm a little desperate. I have a 2006 E90 N52 330i, I just barely replaced my VCG, oil filter housing gasket, PCV valve and the hoses from the valve cover and oil pan, as well as my air intake gaskets. There weren't any issues before this repair other than oil getting everywhere and compromising other components, I just wanted to fix it before it became a worse problem. After I buttoned everything up, I started the engine and all seemed well until about a minute or so in. The engine is running really rough and sometimes will just stall on its own. I can keep the RPMs up with some gas with little to no problems, but the engine stalls as soon as I let off the pedal.

I have checked for a vacuum leak, but with my limited tools I haven't found one. The engine isn't throwing any codes either, I'm just getting nothing from it.

Has anyone experienced this before? I saw somewhere that ignition coils could be the problem? I replaced them about 35000 miles ago, so I'm doubtful it is that.

I've included video of what it sounds like if it helps, thanks everyone for your help.

Edit: I'm currently working on trying to get audio for the video

View post on imgur.com

Last edited by Cwp1851; 10-16-2020 at 06:33 PM.. Reason: Video doesn't have sound
Appreciate 0
      10-16-2020, 08:27 PM   #2
Mustafa.e92
Private First Class
Mustafa.e92's Avatar
32
Rep
184
Posts

Drives: 2009 bmw 335i
Join Date: Feb 2020
Location: Canada

iTrader: (0)

I think you answered your question your self. Check over your work. Make sure all the gaskets are on properly and all the bolts/nuts are tight. It's not coils because you can keep it running with ur foot on the gas. Even if 1 or 2 went out it should still run just misfire like a cun*.
Appreciate 0
      10-17-2020, 12:39 AM   #3
relative4
Major
United_States
541
Rep
1,199
Posts

Drives: '08 335xi E90 MT stage 1+
Join Date: Feb 2019
Location: Denver, CO

iTrader: (0)

Fuel trims?
__________________
Are you gonna eat that?
Appreciate 0
      10-17-2020, 06:57 AM   #4
rt7085
Private
United_States
22
Rep
57
Posts

Drives: E91 328xi wagon / Mercedes GTS
Join Date: Mar 2016
Location: West Newton, MA

iTrader: (0)

Much more likely is that it is misfiring. Coil connector not plugged in or cracked during the removal process. A loose ground return strap? Pull the codes and it will likely tell you about misfires and what cylinder. Then inspect the coils.
Appreciate 0
Reply

Bookmarks

Tags
e90 06 330i, idle problems, pcv valve, stalling, vacuum leak

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:41 PM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST