E90Post
 


Extreme Powerhouse
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > BMW Coding > DIY: Setup BMW Standard Tools 2.12 on Windows XP > 10



Reply
 
Thread Tools Search this Thread
      01-07-2016, 07:11 AM   #45
cryptomit
Captain
80
Rep
701
Posts

Drives: 320d 2012
Join Date: Dec 2013
Location: AS

iTrader: (0)

Quote:
Originally Posted by Banana Clipper View Post
No luck with the TCU flash my dude. I press 'Program' and get this:



Any advise or you think its the cable? I even tried loading the 53.0 files as per the instructions in the Aplina DiY thread and get the same thing. Just wasnt meant for me...lol
Your cable will not work with your car. It's 2009?
__________________
Click "Appreciate" if I helped you.
Appreciate 1
      01-07-2016, 09:03 AM   #46
Banana Clipper
Jewel Runner
Banana Clipper's Avatar
United_States
185
Rep
720
Posts

Drives: '09 335i
Join Date: Dec 2015
Location: Bay Area

iTrader: (2)

Quote:
Originally Posted by cryptomit View Post
Your cable will not work with your car. It's 2009?
Yes 01/09, so which cable do I need?
Appreciate 0
      01-07-2016, 12:31 PM   #47
secrethero
New Member
Canada
11
Rep
22
Posts

Drives: 2008 335XI
Join Date: Sep 2015
Location: Canada

iTrader: (0)

Quote:
Originally Posted by wildcatcrazy View Post
Appears to be a legit/working cable. Good luck.
Can you please forward me a link/ ebay store so that i can purchase that cable.
I got a cable from a different guy and I cant seem to get it communicate it with INPA or INSTA.
Your install instructions were simple and had no problem with installing it.

My guess is cable is bad. Seller claims that he tested and verified it with his Win7 64 before shipping it.
I tried on two different systems (VM windows 8 64 bit and Laptop Windows 7 64 bit) but no luck.
K+DCAN Utility also cant communicate. Tried different COM ports and settings.
Placed obd.ini everywhere (C:\ and C:\Windows C:\EDIABAS\Bin)

[OBD]
Port=Com1
Hardware=USB
RETRY=ON
...

Nada...
Appreciate 0
      01-07-2016, 04:56 PM   #48
evo97
Private First Class
evo97's Avatar
4
Rep
138
Posts

Drives: 335d
Join Date: May 2011
Location: Bucks

iTrader: (2)

Trying to modify the VO in NCS Expert but there seems to be no option for FA read or write from the Choose job pop-up window?

Must of done something wrong my end...working fine and did some coding today!!

Thank again for your effort putting this together

Nathan

Last edited by evo97; 01-09-2016 at 09:14 AM..
Appreciate 0
      01-07-2016, 07:10 PM   #49
wildcatcrazy
Banned
wildcatcrazy's Avatar
United_States
454
Rep
1,529
Posts

Drives: E90 335i
Join Date: Oct 2013
Location: USA

iTrader: (12)

Garage List
2009 335i  [0.00]
Quote:
Originally Posted by secrethero View Post
Can you please forward me a link/ ebay store so that i can purchase that cable.
I got a cable from a different guy and I cant seem to get it communicate it with INPA or INSTA.
Your install instructions were simple and had no problem with installing it.

My guess is cable is bad. Seller claims that he tested and verified it with his Win7 64 before shipping it.
I tried on two different systems (VM windows 8 64 bit and Laptop Windows 7 64 bit) but no luck.
K+DCAN Utility also cant communicate. Tried different COM ports and settings.
Placed obd.ini everywhere (C:\ and C:\Windows C:\EDIABAS\Bin)

[OBD]
Port=Com1
Hardware=USB
RETRY=ON
...

Nada...
b i m m e r s o f t w a r e . com
Appreciate 1
      01-07-2016, 07:13 PM   #50
wildcatcrazy
Banned
wildcatcrazy's Avatar
United_States
454
Rep
1,529
Posts

Drives: E90 335i
Join Date: Oct 2013
Location: USA

iTrader: (12)

Garage List
2009 335i  [0.00]
Quote:
Originally Posted by Banana Clipper View Post
Any advise or you think its the cable? I even tried loading the 53.0 files as per the instructions in the Aplina DiY thread and get the same thing. Just wasnt meant for me...lol
Did you change JB4 to map 0? Try and see if you can read/code a module using NCS.
Appreciate 1
      01-07-2016, 10:00 PM   #51
Banana Clipper
Jewel Runner
Banana Clipper's Avatar
United_States
185
Rep
720
Posts

Drives: '09 335i
Join Date: Dec 2015
Location: Bay Area

iTrader: (2)

Quote:
Originally Posted by wildcatcrazy View Post
Did you change JB4 to map 0? Try and see if you can read/code a module using NCS.
Changed to map 0 did not try NCS expert. I already bought another cable that 'guarantees' it will work on 98-13 BMW's so I'll wait for that to proceed because the cable I have doesnt even show the correct status when I load INPA. Depending on which version of INPA I load, yours or someone elses, it either shows both battery and ignition off or on respectively and I know your software pack is good whereas the others are questionable, due to date, at best.

Appreciate the follow up, I'll come back in a few days when I get the new 'guaranteed' cable and let you know how it went.
Appreciate 0
      01-08-2016, 03:13 PM   #52
Shinzi
Lieutenant
8
Rep
459
Posts

Drives: 335XI
Join Date: Jul 2012
Location: Georgia

iTrader: (1)

i am having a hard time downloading this. It keeps getting stuck at 99%
__________________

08' Atlantic Blue Metallic 335XI
SC7 19's / KW V1 / JB4 / BMS DCI / Wrapped!
Appreciate 0
      01-08-2016, 03:25 PM   #53
Banana Clipper
Jewel Runner
Banana Clipper's Avatar
United_States
185
Rep
720
Posts

Drives: '09 335i
Join Date: Dec 2015
Location: Bay Area

iTrader: (2)

Quote:
Originally Posted by Shinzi View Post
i am having a hard time downloading this. It keeps getting stuck at 99%
If the OP doesnt mind and its not illegal I can host a mirror in my Google Drive, just the core software not the Daten files. It would offer a much faster download speed but out of respect I'd only do this with the OP's blessing since he put all the work into this package.
Appreciate 0
      01-08-2016, 03:38 PM   #54
Banana Clipper
Jewel Runner
Banana Clipper's Avatar
United_States
185
Rep
720
Posts

Drives: '09 335i
Join Date: Dec 2015
Location: Bay Area

iTrader: (2)

Quote:
Originally Posted by wildcatcrazy View Post
Did you change JB4 to map 0? Try and see if you can read/code a module using NCS.
Ok, just for shits and giggles I tried the original cable I have again using NCS Expert and I get

===================
Error

Production Series Faulty
===================
Appreciate 0
      01-08-2016, 03:45 PM   #55
mrvedit
Private First Class
18
Rep
102
Posts

Drives: 2013 M3
Join Date: May 2013
Location: Ann Arbor, MI

iTrader: (1)

Quote:
Originally Posted by wildcatcrazy View Post
b i m m e r s o f t w a r e . com
Yes, that worked perfectly for me; two different ebay cables were flaky.
__________________
2017 M3 DTC * 2013 M3 Manual
2017 330i (Winter beater)
1981 Camaro Z28 - 427 LS3 - 10.94 @126mph
2006 Corvette (streetable track car)
1986 535i "24 Hours of Lemons" also streetable
Appreciate 0
      01-08-2016, 03:46 PM   #56
mrvedit
Private First Class
18
Rep
102
Posts

Drives: 2013 M3
Join Date: May 2013
Location: Ann Arbor, MI

iTrader: (1)

Quote:
Originally Posted by Shinzi View Post
i am having a hard time downloading this. It keeps getting stuck at 99%
Have you installed the "Mega" extension into Chrome or Firefox?
It helps perform the downloads, including the much larger 4GB "Daten" download.
__________________
2017 M3 DTC * 2013 M3 Manual
2017 330i (Winter beater)
1981 Camaro Z28 - 427 LS3 - 10.94 @126mph
2006 Corvette (streetable track car)
1986 535i "24 Hours of Lemons" also streetable
Appreciate 0
      01-08-2016, 03:56 PM   #57
Banana Clipper
Jewel Runner
Banana Clipper's Avatar
United_States
185
Rep
720
Posts

Drives: '09 335i
Join Date: Dec 2015
Location: Bay Area

iTrader: (2)

Quote:
Originally Posted by mrvedit View Post
Yes, that worked perfectly for me; two different ebay cables were flaky.

Awesome because thats the 'guaranteed' one I got. They do 1-3 day First Class delivery too which is better than some of the ones coming from China.

Gave my other cable to a friend with an E46, seems to work on his car.
Appreciate 0
      01-08-2016, 04:34 PM   #58
mrvedit
Private First Class
18
Rep
102
Posts

Drives: 2013 M3
Join Date: May 2013
Location: Ann Arbor, MI

iTrader: (1)

Quote:
Originally Posted by Banana Clipper View Post
Awesome because thats the 'guaranteed' one I got. They do 1-3 day First Class delivery too which is better than some of the ones coming from China.

Gave my other cable to a friend with an E46, seems to work on his car.
Just plug the cable into your Windows laptop and let it "auto connect". Then go to Device Manager, find the cable under "Ports", go to Update Driver and select "Search automatically for updated driver software". It will download and install the correct/latest FTDI drivers. This worked for me on both Windows 7 and XP.

Unlike the Chinese cables, this cable does not include any software.
Remember the INPA and NCSExpert software is "Bootleg" and the copyright clearly belongs to BMW. While BMW seems to tolerate these forums, it is clearly illegal to include their software on anything sold; hence only the cables from China, Romania, etc come with INPA/NCSExpert software (of unknown versions).

The cables all include some version of the FTDI chip. I suspect that either a bootleg version of the FTDI chips or a rejected batch of chips is being used in the cheap Chinese cables that tend to be flaky. On some cars, if you install the cable in the correct order, they work, on other cars rarely if at all.

Finally, some INPA/NCSExpert disk or download gave me a D-Can.exe program. This talks to the cable and sets its COM port number and communication speed:
1. You select the COM port "1", "2", "3" (etc)
2. Enter "1" to "Write" the value.
3. Enter "1" to select the highest speed.
If the program returns "OK" then I have found INPA to work 100% of the time.
If the program returns an error, INPA never works - it might detect the battery and ignition, but will not communicate with any modules.

Personally I run on "COM3", but you need to then find the usb.ini file and change the COM port number. And this file needs to be in the Windows environment "path".

Hopefully this helps as I struggled quite a bit to get this all to work and computers and electronics are my business and hobby.
__________________
2017 M3 DTC * 2013 M3 Manual
2017 330i (Winter beater)
1981 Camaro Z28 - 427 LS3 - 10.94 @126mph
2006 Corvette (streetable track car)
1986 535i "24 Hours of Lemons" also streetable

Last edited by mrvedit; 01-09-2016 at 02:33 PM.. Reason: Corrected name of program to D-Can.exe
Appreciate 0
      01-08-2016, 04:45 PM   #59
Banana Clipper
Jewel Runner
Banana Clipper's Avatar
United_States
185
Rep
720
Posts

Drives: '09 335i
Join Date: Dec 2015
Location: Bay Area

iTrader: (2)

Quote:
Originally Posted by mrvedit View Post
Just plug the cable into your Windows laptop and let it "auto connect". Then go to Device Manager, find the cable under "Ports", go to Update Driver and select "Search automatically for updated driver software". It will download and install the correct/latest FTDI drivers. This worked for me on both Windows 7 and XP.

Unlike the Chinese cables, this cable does not include any software.
Remember the INPA and NCSExpert software is "Bootleg" and the copyright clearly belongs to BMW. While BMW seems to tolerate these forums, it is clearly illegal to include their software on anything sold; hence only the cables from China, Romania, etc come with INPA/NCSExpert software (of unknown versions).

The cables all include some version of the FTDI chip. I suspect that either a bootleg version of the FTDI chips or a rejected batch of chips is being used in the cheap Chinese cables that tend to be flaky. On some cars, if you install the cable in the correct order, they work, on other cars rarely if at all.

Finally, some INPA/NCSExpert disk or download gave me a USB_Driver.exe program (I need to confirm the name). This talks to the cable and sets its COM port number and communication speed:
1. You select the COM port "1", "2", "3" (etc)
2. Enter "1" to "Write" the value.
3. Enter "1" to select the highest speed.
If the program returns "OK" then I have found INPA to work 100% of the time.
If the program returns an error, INPA never works - it might detect the battery and ignition, but will not communicate with any modules.

Personally I run on "COM3", but you need to then find the usb.ini file and change the COM port number. And this file needs to be in the Windows environment "path".

Hopefully this helps as I struggled quite a bit to get this all to work and computers and electronics are my business and hobby.

Appreciate it but the cable is already recognized by my PC and the settings match whats in the tutorial. Im 99.99% sure its the cable as the Amazon ad clearly states that it only works for 1998 to 2008 vehicles and I have a 09. Dont mean to come off sour, I do appreciate the input.

Last edited by Banana Clipper; 01-08-2016 at 07:50 PM..
Appreciate 0
      01-09-2016, 01:02 PM   #60
Esixty1
Enlisted Member
New Zealand
19
Rep
47
Posts

Drives: 2008 E91 335i M-Sport
Join Date: May 2014
Location: New Zealand

iTrader: (0)

Quote:
Originally Posted by Banana Clipper View Post
Appreciate it but the cable is already recognized by my PC and the settings match whats in the tutorial. Im 99.99% sure its the cable as the Amazon ad clearly states that it only works for 1998 to 2008 vehicles and I have a 09. Dont mean to come off sour, I do appreciate the input.
I had similar issues with a cable that worked fine on my 05 E61 but not on my August 08 build E91. The earlier car is kcan, the latter is dcan... Tried unsoldering the bridge between a couple of the pins as advised somewhere but still no joy. Ended up getting a different cable in the end and now have it working...of course that may just be because of wildcat's awesome guide...I should give that other cable another go.
Appreciate 0
      01-09-2016, 01:10 PM   #61
wildcatcrazy
Banned
wildcatcrazy's Avatar
United_States
454
Rep
1,529
Posts

Drives: E90 335i
Join Date: Oct 2013
Location: USA

iTrader: (12)

Garage List
2009 335i  [0.00]
Quote:
Originally Posted by Banana Clipper
Quote:
Originally Posted by Shinzi View Post
i am having a hard time downloading this. It keeps getting stuck at 99%
If the OP doesnt mind and its not illegal I can host a mirror in my Google Drive, just the core software not the Daten files. It would offer a much faster download speed but out of respect I'd only do this with the OP's blessing since he put all the work into this package.
I'd rather keep all of this in the same location so links aren't broken/dead.
Appreciate 1
      01-09-2016, 02:40 PM   #62
Dann
Major
Dann's Avatar
125
Rep
1,392
Posts

Drives: E90 LCi 335i
Join Date: Feb 2015
Location: Portsmouth, United Kingdom

iTrader: (0)

How does mega download files?
On chrome mine got 100% on the browser and then it did nothing else.

Does it download on the browser then download to your PC once that has reached 100%?
Appreciate 0
      01-09-2016, 03:15 PM   #63
wildcatcrazy
Banned
wildcatcrazy's Avatar
United_States
454
Rep
1,529
Posts

Drives: E90 335i
Join Date: Oct 2013
Location: USA

iTrader: (12)

Garage List
2009 335i  [0.00]
Quote:
Originally Posted by Dann
How does mega download files?
On chrome mine got 100% on the browser and then it did nothing else.

Does it download on the browser then download to your PC once that has reached 100%?
It will download 100% on the browser, then it will start the final download to your Downloads folder.
Appreciate 1
      01-09-2016, 05:13 PM   #64
Banana Clipper
Jewel Runner
Banana Clipper's Avatar
United_States
185
Rep
720
Posts

Drives: '09 335i
Join Date: Dec 2015
Location: Bay Area

iTrader: (2)

Quote:
Originally Posted by wildcatcrazy View Post
I'd rather keep all of this in the same location so links aren't broken/dead.

no worries man, I respect your work which is why I asked rather than just doing it
Appreciate 0
      01-09-2016, 06:37 PM   #65
PichaDis11
Colonel
PichaDis11's Avatar
United_States
214
Rep
2,019
Posts

Drives: E90 N52
Join Date: Mar 2013
Location: NY

iTrader: (3)

Quote:
Originally Posted by wildcatcrazy View Post
It will download 100% on the browser, then it will start the final download to your Downloads folder.
To add to this.. watch out if your browser auto-save off. It will come up with a prompt asking where to save the files.. I downloaded the thing about 3 times before I could figure it out..
__________________
...
Appreciate 0
      01-09-2016, 07:17 PM   #66
Banana Clipper
Jewel Runner
Banana Clipper's Avatar
United_States
185
Rep
720
Posts

Drives: '09 335i
Join Date: Dec 2015
Location: Bay Area

iTrader: (2)

Just wanted to come back and thank everyone for their help and input; mostly and especially wildcatcrazy for putting together a COMPLETE software pack. I've been trying this shit for over a week now and wildcat's pack is the ONLY pack that worked and provided clear instructions.

I also want to re-confirm that the cable I bought from bimmer software . com was the ONLY one of 3 cables that worked and for $40 they provide priority shipping which got to me in 2 days.

Again, BIG props to wildcatcrazy for putting this all together and providing his/her input. REALLY do appreciate it because I was about to give up and just pay someone else to do it.
Appreciate 1
Reply

Bookmarks

Tags
coding, inpa, ncs, tool32, winkfp

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 08:54 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST