E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N55 Turbo Engine Tuning and Exhaust Modifications - 335i Tuning > Valvetronic Pain



Reply
 
Thread Tools Search this Thread
      05-19-2022, 11:52 AM   #1
n0x1ous
Registered
0
Rep
1
Posts

Drives: 2011 BMW 335xi 6-spd
Join Date: May 2022
Location: USA

iTrader: (0)

Valvetronic Pain

Hey everyone,
longtime lurker, first time poster. I bought a 2011 335xi 6spd at the beginning of the year. it has 81k miles. All stock and had the clutch replaced at 50k and water pump replaced at 65k.
Everything worked when I purchased it. No codes or CEL's but soon after started getting CEL light when accelerating hard and car started going into limp mode.

2E0F Valvetronic System Deactivated - Adjustment Fault too Frequent. Car was idling rough with bouncing RPM but no clicking sound when unlocking doors. I brought the car to a local Indy who works on a lot of German stuff. They recommended replacing VVT motor but said the eccentric shaft looked good and shouldn't need replacing. I went ahead with the repair and did other maintenance items that I knew it should have at this mileage.

Additional things done at same time as VVT motor replacement include:
*Spark plugs and ignition coils
*Valve Cover + Gasket
*OFHG and Oil Pan Gasket and Oil Cooler Gasket replacement
*2 Engine Mounts
*Walnut Blast
*added Crank Seal
*2 new VANOS Solenoids

Got the car back and its idling better but still some shakes/quivers at times. Drives fine but still throws CEL under hard acceleration and returns codes
2E0F like before, but now also getting
2C56 - Charging pressure control: Plausibility pressure too high
2C58 - Charging pressure control: Deactivation Pressure bulid-up blocked.

Indy says only other thing it could be is Eccentric Shaft or DME and likely boost solenoid for the 2C56/58. Says Turbo looks good

these three codes have stuck now after several clears.

A few other codes it has shown sometimes but not others (and not currently) are

29D2 - Intake Air Temperature Sensor, Signal Change too Fast
29D0 - Intake Air Temperature Sensor, Electrical Short Circuit to Battery +
3220 - Data Mining Template Library, System Fault:Abort Due To Current Fluctuations During Reference Measurement
6EC4 - Steering Angle Sensor Adjustment
D115 - Fault CAN Telegram Timeout

Mostly concerned with the 2E0F and 2C56/58 as those appear to be whats causing CEL/Limp Mode. I welcome your advice
Appreciate 0
      05-19-2022, 08:11 PM   #2
jlegelis
Private First Class
jlegelis's Avatar
United_States
31
Rep
123
Posts

Drives: 2013 E92 N55 MT MSport
Join Date: Jan 2013
Location: Boston, MA

iTrader: (0)

https://www.e90post.com/forums/showthread.php?t=1536073 ?
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:36 PM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST