E90Post
 


Extreme Powerhouse
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > UK > UK Technical Forum > Power Steering Assist Faulty / Failure



Reply
 
Thread Tools Search this Thread
      02-04-2020, 06:45 AM   #1
aaronblack
Private First Class
23
Rep
101
Posts

Drives: 330i E92 N53 - MT
Join Date: Apr 2019
Location: London

iTrader: (0)

Power Steering Assist Faulty / Failure

As per title, driving to work this morning and the error kept switching from faulty to failure.

This has happened before about 2/3 months ago, came up once and disappeared and because of that it doesn't show up anything on INPA.

Anyone have a clue? Is it a steering rack change job or a bad connector?
Appreciate 0
      02-04-2020, 03:28 PM   #2
aaronblack
Private First Class
23
Rep
101
Posts

Drives: 330i E92 N53 - MT
Join Date: Apr 2019
Location: London

iTrader: (0)

So managed to quickly scan with INPA whilst EPS light was on and got the following:

D516
D507
D514

Can't find anything related to D507 or D514? Appears no one has had this before!

Can this be steering rack / pump despite it appearing once in the last 3 months, then fully disappearing until today?
Appreciate 0
      02-04-2020, 03:51 PM   #3
Finngo
New Member
3
Rep
15
Posts

Drives: E90
Join Date: Jan 2020
Location: bali

iTrader: (0)

Quote:
Originally Posted by aaronblack View Post
So managed to quickly scan with INPA whilst EPS light was on and got the following:

D516
D507
D514

Can't find anything related to D507 or D514? Appears no one has had this before!

Can this be steering rack / pump despite it appearing once in the last 3 months, then fully disappearing until today?
+1

Appreciate 0
      02-04-2020, 05:27 PM   #4
therealdb1
First Lieutenant
41
Rep
328
Posts

Drives: Graphite E93 335i
Join Date: Aug 2017
Location: Norfolk UK

iTrader: (0)

Surely if these codes came from INPA it should have given you a description even if it is in German.

2 minutes on a search engine suggests:

D507 - EPS controller unable to communicate with the rest of the component in PT-CAN system.

D514 - EPS is not receiving a speed signal from the DME.

D516 - EPS is receiving an error from CAS.

Sounds like there is a problem with the EPS controller connections so that is first port of call.

Not sure BMW list the EPS separately so it could be a new rack if all the connectors are pristine and making good contact.
Appreciate 1
      02-04-2020, 05:37 PM   #5
aaronblack
Private First Class
23
Rep
101
Posts

Drives: 330i E92 N53 - MT
Join Date: Apr 2019
Location: London

iTrader: (0)

Quote:
Originally Posted by therealdb1 View Post
Surely if these codes came from INPA it should have given you a description even if it is in German.

2 minutes on a search engine suggests:

D507 - EPS controller unable to communicate with the rest of the component in PT-CAN system.

D514 - EPS is not receiving a speed signal from the DME.

D516 - EPS is receiving an error from CAS.

Sounds like there is a problem with the EPS controller connections so that is first port of call.

Not sure BMW list the EPS separately so it could be a new rack if all the connectors are pristine and making good contact.
Not the greatest with INPA, didn't know it does that will have a scan and read the description!

Havn't seen much regarding EPS so hopefully it isn't a fault etc. I am missing the engine tray so maybe (hopefully) it's just water between connectors etc.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 05:21 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST