E90Post
 


The Tire Rack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Has anyone contacted BMW regarding 29.2 and lag?



Reply
 
Thread Tools Search this Thread
      02-17-2009, 07:52 PM   #3829
dinkoh
Captain
dinkoh's Avatar
United_States
17
Rep
877
Posts

Drives: 07 e90 lemon/black
Join Date: Feb 2007
Location: charm city --> bay area

iTrader: (4)

Quote:
Originally Posted by iScream View Post
Strange, then, how it is not present on pre-29.2 and some retrofits, but is present on others. I am wondering, if the wastegates open at any point above 1400 RPM, then how can it be the same as the original programming? I'd like to hear some more responses on the deceleration tick vs lag.

BTW, Bill, I've been cordial and assertive with the people I've dealt with, only coming close to the boiling point once with BMWNA customer service. The trouble is, even when they TRY to help you, they are not always enabled, and that is as frustrating as anything else. You'd think for a global corporation that relies so much on advanced technology to keep its customers safe, they'd be better at internally educating their employees on these things.

Does anyone know the best way to quantitatively compare the lag in two cars? I think I know someone who still has a pre-29.2 (and no tick) and would like to compare the retrofit with it.
Mine is updated with 2.32.1, and mine rattles at 3300 rpm on neutral decel. Not sure if I got the retrofit since there is no mention of it. I'm assuming I don't. My vehicle data status is E89x-08-03-530.
Appreciate 0
      02-17-2009, 08:38 PM   #3830
Quisp
Does not play well with others
United_States
65
Rep
1,787
Posts

Drives: BMW
Join Date: Apr 2007
Location: Arizona

iTrader: (4)

Meyer, great to hear that you are enjoying the car again!
Mine is at the dealership now getting the hood bend fixed, then it is over to the service dept for a few things(including the new update).
I hope it goes smoothly.
__________________
Appreciate 0
      02-17-2009, 09:28 PM   #3831
bmrm396
Lieutenant Colonel
United_States
517
Rep
1,642
Posts

Drives: 2016 F80 M3
Join Date: Sep 2008
Location: sD, CA

iTrader: (2)

Quote:
Originally Posted by dinkoh View Post
Mine is updated with 2.32.1, and mine rattles at 3300 rpm on neutral decel. Not sure if I got the retrofit since there is no mention of it. I'm assuming I don't. My vehicle data status is E89x-08-03-530.
so what ur saying is that we all NEED to get the conversion and not just the software??? otherwise well end up with the dreaded rattle???

my car is going in this weekend and im bringing the SIB so i need to tell the SA what i want.

thanx
__________________
Formerly addicted to e46fanatics
Formerly addicted to e90post
Appreciate 0
      02-17-2009, 09:36 PM   #3832
iScream
solid @ 153, no, 155mph!
iScream's Avatar
United_States
11
Rep
335
Posts

Drives: '07/'09/'13 335, '16 340ix
Join Date: May 2008
Location: Washington, DC

iTrader: (0)

Quote:
Originally Posted by dinkoh View Post
Mine is updated with 2.32.1, and mine rattles at 3300 rpm on neutral decel. Not sure if I got the retrofit since there is no mention of it. I'm assuming I don't. My vehicle data status is E89x-08-03-530.
If you did not specifically request lag-fix, then you got the [ironically named] rattle-fix. And, like me and at least a few other people here, you hear the wastegate opening at 3300 RPM.

I know you already believe me, but if you want to see for yourself that it's the wastegate, just open the hood and get a friend to rev the engine while you watch the outside wastegate actuator arm, and you will see it open at 3300 RPM. Or, set up a video camera trained on the turbo and do the revving yourself. If I had a tripod, then I'd do this and post it for everyone to see.

To rule out noisy wastegates as the differentiator here, I am wondering if someone who DOESN'T hear the noise could run the above experiment to visually confirm my theory. That would be, if I am not mistaken, anyone with *confirmed* 2.32.1 lag-fix and/or anyone who is pre-29.2.

Lastly, dinkoh, this almost slipped by me... are you sure about E89x-08-03-530 and 2.32.1? IIRC, 08-03-530 is the 29.2-30.x data status, which means that one of those numbers must be incorrect.
Appreciate 0
      02-18-2009, 09:50 AM   #3833
golf4501
Lieutenant
87
Rep
566
Posts

Drives: 2020 M2C
Join Date: Sep 2008
Location: chicagoland

iTrader: (0)

Garage List
2020 BMW M2C  [0.00]
Quote:
Originally Posted by eelton View Post
Was that by any chance Fields BMW?

Nope Bill Jacobs in Naperville. I did have it installed yesterday. I noticed a slight difference in low RPM's so far. It's not very ideal weather wise here though, so I really haven't exercised it yet.
Appreciate 0
      02-18-2009, 10:07 AM   #3834
Christos
Lieutenant
Christos's Avatar
29
Rep
524
Posts

Drives: 2014 428i Msport
Join Date: Jun 2008
Location: Central, NJ

iTrader: (0)

Quote:
Originally Posted by Christos View Post
I know how to access the hidden menus in iDrive, but once in there what submenu shows if you have received ISTA/P 2.32.2.0.1 software version?
I checked the Functional Software Verison under the Applikations menu:

It reads: 008.106.001....does this mean anythign to anybody?
__________________
2014 428i Msport Delivered
Previously owned 2011 Audi S4, 2008 335i Coupe, 2007 328xi sedan, 2005 G35, 2002 325i sedan, 2000 Audi A4, 1998 Audi A4, 1996 318ti (loved this little car)
Appreciate 0
      02-18-2009, 10:46 AM   #3835
dinkoh
Captain
dinkoh's Avatar
United_States
17
Rep
877
Posts

Drives: 07 e90 lemon/black
Join Date: Feb 2007
Location: charm city --> bay area

iTrader: (4)

Quote:
Originally Posted by iScream View Post
If you did not specifically request lag-fix, then you got the [ironically named] rattle-fix. And, like me and at least a few other people here, you hear the wastegate opening at 3300 RPM.

I know you already believe me, but if you want to see for yourself that it's the wastegate, just open the hood and get a friend to rev the engine while you watch the outside wastegate actuator arm, and you will see it open at 3300 RPM. Or, set up a video camera trained on the turbo and do the revving yourself. If I had a tripod, then I'd do this and post it for everyone to see.

To rule out noisy wastegates as the differentiator here, I am wondering if someone who DOESN'T hear the noise could run the above experiment to visually confirm my theory. That would be, if I am not mistaken, anyone with *confirmed* 2.32.1 lag-fix and/or anyone who is pre-29.2.

Lastly, dinkoh, this almost slipped by me... are you sure about E89x-08-03-530 and 2.32.1? IIRC, 08-03-530 is the 29.2-30.x data status, which means that one of those numbers must be incorrect.
I specifically requested the lag-fix. I did not mention any "turbo or wastegate retrofit". They did mention that my engine would be louder, not sure if it included more wastegate rattle or not.
Appreciate 0
      02-18-2009, 11:41 AM   #3836
iScream
solid @ 153, no, 155mph!
iScream's Avatar
United_States
11
Rep
335
Posts

Drives: '07/'09/'13 335, '16 340ix
Join Date: May 2008
Location: Washington, DC

iTrader: (0)

Quote:
Originally Posted by dinkoh View Post
I specifically requested the lag-fix. I did not mention any "turbo or wastegate retrofit". They did mention that my engine would be louder, not sure if it included more wastegate rattle or not.
So are you sure your current version is E89x-08-03-530, or is that your previous/original version? Because if that's your current status, then you do not have 32.1 at all.

Also, I requested "lagfix" and even mentioned "turbo retrofit" and "wastegate" and all that jazz two, three, four times before my initial update, and was reassured they knew what I was talking about. And I was working with arguably the two most knowledgeable dealerships in the state. Yet they still missed the wastegate conversion the first time (and possibly the second time as well, which I'm trying to figure out) because it is not something the tech is prompted for.

The bulletin I posted a few pages back was updated in early Feb to be much more clear about the process, but if the tech does not read the whole thing, they can still miss it.
Appreciate 0
      02-18-2009, 12:20 PM   #3837
Tschuss
Private
3
Rep
92
Posts

Drives: 2007 BMW 335i Coupe
Join Date: Sep 2008
Location: Out West

iTrader: (0)

Quote:
Originally Posted by iScream View Post
So are you sure your current version is E89x-08-03-530, or is that your previous/original version? Because if that's your current status, then you do not have 32.1 at all.

Also, I requested "lagfix" and even mentioned "turbo retrofit" and "wastegate" and all that jazz two, three, four times before my initial update, and was reassured they knew what I was talking about. And I was working with arguably the two most knowledgeable dealerships in the state. Yet they still missed the wastegate conversion the first time (and possibly the second time as well, which I'm trying to figure out) because it is not something the tech is prompted for.

The bulletin I posted a few pages back was updated in early Feb to be much more clear about the process, but if the tech does not read the whole thing, they can still miss it.
iScream - with a manual trans it's easy to tell if you have the lag free update. Nothing subtle about it. Do the test where you're in second gear going 2,000 rpm - floor it. If you get linear power - you're set. If you get a huge boost of power toward 2800-3000, you're laggin'.
-B
Appreciate 0
      02-18-2009, 12:28 PM   #3838
Christos
Lieutenant
Christos's Avatar
29
Rep
524
Posts

Drives: 2014 428i Msport
Join Date: Jun 2008
Location: Central, NJ

iTrader: (0)

Quote:
Originally Posted by Tschuss View Post
iScream - with a manual trans it's easy to tell if you have the lag free update. Nothing subtle about it. Do the test where you're in second gear going 2,000 rpm - floor it. If you get linear power - you're set. If you get a huge boost of power toward 2800-3000, you're laggin'.
-B
I was able to replicate the lag in this manner on my automatic as well. I will try this method again tonight on my way home from work.
__________________
2014 428i Msport Delivered
Previously owned 2011 Audi S4, 2008 335i Coupe, 2007 328xi sedan, 2005 G35, 2002 325i sedan, 2000 Audi A4, 1998 Audi A4, 1996 318ti (loved this little car)
Appreciate 0
      02-18-2009, 12:42 PM   #3839
Kruz
Major
Kruz's Avatar
18
Rep
1,077
Posts

Drives: 335xi
Join Date: Jun 2007
Location: Chicagoland

iTrader: (4)

Garage List
Quote:
Originally Posted by golf4501 View Post
Nope Bill Jacobs in Naperville. I did have it installed yesterday. I noticed a slight difference in low RPM's so far. It's not very ideal weather wise here though, so I really haven't exercised it yet.
This is the same dealer I questioned about a month ago on this same issue...sounds like they are still behind the curve.
__________________
07/07 E90 335xi SG
Black Dakota|Alum|ZSP|2AB|ZPP|ZCW|Nav|CA|6FL|PDC|Blackli nes|3M
Summers: 235/40/18 265/35/18 Hankook Ventus V12 on VMR 701s
A/S: 225/40/18 255/35/18 Pirelli PZero Nero M+S on OEM 162s
Appreciate 0
      02-18-2009, 01:08 PM   #3840
borisivan
craptastic
borisivan's Avatar
15
Rep
281
Posts

Drives: 2010 335xi
Join Date: Jul 2007
Location: hell in a handbasket

iTrader: (0)

Quote:
Originally Posted by Tschuss View Post
iScream - with a manual trans it's easy to tell if you have the lag free update. Nothing subtle about it. Do the test where you're in second gear going 2,000 rpm - floor it. If you get linear power - you're set. If you get a huge boost of power toward 2800-3000, you're laggin'.
-B
iScream, I will try your test tonight.

Tschuss --- regarding the quote above, are you saying that the behavior you describe above is for 29.2 (i.e. major lag), or for 2.32.1 without the wastegate retrofit (i.e. better than 29.2, but still with lag)?
Appreciate 0
      02-18-2009, 02:04 PM   #3841
golf4501
Lieutenant
87
Rep
566
Posts

Drives: 2020 M2C
Join Date: Sep 2008
Location: chicagoland

iTrader: (0)

Garage List
2020 BMW M2C  [0.00]
Quote:
Originally Posted by Kruz View Post
This is the same dealer I questioned about a month ago on this same issue...sounds like they are still behind the curve.

Well after me pounding on them they should be well aware of it now. I came in there armed with the Technical service bulletin. I think they were just trying to make sure they got paid for reprogramming the car.
Appreciate 0
      02-18-2009, 02:09 PM   #3842
Tschuss
Private
3
Rep
92
Posts

Drives: 2007 BMW 335i Coupe
Join Date: Sep 2008
Location: Out West

iTrader: (0)

Quote:
Originally Posted by borisivan View Post
............Tschuss --- regarding the quote above, are you saying that the behavior you describe above is for 29.2 (i.e. major lag), or for 2.32.1 without the wastegate retrofit (i.e. better than 29.2, but still with lag)?
Which behavior? Huh? I have never experienced "2.32.1 without the wastegate retrofit". However, based on what I read on these pages, I conclude for MSD80:

Laggy is progman 29.2 or greater; or ISTA/P 2.32.x without lag fix option applied.
No Lag is progman 29.1 or less; or ISTA/P 2.32.x with lag fix option applied.

I did not notice any difference between pre-29.2 vs. ISTA/P 2.32.1 with lag-fix applied.

-B
Appreciate 0
      02-18-2009, 02:21 PM   #3843
citrixscu
First Lieutenant
citrixscu's Avatar
United_States
3
Rep
363
Posts

Drives: '14 335i EB II
Join Date: Nov 2008
Location: Los Gatos, CA

iTrader: (0)

Quote:
Originally Posted by iScream View Post
To rule out noisy wastegates as the differentiator here, I am wondering if someone who DOESN'T hear the noise could run the above experiment to visually confirm my theory. That would be, if I am not mistaken, anyone with *confirmed* 2.32.1 lag-fix and/or anyone who is pre-29.2.
@iScream:

This may not be the case. I have confirmed 2.32.1 lag-fix ("WAISTGATE [sic] VALVE" RETROFIT) on my paperwork, and I have that noise at 3250 RPM.
Appreciate 0
      02-18-2009, 02:23 PM   #3844
citrixscu
First Lieutenant
citrixscu's Avatar
United_States
3
Rep
363
Posts

Drives: '14 335i EB II
Join Date: Nov 2008
Location: Los Gatos, CA

iTrader: (0)

Quote:
Originally Posted by Tschuss View Post
Laggy is progman 29.2 or greater; or ISTA/P 2.32.x without lag fix option applied.
No Lag is progman 29.1 or less; or ISTA/P 2.32.x with lag fix option applied.

I did not notice any difference between pre-29.2 vs. ISTA/P 2.32.1 with lag-fix applied.

-B
MSD80 + ISTA/P 2.32.1 + lag-fix applied = rattly motor but *much* better performance. (In my case, anyway)
Appreciate 0
      02-18-2009, 02:29 PM   #3845
borisivan
craptastic
borisivan's Avatar
15
Rep
281
Posts

Drives: 2010 335xi
Join Date: Jul 2007
Location: hell in a handbasket

iTrader: (0)

Quote:
Originally Posted by Tschuss View Post
Which behavior? Huh? I have never experienced "2.32.1 without the wastegate retrofit". However, based on what I read on these pages, I conclude for MSD80:

Laggy is progman 29.2 or greater; or ISTA/P 2.32.x without lag fix option applied.
No Lag is progman 29.1 or less; or ISTA/P 2.32.x with lag fix option applied.

I did not notice any difference between pre-29.2 vs. ISTA/P 2.32.1 with lag-fix applied.

-B
Hi,

The 'wastegate retrofit' is the option via the new ISTA/P programming, that you call "lag fix" --- there is nothing that says: "lag fix" on the machine the tech uses, that's just what we're calling it. Tomato, ToMAto, I think we're saying the same thing there.

From what I've been reading, there was a difference noticed by some people between the following 3 scenarios

A) 29.2 (lag)

B) 2.32.1 withOUT the "lag fix option" (i.e. the wastegate retrofit conversion)

C) 2.32.1 with the "lag fix option" (i.e. the wastegate retrofit conversion)

In other words, I was under the assumption that "B" is BETTER than "A" (i.e. some lag, but less lag than "A"), even though it's still not as good as "C".

And so my question to you regarding the "2nd gear 2k rpms floor it test", was whether or not the whoosh at 2.8k rpm was 29.2 behavior, or 2.32.1 w/out the "lag fix" behavior.
Appreciate 0
      02-18-2009, 02:55 PM   #3846
Tschuss
Private
3
Rep
92
Posts

Drives: 2007 BMW 335i Coupe
Join Date: Sep 2008
Location: Out West

iTrader: (0)

Quote:
Originally Posted by borisivan View Post
Hi,

The 'wastegate retrofit' is the option via the new ISTA/P programming, that you call "lag fix" --- there is nothing that says: "lag fix" on the machine the tech uses, that's just what we're calling it. Tomato, ToMAto, I think we're saying the same thing there.

From what I've been reading, there was a difference noticed by some people between the following 3 scenarios

A) 29.2 (lag)

B) 2.32.1 withOUT the "lag fix option" (i.e. the wastegate retrofit conversion)

C) 2.32.1 with the "lag fix option" (i.e. the wastegate retrofit conversion)

In other words, I was under the assumption that "B" is BETTER than "A" (i.e. some lag, but less lag than "A"), even though it's still not as good as "C".

And so my question to you regarding the "2nd gear 2k rpms floor it test", was whether or not the whoosh at 2.8k rpm was 29.2 behavior, or 2.32.1 w/out the "lag fix" behavior.
I think the option on the machine is something like "control valve-wastegate" option.

I have not experienced B. From some of the descriptions I've heard, B is no better than A.

To answer your question the "2800 rpm whoosh" was (in my case) 29.2 behavior.

There is nothing subtle about the fix. If you're not sure that you got the lag fixed, you probably don't have it fixed. My wife who rarely drives my car had no problem noticing the difference.

-B
Appreciate 0
      02-18-2009, 02:58 PM   #3847
iatacs19
Major General
iatacs19's Avatar
United_States
323
Rep
5,333
Posts

Drives: 2016 SO M4
Join Date: Sep 2006
Location: Washington, DC

iTrader: (8)

Quote:
Originally Posted by borisivan View Post
Hi,

The 'wastegate retrofit' is the option via the new ISTA/P programming, that you call "lag fix" --- there is nothing that says: "lag fix" on the machine the tech uses, that's just what we're calling it. Tomato, ToMAto, I think we're saying the same thing there.

From what I've been reading, there was a difference noticed by some people between the following 3 scenarios

A) 29.2 (lag)

B) 2.32.1 withOUT the "lag fix option" (i.e. the wastegate retrofit conversion)

C) 2.32.1 with the "lag fix option" (i.e. the wastegate retrofit conversion)

In other words, I was under the assumption that "B" is BETTER than "A" (i.e. some lag, but less lag than "A"), even though it's still not as good as "C".

And so my question to you regarding the "2nd gear 2k rpms floor it test", was whether or not the whoosh at 2.8k rpm was 29.2 behavior, or 2.32.1 w/out the "lag fix" behavior.
So ultimately we want to get option C?

2.32.1 with the "wastegate retrofit" option

I have to go in next month for 30k check and will ask for this. I have a 03/2007 build and had my fuel pump replaced twice, not sure which version of software I am running anymore...
__________________
Appreciate 0
      02-18-2009, 03:13 PM   #3848
borisivan
craptastic
borisivan's Avatar
15
Rep
281
Posts

Drives: 2010 335xi
Join Date: Jul 2007
Location: hell in a handbasket

iTrader: (0)

Quote:
Originally Posted by Tschuss View Post
I think the option on the machine is something like "control valve-wastegate" option.

I have not experienced B. From some of the descriptions I've heard, B is no better than A.

To answer your question the "2800 rpm whoosh" was (in my case) 29.2 behavior.

There is nothing subtle about the fix. If you're not sure that you got the lag fixed, you probably don't have it fixed. My wife who rarely drives my car had no problem noticing the difference.

-B
Cool, thanks for the info.
Appreciate 0
      02-18-2009, 03:31 PM   #3849
iScream
solid @ 153, no, 155mph!
iScream's Avatar
United_States
11
Rep
335
Posts

Drives: '07/'09/'13 335, '16 340ix
Join Date: May 2008
Location: Washington, DC

iTrader: (0)

I'm pretty tuned into the feel of the Lag... In the past 9 months, I've had

A) pre-29.2
B) 29.2
C) 29.2 with new wastegates and new turbos
D) 2.32.1 with no lagfix
E) 2.32.1 (supposedly) with lagfix

I drove option A for by far the most miles, and it was the best, and that is all I am trying to get out of my car. It had no strange wastegate noises, no tick at 3300 RPM, and the original (<200ms) "lag" at all revs higher than 1.4k. Options D and E are indiscernible from one another, but noticeably better than B or C. Some have said D is 90% better than C, but I'd say it's more like 50% better, or only halfway back to A.

Right now I am trying to figure out if this abnormal wastegate behavior is a sign that the lagfix was not applied properly, as I can't tell the difference between D and E, yet some people apparently notice a big difference.
Appreciate 0
      02-18-2009, 03:33 PM   #3850
citrixscu
First Lieutenant
citrixscu's Avatar
United_States
3
Rep
363
Posts

Drives: '14 335i EB II
Join Date: Nov 2008
Location: Los Gatos, CA

iTrader: (0)

Quote:
Originally Posted by iScream View Post
I'm pretty tuned into the feel of the Lag... In the past 9 months, I've had

A) pre-29.2
B) 29.2
C) 29.2 with new wastegates and new turbos
D) 2.32.1 with no lagfix
E) 2.32.1 (supposedly) with lagfix

...

Right now I am trying to figure out if this abnormal wastegate behavior is a sign that the lagfix was not applied properly, as I can't tell the difference between D and E, yet some people apparently notice a big difference.
Interesting you do not feel any difference between D and E. Let us know what you come up with.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:22 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST