E90Post
 


Extreme Powerhouse
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Has anyone contacted BMW regarding 29.2 and lag?



Reply
 
Thread Tools Search this Thread
      01-16-2017, 09:07 PM   #4929
mxchris727
Captain
mxchris727's Avatar
United_States
160
Rep
641
Posts

Drives: '07 E93 335i/6 & '03 E39 M5
Join Date: Aug 2012
Location: Westport, CT

iTrader: (0)

Quote:
Originally Posted by 808AWD325xi View Post
You can use WinKFP expert mode to downgrade your DME to whichever software revision you wish.
I would highly suggest against actually downgrading. Updating the DME to the latest version and then performing the wastegate conversion in ISTA /P is the proper and effective way to solve the issue.
__________________

BMW GT1 (INPA, DIS, WinKFP, ect..), ISTA/P & /D is up and running! PM me if you want to stop by and code your car.
Appreciate 1
OlliD28.50

      03-27-2017, 04:44 AM   #4930
OlliD
Private
OlliD's Avatar
Germany
29
Rep
91
Posts

Drives: E92 335i
Join Date: Oct 2016
Location: Germany

iTrader: (0)

Quote:
Originally Posted by mxchris727 View Post
I would highly suggest against actually downgrading. Updating the DME to the latest version and then performing the wastegate conversion in ISTA /P is the proper and effective way to solve the issue.
I would second this.

In my case got horrid wastegate rattle (because they are worn bad which was masked by the old software).
Re-adjusting the rear rod got rid of most of it (not completely) but the car feels so much better without lag. Drove like 3 yers with lag without knowing it, now car performs soooo much better.
Just use ISTA /P with retrofit option, since adding the d-(or K-?) word via WinKFP doesn´t do the trick (missing the proper DME maps I think)
Appreciate 0
      04-07-2017, 07:00 PM   #4931
mxchris727
Captain
mxchris727's Avatar
United_States
160
Rep
641
Posts

Drives: '07 E93 335i/6 & '03 E39 M5
Join Date: Aug 2012
Location: Westport, CT

iTrader: (0)

Quote:
Originally Posted by OlliD View Post
Just use ISTA /P with retrofit option, since adding the d-(or K-?) word via WinKFP doesn´t do the trick (missing the proper DME maps I think)
Correct, adding just the VO code won't change anything; it needs to be flashed in.
__________________

BMW GT1 (INPA, DIS, WinKFP, ect..), ISTA/P & /D is up and running! PM me if you want to stop by and code your car.
Appreciate 0
      12-17-2017, 12:45 PM   #4932
krteam
Registered
3
Rep
2
Posts

Drives: 335i E90
Join Date: Dec 2017
Location: Poland

iTrader: (0)

Hi Guys,

I'm struggling the same issue...
I've chnaged my wastegates and it was okay for some time.
But I don't know why... One day I said okay maybe let's go and update my ecu... After this I have ruttling back... Is it possible that someone will share with me Sp-daten v29.0, that I could downgrade it?

I don't have ISTA so probably I cannot convers back the vacuum settings?
Appreciate 0
      12-18-2017, 11:44 AM   #4933
krteam
Registered
3
Rep
2
Posts

Drives: 335i E90
Join Date: Dec 2017
Location: Poland

iTrader: (0)

Hi All,

I managed to change a logic back using WinKFP - closed wastegate when deceleration etc.
If you want to do so, you can use the ZUSB number
-USA cars ZUSB 7626168 MSD80
-EU cars ZUSB 7628326 MSD80
You will find those ZUSBs in Spdatens >= v50
Appreciate 2
Dackelone9587.00
OlliD28.50

      01-31-2018, 10:30 PM   #4934
BN244
Banned
2
Rep
31
Posts

Drives: f30
Join Date: Oct 2017
Location: USA

iTrader: (0)

Anyone know what wastegates cost by chance?
Appreciate 0
      01-31-2018, 10:41 PM   #4935
BN244
Banned
2
Rep
31
Posts

Drives: f30
Join Date: Oct 2017
Location: USA

iTrader: (0)

Just curious
Appreciate 0
      01-31-2018, 10:52 PM   #4936
BN244
Banned
2
Rep
31
Posts

Drives: f30
Join Date: Oct 2017
Location: USA

iTrader: (0)

I'll appreciate answers from anyone
Appreciate 0
      02-12-2018, 08:12 PM   #4937
IK6SPEED
Banned
United_States
4278
Rep
10,520
Posts

Drives: BMW M3 / AH3
Join Date: Jan 2013
Location: Cali

iTrader: (23)

Quote:
Originally Posted by BN244 View Post
Anyone know what wastegates cost by chance?
Well, free if you use your method

http://f30.bimmerpost.com/forums/sho....php?t=1465863
Appreciate 0
      09-16-2020, 09:06 AM   #4938
snaeem155
Private
0
Rep
68
Posts

Drives: 335i
Join Date: Jul 2018
Location: London

iTrader: (0)

Can someone point me to a TSB regarding this issue or how to sort it via ISTA/P?

Got huge lag and a loud exhaust. BMW deny all knowledge of any issue existing.
Appreciate 0
      09-16-2020, 10:25 AM   #4939
meyergru
No military grade
meyergru's Avatar
Germany
39
Rep
602
Posts

Drives: E92 M3 DCT
Join Date: Aug 2007
Location: Munich, Germany

iTrader: (0)

Quote:
Originally Posted by snaeem155 View Post
Can someone point me to a TSB regarding this issue or how to sort it via ISTA/P?

Got huge lag and a loud exhaust. BMW deny all knowledge of any issue existing.
I don't know about the loud exhaust, but as for wastegate rattle, I had set up a page for this back in 2011.

As you can see, BMW has changed SIB111307 in order to cover up the problem. I do not know what the software and/or hardware fixes do now - nine years later. Matter-of-fact the cars should be out of warranty now, so I guess it is all your problem anyway.
__________________
Appreciate 0
      09-16-2020, 10:43 AM   #4940
snaeem155
Private
0
Rep
68
Posts

Drives: 335i
Join Date: Jul 2018
Location: London

iTrader: (0)

Quote:
Originally Posted by meyergru View Post
I don't know about the loud exhaust, but as for wastegate rattle, I had set up a page for this back in 2011.

As you can see, BMW has changed SIB111307 in order to cover up the problem. I do not know what the software and/or hardware fixes do now - nine years later. Matter-of-fact the cars should be out of warranty now, so I guess it is all your problem anyway.
I've got a comprehensive warranty with BMW which covers pretty much everything.

They aren't playing ball and are denying knowledge of any issue (granted its an old issue).
Appreciate 0
      09-16-2020, 11:12 AM   #4941
Maestro
Major
693
Rep
1,230
Posts

Drives: 2007 335i Sedan
Join Date: Nov 2006
Location: Philadelphia

iTrader: (0)

Quote:
Originally Posted by snaeem155 View Post
I've got a comprehensive warranty with BMW which covers pretty much everything.

They aren't playing ball and are denying knowledge of any issue (granted its an old issue).
This specific lag was due to a software update BMW did, my car was affected at the time, two or three updates later this problem went away, but in between it caused other issues such as the waste gate rattle. My 07 has the latest software which was done probably 10 yrs ago and the car has been fine ever since.

You will need to know which software you car is running and I doubt it has the software which was affect since any maintenance done on the car since the issue showed up would have caused the dealer to update the software. My car was fine then they did this update as standard course of warranty and maintenance work and I immediately had the issue and was piss they update the software without my permission. I also doubt if you have full warranty car, this problem predates your car.

I personally do not remember BMW ever acknowledging this was an issue, they just made a number of software updates to address various issues. Your car could have a lag issue for a number of reason now of which related to the software, Like all of us who dealt with this issue you just need to get the tech working on the car take it for drive and see what is happening.
Appreciate 0
      09-16-2020, 11:23 AM   #4942
snaeem155
Private
0
Rep
68
Posts

Drives: 335i
Join Date: Jul 2018
Location: London

iTrader: (0)

Quote:
Originally Posted by Maestro View Post
This specific lag was due to a software update BMW did, my car was affected at the time, two or three updates later this problem went away, but in between it caused other issues such as the waste gate rattle. My 07 has the latest software which was done probably 10 yrs ago and the car has been fine ever since.

You will need to know which software you car is running and I doubt it has the software which was affect since any maintenance done on the car since the issue showed up would have caused the dealer to update the software. My car was fine then they did this update as standard course of warranty and maintenance work and I immediately had the issue and was piss they update the software without my permission. I also doubt if you have full warranty car, this problem predates your car.

I personally do not remember BMW ever acknowledging this was an issue, they just made a number of software updates to address various issues. Your car could have a lag issue for a number of reason now of which related to the software, Like all of us who dealt with this issue you just need to get the tech working on the car take it for drive and see what is happening.
I've taken it multiple times to BMW who claim nothing is wrong.

I have wastegate rattle on startup, lag up until 3k where the car then takes off, lower fuel economy and a loud exhaust (almost sounds aftermarket).

Going through the thread its pretty much the same symptoms everyone else had.
Appreciate 0
      09-16-2020, 12:02 PM   #4943
meyergru
No military grade
meyergru's Avatar
Germany
39
Rep
602
Posts

Drives: E92 M3 DCT
Join Date: Aug 2007
Location: Munich, Germany

iTrader: (0)

Quote:
Originally Posted by Maestro View Post
This specific lag was due to a software update BMW did, my car was affected at the time, two or three updates later this problem went away, but in between it caused other issues such as the waste gate rattle. My 07 has the latest software which was done probably 10 yrs ago and the car has been fine ever since.
If you read my page about it closely, you will find that this a kind of simplification. What was really happening is:

1. BMW had a hardware problem with the wastegate rods elongating over time because they were too thin. This in turn caused a rattling noise at idle because the wastegates did not close fully with elongated rods.

2. BMW fixed a few cars by exchanging the hardware and found out about that issue. They figured it would be too costly to fix this in old already-build N54 cars and took two measures: a. for newer production cars, the rods were replaced by stronger parts (you can see that there is another part number for newer production cars). b. for older cars, they would open the wastegates in idle, thus eliminating the rattle, but with the side effect of turbo lag when having to close them at acceleration. You can see that there are different versions of the software for older and newer cars - actually, there are cars that do not even have the correct combination of hardware and software as the parts were switched out softly - mine was one of those, as it had the newer rods, but was not guaranteed by its production date to have them, so it got the laggy software). They documented that in the inital version of SIB111307 (until April 2009), you can find the exact wording on my page.

3. Many customers with older cars (such as me) complained about the lag after updates. Initially, BMW even said they had done nothing. After they were proven wrong, they said: "yes, but you cannot notice". After two of their own technicians "noticed", a few of the BMW Munich development engineers took MY car in to investigate the matter and had to accept that not only one actually COULD notice the difference, but they could also measure the delay, which was WAY too big at ~600ms before boosting.

4. In a second attempt, they reduced the lag a little, but I (and others) could still feel it, such that in the final version of the software, they decided to have a little (i.e. unnoticeable for many people) lag per default, but with an option in ISTA/P to switch to the old completely lag-free version. However, if you choose to have the option activated, they will not acknowledge rattling complaints any more. This was in the updated SIB111307 from May 2009.
Apart from some cars right in the beginning, they never changed wastegate rods again, because that actually means changing the whole wastegates at a high labor (plus parts) cost.

Quote:
Originally Posted by Maestro View Post
You will need to know which software you car is running and I doubt it has the software which was affect since any maintenance done on the car since the issue showed up would have caused the dealer to update the software. My car was fine then they did this update as standard course of warranty and maintenance work and I immediately had the issue and was piss they update the software without my permission. I also doubt if you have full warranty car, this problem predates your car.
The software is one thing, the state of the ISTA/P wastegate option is another and the real rod hardware is the third. However, I think that with the old rods, after another few years of rod elongation, you will get rattles either way and you will have to change the wastegaste. This should fix the problem permanently, because they will be of the stronger type.

The most desirable version is having the ISTA/P option set to "no lag" and getting new wastegates (or at least rods).

Quote:
Originally Posted by Maestro View Post
I personally do not remember BMW ever acknowledging this was an issue, they just made a number of software updates to address various issues. Your car could have a lag issue for a number of reason now of which related to the software, Like all of us who dealt with this issue you just need to get the tech working on the car take it for drive and see what is happening.
They certainly did not want to acknowledge this, but if you challenge my story, you will find that all proveable facts fit in. Their covering-up on this matter is well documented in their own paperwork (i.e. TIS history).


BTS: Take this with a grain of salt as this is old news, they may have changed to software or the availability of the option in the meantime (ISTA/P has been replaced by something else, I imagine).
__________________

Last edited by meyergru; 09-16-2020 at 12:20 PM..
Appreciate 0
      09-17-2020, 11:17 AM   #4944
Prof3ssor
Second Lieutenant
Prof3ssor's Avatar
6
Rep
211
Posts

Drives: M340
Join Date: Aug 2008
Location: New Jersey

iTrader: (0)

This is a blast from the past. I guess I'm signed up for notifications. I wish I could add my .02 but from a legal standpoint, I am not permitted.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 10:56 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST