E90Post
 


Studio RSR
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > All-Wheel-Drive (Xi / xDrive) Talk > AWD trifecta issues



Reply
 
Thread Tools Search this Thread
      11-23-2021, 11:58 AM   #1
ezadel
Registered
0
Rep
3
Posts

Drives: 328xi wagon
Join Date: Nov 2021
Location: colorado springs

iTrader: (0)

AWD trifecta issues

Hello everyone:
I have been reading those forums for a while and finally decided to post. I have an E91 2008 328xi 120,000 miles ( recently bought)
I got the trifecta lights AWD, DSC, ABS
Got INPA and ISTA/D and got the following codes: 578E, 54C6, 55C3, 54C8, D104, 5F39, D904, E104 and E5C4
so I thought by replacing the transfer case servo motor and the transfer case and transmission fluids.
Here's what I am worried about I hear conflicting opinions about transmission and transfer case fluid changes.. some say that changing these fluids will ruin my transmission and transfer case (because I have the wear codes and they probably never been changed)...
should I change the fluids?
Any other advice on my codes/repair plan?
Thanks a bunch and looking forward to hear from you
Appreciate 0
      11-23-2021, 12:11 PM   #2
Brian86
First Lieutenant
Brian86's Avatar
291
Rep
395
Posts

Drives: e36 M3, e91 325xi, N50 Xterra
Join Date: Dec 2020
Location: Pittsburgh

iTrader: (0)

Changing fluids won't ruin anything. That's silly.

If it's worn out, it's worn out. New fluid or old.

I think there was some talk on the general forum about not resetting adaptation values on the transmission because it takes an eternity to re-learn, and the system will 'adapt' more swiftly than it will 'relearn'

This is probably correct. My engine took like 3 weeks to rev and drive right after I reset all the adaptations shortly after I purchased it and after doing a bunch of maintenance.

Transfer case adaptation resets are uneventful. You won't even notice it happening. They are required when changing mechanical parts otherwise the computer will continue to be angry with you.
__________________
Sometimes a bolt is just a bolt.
Appreciate 0
      11-23-2021, 12:15 PM   #3
ezadel
Registered
0
Rep
3
Posts

Drives: 328xi wagon
Join Date: Nov 2021
Location: colorado springs

iTrader: (0)

Thanks. I ll change both fluids the servo motor and hope for the best
Do I need Ista/F to readapt? or can I used ista/D or Inpa. What is the procedure for resetting Transfer case on ista/D
Appreciate 0
      12-01-2021, 09:26 PM   #4
ezadel
Registered
0
Rep
3
Posts

Drives: 328xi wagon
Join Date: Nov 2021
Location: colorado springs

iTrader: (0)

Help. I just changed servo motor and TF oil still has same error. I tried to rest the transfer case but ista D said function could not be perfomed without fault. Please help. I dont know what to do now
Appreciate 0
      12-09-2021, 10:41 AM   #5
andy_06xi
Second Lieutenant
58
Rep
210
Posts

Drives: 2006 330xi
Join Date: Nov 2006
Location: Boston, MA

iTrader: (1)

Could be a bad wheel sensor

A bad wheel sensor is a common problem and will cause this. Without a good scan tool -- it will be difficult to identify which one is the problem.

I used a Foxwell scanner to identify my problem and it correctly pointed to the left front sensor. Swapping a sensor is pretty straightforward. Sometimes the sensor ring develops rust and takes out the sensor -- so cleaning the sensor ring is a good idea as well.
Appreciate 0
      12-13-2021, 10:55 AM   #6
m_thompson
Major
m_thompson's Avatar
United_States
122
Rep
1,397
Posts

Drives: M-Sport 128i, 328xi, 3.0CS
Join Date: Jun 2008
Location: New England, USA

iTrader: (0)

Garage List
2009 128i  [0.00]
1972 3.0CS  [10.00]
Quote:
Originally Posted by andy_06xi View Post
A bad wheel sensor is a common problem and will cause this. Without a good scan tool -- it will be difficult to identify which one is the problem.

Sometimes the sensor ring develops rust and takes out the sensor -- so cleaning the sensor ring is a good idea as well.
We also had the lights on the dash. We cleaned the reluctor ring and replaced the ABS sensor. That fix lasted about two years. This time we had to replace the axle and the sensor. We used a GKN axle because it was 1/2 the price of one from the dealer.
__________________
'09 128i - Black Sapphire Metallic\Coral Red\Glacier Silver\N51 DISA\6MT\Navigation\Premium\M-Sport\Heated seats\Xenon\Headlights\iPod\Smartphone\Euro Delivery
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 05:46 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST